Windows 10: File Explorer shows "Working on it..." after Windows 10 upgrade

  1.    27 Aug 2016 #1

    File Explorer shows "Working on it..." after Windows 10 upgrade


    Since my free upgrade to Windows 10, I see the message "Working on it..." whenever I try to open My Computer/File Explorer. It stays this way for a few minutes and doesn't show the drives during this period. If try to click anywhere or close the window, then the window switches to "Not Responding".

    Other problems that I am seeing seem to be related (or not) are:
    1. Right-click menu takes a LONG time to appear when clicked on an icon.
    2. The "Open File" and "Save As" menu from inside any program also takes a LONG time to open (just like File Explorer). If I do try to click or try to close it, I again see the "Not Responding" message.

    I've been try to get rid of this problem since the upgrade, but no luck yet.

    Would anyone have a fix for it?

    See attached images for details (Faced the issue related to the "Open" option when browsed the PC to add these images).

    Click image for larger version. 

Name:	1.jpg 
Views:	6 
Size:	44.9 KB 
ID:	98350
    Click image for larger version. 

Name:	2.jpg 
Views:	6 
Size:	28.9 KB 
ID:	98351
    Click image for larger version. 

Name:	3.jpg 
Views:	5 
Size:	47.5 KB 
ID:	98352

      My ComputerSystem Spec

  2.    27 Aug 2016 #2

    This appears to be a bug some (not all) are experiencing related to the upgrade. Fortunately I don't..
    I guess this is one where MS is 'working on it' - comments suggest updates in Sept.

    You do have 10 days to roll back, and if you use Win 10 Pro, you can defer the upgrade.

    Otherwise you may wish to use other means of blocking updates.

    Meanwhile feel free to try checking for a 3rd party program conflict:
    - does it happen in Safe Mode?
    - after a clean boot?
    - if you disable context menu entries using Shellexview (free) - hide all MS entries, disable all others, noting the 32 bit option which reveals more.

    Thus you may be able to solve this.
    Last edited by dalchina; 28 Aug 2016 at 01:34.
      My ComputerSystem Spec

  3. AndreTen's Avatar
    Posts : 14,165
    Windows 10 (Pro and Insider Pro)
       27 Aug 2016 #3

    Hi Metalhead!

    Tray to "Unpin from Quick access" any network connection (that Google Drive). No guaranty it will help, just try.
      My ComputersSystem Spec

  4.    28 Aug 2016 #4

    AndreTen said: View Post
    Hi Metalhead!

    Tray to "Unpin from Quick access" any network connection (that Google Drive). No guaranty it will help, just try.
    @AndreTen maybe onto something , the 3rd pic reminds me of an issue I was having here (wasn't getting 1st or 2nd pic) on this desktop until I Enabled Netbios over TCPIP. In Win 10 the Default is Default but it doesn't seem to work on all PC's so you need to switch it to Enabled (below) Networking doesn't seem as fast on Win10 as Win7 but I can't tell if you have mapped network drives or anything like that from your images.

    Attached Thumbnails Attached Thumbnails 2016_08_20_02_47_231.png  
      My ComputerSystem Spec


Related Threads
Hi all, I have been searching the web for an answer to this question since first getting Windows 10 last year. I would like my File Explorer to open using the "List" view rather than the current default of "Details". I have seen many responses...
I decided to upgrade my PC from Win7 to Win10 before the free upgrade time expires. It has been a bit of a nightmare. After the upgrade completed I have no Internet Access. I know the hardware is good because when I revert back to my image of...
Hi, I upgraded to 10 from 7 as a download and I am occasionally losing right mouse function (start menu, task bar) and file explorer will not open ("working on it"). Restart fixes it for a while and sometimes it will work for hours and sometimes...
My "File Explorer" button in Start menu is not working. When I press on it nothing happens. Already tried: SFC/scannow, reboot, restart explorer.exe
I'm unable to use either File Explorer and This PC. I need to access my drives and can't get to them. I did sfc/scannow and it says unable to use it. I opened up Task Manager - New File-as Admin and tried to run sfc/ scannow. Says it can't find a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:15.
Find Us