1. Joined : Jul 2015
    Posts : 14
    Windows 10 Pro
       22 Jun 2016 #1

    Right Click context menu sloooow


    I am using Windows 10 Pro 64 bit OS on my self built system. It's been working great for years but recently I have notice when right clicking on any file in File Explorer or on the desktop it takes up to 30 seconds for the context menu to appear. I have read other posts about tweaking the graphic configuration or services. I have a Radeon R7 200 Series graphics card. I rolled back the most recent driver with no improvement. If I reboot it fixes the problem for a short while.
    I use the right click often and this is unacceptable. I am thinking of a clean reinstall but others have stated that it doesn't fix the problem.

    I'm wondering if a recent Windows update changed something that is causing this. Please help because this is a drag and I don't want to go through the reinstall unless absolutely necessary only to find out it doesn't help.
      My System SpecsSystem Spec


  2. Joined : Jul 2014
    San Jose, California
    Posts : 1,956
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       23 Jun 2016 #2

    Right click context menu should be almost instantaneous.
    If you have a long delay, it might be due to incompatible Shell Extensions. Try:
    Right Click on Desktop take long time to show up - Windows 10 Forums

    In addition, delay can be a cause if your HD/SSD is corrupted (run chkdsk /r) or if you have any USB device connected with Power Option to allow PC to turn off the device (Uncheck the option from Device Manager)

    If still does not fix the problem. Open Admin Command. Copy/paste then run:
    Dism.exe /online /Cleanup-Image /StartComponentCleanup&dism /online /cleanup-image /restorehealth&sfc /scannow&pause
    Last edited by topgundcp; 23 Jun 2016 at 12:10.
      My System SpecsSystem Spec


  3. Joined : Jul 2015
    Posts : 14
    Windows 10 Pro
       23 Jun 2016 #3

    Thanks for the help. I downloaded and ran the program and when I disabled all the pink highlighted extensions my context menu worked properly. My question now is: I re-enabled the extensions and each time I restarted explorer from the options menu. I'm not sure if restarting explorer by itself solves the problem temporary. Before I tried this fix I noticed that upon reboot the context menu worked properly for some time and then degraded, so I'm wondering if I have to wait after re-enabling each extension to see if the problem reappears. Hopefully this makes some sense. Your comments are greatly appreciated.

    Thanks

    John
      My System SpecsSystem Spec


  4. Joined : Jul 2014
    San Jose, California
    Posts : 1,956
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       23 Jun 2016 #4

    Enable one by one is just to isolate and identify which extension is causing problem. Restart Explorer so that it will refresh its shell extension settings. You might want to perform each step slowly by enabling one then try for a while to see if it causes any problem.

    It also would not hurt to run chkdsk and run DISM command to ensure that you don't have any corrupted system files.

    In addition, you can also tweak the Registry to make the context menu popup faster by creating a file with .reg extension and copy/past the code below, double click to merge into the registry:
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "MenuShowDelay"="1"
    
    [HKEY_USERS\S-1-5-19\Control Panel\Desktop]
    "MenuShowDelay"="1"
    
    [HKEY_USERS\S-1-5-20\Control Panel\Desktop]
    "MenuShowDelay"="1"
    
    [HKEY_CURRENT_USER\Control Panel\Mouse]
    "MouseHoverTime"="1"
    
    [HKEY_USERS\S-1-5-19\Control Panel\Mouse]
    "MouseHoverTime"="1"
    
    [HKEY_USERS\S-1-5-20\Control Panel\Mouse]
    "MouseHoverTime"="1"
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Right click often has blank context menu or partials?
I'm running Windows 10 x64.. with very little installed outside of Office 2013 and Visual Studio 2015. Every once in awhile I run into a situation where my right clicks no longer result in a context menu being visable.. at least mostly.....
General Support
Pin/Unpin is missing from right click context menu
Hi guys I reinstalled windows 10 on my laptop and after that the pin/unpin options is missing from the context menu (right click) to pin/unpin tiles from the startmenu. Any ideas?
General Support
Black Context Menu for Taskbar and Old Context Menu for Desktop
Hello. Today I got an update, and I noticed afterwards that the Windows 10 context menu when you right click the desktop went back to the old version and not the Windows 10 version. Also, the context menu for right clicking in the taskbar turned...
Customization
"Open with" Right click context menu lacks browse for program option.
Trying to figure this out in Windows 10. I have a file on my system, and windows doesn't yet know what program to open it with. When I right click the file and select "open with", the dialogue is quite different. Now I no longer have the option...
General Support
Solved New update right click (context menu) is way too big.
i noticed like 2 updates ago that the new context menu size increased so much. now i have to scroll to see the bottom just to see proprieties and rename. its annoying id like the old context menu, is there a way to get the old menu back?
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:04.
Find Us
Twitter Facebook Google+



Windows 10 Forums