Windows 10: Win10 or MalWareBytes issue?

  1.    12 May 2016 #1

    Win10 or MalWareBytes issue?


    A little over a month ago I bought the latest version of Malware Bytes (also installed Anti-Ransomware). Since then I've noticed that my system hitches, stammers or hesitates, very briefly, when certain programs are loading (including FireFox and VLC player or Not Responding messages). Also, since I've had Win10 and friends have had the same issues, when we go to certain secure sites we have to re-enter our information twice.

    In other words I'll put in a username and password for a particular site, hit login and the login page just refreshes and requires the login again. I've done some basic hardware checks to eliminate that as a possibility of the hesitation. Any suggestions would be appreciated.
      My ComputerSystem Spec

  2.    13 May 2016 #2

    That's price you pay for higher security with resident security programs. I order to protect they have to insert themselves between your system and the source of potential threat. Whatever you do they have to check it first.
    How much you notice them depends on computer's "power", internet speed and how many of them run at same time.
      My ComputersSystem Spec

  3.    13 May 2016 #3

    How much ram do you have? How old is the computer?
      My ComputersSystem Spec

  4.    13 May 2016 #4

    CountMike said: View Post
    That's price you pay for higher security with resident security programs. I order to protect they have to insert themselves between your system and the source of potential threat. Whatever you do they have to check it first.
    How much you notice them depends on computer's "power", internet speed and how many of them run at same time.
    Very true. I ended up reloading the software that was having issues and they seem to working a lot better.

    swarfega said: View Post
    How much ram do you have? How old is the computer?
    I have an i7 960, 3.2Ghz, 12g of RAM.
      My ComputerSystem Spec

  5.    14 May 2016 #5

    Could be also a slow disk.
      My ComputersSystem Spec


 

Related Threads
Hi Guys, Thanks for reading. I have got this problem: My taskbar is out of place when I connect the second monitor. I extended the view. 61030
Solved Is Windows defender and Malwarebytes pro enough? (Win10) in AntiVirus, Firewalls and System Security
I'm just curious if Malwarebytes coupled with Windows defender is enough. I would like to add I use the internet quite a bit so I would like solid protection. I know windows defender doesn't have the BEST detection rate but I would hope...
First off, the part of my setup that the following pertains to: Windows 10 (x64) NVIDIA GeForce GT 730 (drivers are current march 2016) Mitsubishi MEUSPTV11 (73.2"vis, March 2009) Insignia NS-HTIB51A Microsoft Basic Display Adapter (No...
Can anyone help me to solve the problem on desktop auto power on? Few days ago I just upgraded my desktop to Win 10 pro 64bit, it was fine until tonight, I tried to shut down the PC, it did actually powered off everything just for about a min., the...
Hi all, I've got a strange issue that I'm not getting information about online. I upgraded my Win8.1 to Win10 last week and found that on reinstalling certain apps to Win10 compatible versions that the web installer files didn't want to connect to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:17.
Find Us