Windows 10: Attempting to enable .net framework and Dism does nothing

  1.    12 May 2016 #1

    Attempting to enable .net framework and Dism does nothing

    I just upgraded to Windows 10 x64 today and I am attempting to get everything back up and running the way I like it. I've run across a problem where several things I'm attempting to install are requiring .net framework 3.5 to be enabled. I have now tried this through letting the program attempt to do it, enabling it manually in windows, and using the Dism command in tandem with my win10 USB.

    Everytime I try to enable it I get the pop up that eventually gets stuck at searching for required files, or downloading required files. which I can't close outside of killing it in task manager. I have tried rebooting to no success. When I try using cmd and the Dism command it returns the following and stops doing anything.

    "Deployment Image Servicing and Management toolVersion: 10.0.10586.0

    Image Version: 10.0.10586.0"

    The cursor moves to the next blank line but does not give me the ability to type anything. This problem has passed the point of being frustrating any help would be greatly appreciated.

    For clarification the Dism command I'm using is: "C:\Windows\system32>Dism.exe /online /enable-feature /featurename:NetFX3 /source:H:\x86\sources\sxs /LimitAccess"
      My ComputerSystem Spec

  2. TairikuOkami's Avatar
    Posts : 3,419
    10.6 Home 1809 x64
       12 May 2016 #2

    Bowiie said: View Post
    I just upgraded to Windows 10 x64 today
    Upgrade usually cause problems, you better do a clean install or at least reset.

    How to refresh, reset, or restore your PC - Windows Help

    You could try those command, in this order, maybe they will help.

    chkdsk /scan
    fsutil usn deletejournal /d /n c:
    Dism /online /Cleanup-Image /RestoreHealth
    sfc /scannow
    Dism /Online /Cleanup-Image /StartComponentCleanup /ResetBase
    winmgmt /salvagerepositorycleanmgr /sageset:65535 & cleanmgr /sagerun:65535
      My ComputerSystem Spec

  3.    12 May 2016 #3

    Sorry poor choice of words on my part, it was a fresh install on a just out of the box SSD.

    Following your commands chkdsk returns no errors and as soon as I put in the Dism command same problem occurs.
    Click image for larger version. 

Name:	dism.PNG 
Views:	2 
Size:	32.2 KB 
ID:	79390
      My ComputerSystem Spec

  4.    12 May 2016 #4

    AskVG is usually reliable:


    Cant install .net 3.5 on Windows 10 - Super User
    Have you tried the first answer here?

    Clearly this is an issue that has affected a few - reports from Win 8 on at least. But it's not one I've seen on tenforums yet..

    This (about Win 8.1) may suggest a way forward with respect to Windows 10 updates already installed.
      My ComputerSystem Spec

  5. JohnC's Avatar
    Posts : 3
    Dual Boot 10 Pro v1607 10 Pro rs2 build 14971
       12 May 2016 #5

    See if this helps. .net 3.5 Feature Fails to Download - Windows 10 Forums . He is using the insider build, but the Microsoft page is a general solution not just for an insider build. Also the Dism command structure is slightly different than the OP posted.
      My ComputerSystem Spec

  6.    13 May 2016 #6

    So after much digging through pretty much everything I've found what may be the problem. I saw in one of the links some mentioned using the Add a Feature option under Optional features, so I tried that, but when I click on Add a Feature it shifts fo a screen with the header Optional Features and a loading icon below it and stays there. I had also read where someone mentioned that there is a group policy that may block me from enabling features, and that if I could disable that policy then it might work.

    Well I've run into yet another problem (isn't that how this goes) namely that I have the home version of Win 10 so no group policy editor, of course. I looked online and found a download for the policy editor which I grabbed and tried to install, but wouldn't you know it, it requires .net framework 3.5....and we've come full circle.

    Also I tried the different Dism structure and same thing happened, which is nothing.

    Question now being would I have that policy even being on a home version? If so any idea how I could find it in the registry, because I don't have a way to get gpedit going at this time.
      My ComputerSystem Spec

  7.    13 May 2016 #7

    Try this, noting the warning. Take due precautions. Said to work in '10
    How to Enable (gpedit.msc) in Home and Starter Editions of Windows 7 and Later - AskVG
      My ComputerSystem Spec

  8.    13 May 2016 #8

    Thats where I was when I said I tried it earlier. When you download and run the installer it tells you it requires .net framework 3.5 so I can't really do that.
      My ComputerSystem Spec


Related Threads
Hey, i'm getting a KERNEL_SECURITY_CHECK_FAILURE BSOD shortly after or by execution of the win10 version of handbrakeCLI (uses x264 encoder). In compability mode (win7) it seems to work. I updated the drivers before the last bluescreen (from...
hello everyone. i had a pop up telling me that i have a Windows update pending and that it would run when i restarted my laptop. But, when it started, i noticed that it was reinstalling Windows 10 - which i have been running for the last...
Hello, I've run into a problem where my windows apps will not open. Calc opens with a gray screen just showing the calculator logo...calendar opens to a blue screen only showing the calendar logo, etc. I can't run SFC /scannow due to error...
The computer won't automatically sleep any longer after 20 minutes. When I manually put it to sleep, it all sleeps; however, it won't wake up. Instead, when I move the mouse, I hear the fans engage for <1 second and then all peripherals go dark and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:24.
Find Us