Page 1 of 2 12 LastLast
  1.    16 Apr 2016 #1
    Join Date : Apr 2016
    Posts : 5
    10 64bit

    Bootmangr is missing error, only if i try and get in to the bios.


    This is driving me nuts.
    Im trying to get in to the bios (F2 or Del) so i can change the password. When hitting any key on the keyboard i get an error that Bootmangr is missing, and to re start my PC. If i dont try and get in to the bios Windows starts fine.
    This is not random, its happening every time. I do have a password on the PC, and can enter that fine, but its just a user password which i need to change.

    Iv never seen this happen in all my PC years, and while its not the end of the world i know its something that isnt right and will cause me issues later on.
    The fact that Windows starts fine if i leave it to its own devices is the confusing part, as it means Bootmangr isnt missing or corrupt.
    My thoughts are that by pressing a key down i might be causing the HDD to delay starting, and so giving me this error. Just a guess though.

    Formatting and re installing answers are going to be helpful, as im not going to do this. Its always easier said than done. I need to figure out what the issue actual is, in case it happens again.

    System is running Windows 10 64 bit, and its been working fine since Win 10 came out.
    Ive done a start up recovery and no errors have been found.

    Cheers for any help.

    Dave.
      My ComputerSystem Spec
  2.    16 Apr 2016 #2
    Join Date : Apr 2015
    Posts : 12,999
    W10Prox64

    Hi fliplip and welcome to Tenforums.
    It may help people to help you, if you fill in your system specs, so we know what kind of BIOS we're dealing with.
    Thanks!
      My ComputerSystem Spec
  3.    16 Apr 2016 #3
    Join Date : Apr 2016
    Posts : 5
    10 64bit
    Thread Starter

    Thanks for the welcome. I'm about 200 miles away from my PC so that's why the profile is as it is. All I can remember is its a 3 year old Asus MoBo. Can't fill the info in until Monday.
      My ComputerSystem Spec
  4.    16 Apr 2016 #4
    Join Date : Aug 2014
    Forever West
    Posts : 3,986
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Is it BIOS passwords you want to change [there's 2 possibles] or the Windows login password? The BIOS can be set to first keep the computer booting to the OS/Operating System and the second is to prevent any changes to the BIOS settings including the other password. The BIOS passwords are not in much consumer use but are somewhat favored in businesses where more people would have access.
      My ComputerSystem Spec
  5.    16 Apr 2016 #5
    Join Date : Apr 2016
    Posts : 5
    10 64bit
    Thread Starter

    Thanks.

    I have two bios passwords set, one is a user setting that locks the PC, the other is the bios admin password. My son found out the user password so I just want to change that. Ive used this method for years and it's only just stopped working over the past week.
    The issue is I can't get in to the Bios, due to Windows failing if I hit a key on the keyboard to access the bios.
    I have no trouble entering the user password, as that's the first screen that comes up when the computer is turned on.

    I'm wondering if I should just do a system restore first to make sure it's not Windows causing any issues.

    I hope that makes sense.

    Im not a novice, I've been building all my own PC's for about 20 years, but do admit I'm not an expert either.

    Dave.
    Last edited by fliplip; 16 Apr 2016 at 13:38.
      My ComputerSystem Spec
  6.    16 Apr 2016 #6
    Join Date : Aug 2014
    Forever West
    Posts : 3,986
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Most of my computers don't use UEFI so they boot to the BIOS process which all occurs before the OS loads. If I can't get into those BIOS' I can't boot the computer.
      My ComputerSystem Spec
  7.    16 Apr 2016 #7
    Join Date : Oct 2013
    NW Florida
    Posts : 9,718
    Windows 10 Pro and Windows 10 Pro Insider

    fliplip, I want to make sure I understand. You can enter the user password to enter the OS with no problem. But you cannot enter BIOS? Is that correct? I know you said you have been building computers for quite awhile, but are you sure you are entering the BIOS boot key at the proper time? I ask because, it is my understanding that at startup the BIOS goes through the initialization then turns the boot process over to the hard drive. You enter BIOS before the process turns it over to the hard drive. So, the problem, as I understand it, cannot be the OS because the BIOS entry is made before the OS becomes involved. Therefore I would suspect a problem other than the OS.

    What type of keyboard do you have? Could it be the issue? Here is a solution you may try, assuming you have a UEFI Bios.
    https://www.tenforums.com/tutorials/5...dows-10-a.html. I don't believe it will work with a legacy bios, but it may be worth a try.
      My ComputersSystem Spec
  8.    16 Apr 2016 #8
    Join Date : Apr 2016
    Posts : 5
    10 64bit
    Thread Starter

    Thanks again for the replies.

    First off, thus has been working perfectly on this PC for about 3 years, with Windows 7, 8 and now 10, and I've had other PC's that I do this with. I know when and how to hit the relevant keys, and have no issues with entering the bios password to allow the PC to hand over to the OS so it boots ok. Letting it do this works fine 100% of the time.
    Once the password has been entered I see a screen that shows the MoBo name and at the bottom is a line of text that says hit F2 one Del to enter Bios. Normally doing this, at this time will evoke a new password box, and once the correct password is entered I get in to the Bios set up screens.
    At the moment if I hit either of those keys on the keyboard (I've also tried another keyboard), I get the Bootmangr file missing error, and i have to reboot. This makes no difference, same options/error depending on what I do.

    Unfruatlualy I don't have a UEFI bios boot option under Advanced start up settings.

    I too can't see how it's a OS issue, BUT it's Windows that is complaining it can't find the boot file. As I know the Bios hasn't changed I can only assume something in the OS is causing this.

    Possible that the C: drive is stalling when I press a key maybe?
      My ComputerSystem Spec
  9.    16 Apr 2016 #9
    Join Date : Oct 2013
    NW Florida
    Posts : 9,718
    Windows 10 Pro and Windows 10 Pro Insider

    I was not trying to make it sound quite like it did when I made that suggestion. I was simply trying to "logic" it out. I don't recall ever hearing of a problem like this before. I thought I had encountered every possible problem that could happen, but obviously not.

    I have had both Legacy and UEFI installs on this computer at different times. It does not matter which, the process for entering the BIOS is the same, although I don't use passwords.
      My ComputersSystem Spec
  10.    16 Apr 2016 #10
    Join Date : Apr 2016
    Posts : 5
    10 64bit
    Thread Starter

    No offence taken, I too have never seen this happen before. Normally I can figure these things out, but not this as I've not seen it happen before. I'm just not sure where to look. I could re set the bios by taking the battery out and shorting it out, but as this is post bios I'm not sure that would help.
    ill post back if I do figure it out, but I can't do anything until Monday when I'm back home.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
NSI registry error for missing protocols
So I'm having a bit of an issue connected to the Internet. By using netsh int ip reset. It seems that the folder containing the registry for 26 is causing it to becoming inaccessible and gives me an error every time I try and acess it. Is there a...
Network and Sharing
error 0x9f, ACPI - will BIOS update fix?
Hi @essenbe Have attached the collector per your request. Hoping there's nothing here and the BIOS update will fix it? Thanks. :)
BSOD Crashes and Debugging
Help! Laptop crashed, boot media missing, and BIOS can't detect drive.
Please, help. My laptop suddenly crashed and now it says "Boot media missing" when I restarted. After that, it always takes me to "Preparing Automatic Repair" and then the 'Troubleshoot' menu. In the 'Troubleshoot' menu, it has two options:...
General Support
Solved Backup error, some files missing
Mods, if there's a better sub forum for this please move it and thank you :) tenforums doesn't have a backup and restore forum yet. The problem is when I do a backup, I get an error message "The backup completed but some files were skipped" I've...
Backup and Restore
Bootmgr missing error
Has anyone figured out why this happens? I rolled back to 7 Pro because non of the fixes worked. This is an error in all my years using Windows i've never seen. And one fix had you put in your Win7 cd. But in the partition no OS shows up. The only...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums