Windows 10: Win 10 taking a really long time to boot Solved

  1.    23 Mar 2016 #1

    Win 10 taking a really long time to boot


    I have a Dell Inspiron 3531 with the Windows 10 free upgrade (Home edition) and an Intel Celeron N2830. Since a couple of days, my laptop is taking a really long time to start up.

    After it powers on, there is a blank screen for 1-2 minutes before the Dell logo and loading circle appears. The loading screen doesn't take a long time and the logon screen comes up pretty quickly, but I'm just concerned about what is happening right after I press the power button. There is a blank screen for far too long (no cursor, ctrl-alt-del doesn't work, nothing.)

    The Task Manager says the last BIOS time is anywhere from 60-90 seconds (I got different times throughout the last few days). I have updated all drivers and turned on Fast Startup. Any other suggestions/help would be much appreciated!
      My ComputerSystem Spec

  2.    23 Mar 2016 #2

    My guess is that your Bios may be upset about a piece of hardware. I would try disconnecting everything, including a second hard drive if you have one installed (remove the mouse and keyboard too). If the problem goes away, start installing the disconnected devices one at a time until you find the guilty device.
      My ComputerSystem Spec

  3.    23 Mar 2016 #3

    socklosk said: View Post
    My guess is that your Bios may be upset about a piece of hardware. I would try disconnecting everything, including a second hard drive if you have one installed (remove the mouse and keyboard too). If the problem goes away, start installing the disconnected devices one at a time until you find the guilty device.
    Now that you mention it... I use a USB wireless adapter instead of the built-in one, and that has been malfunctioning on and off for about the same time as the boot problem has been happening. I got a shiny new USB adapter today and it's working great. I'll try to boot up later tonight or tomorrow morning and see how it goes.

    Thank you!
      My ComputerSystem Spec

  4.    24 Mar 2016 #4

    Got it!


    It was the faulty USB adapter. I now have no blank screen after powering on and the BIOS time is down to 3.9 seconds!

    Thanks again!
      My ComputerSystem Spec


 

Related Threads
last time after update 1511 i tried restarting my laptop was 1 hour please help me
Windows 10 taking too long to boot in Performance & Maintenance
I know there are several threads by this name, but my problem, as far as I know, is quite peculiar and I haven't seen anything similar to this in any thread. Yesterday I did a clean install (actually I wiped the whole hard drive and converted it to...
So, I've encountered this issue lately where Windows 10 takes considerably longer to boot than before. (Usually 4 to 5 minutes) It used to boot under 30 seconds before so I don't know what went wrong here. So, the screen with the Windows logo...
Hi, folks. Everytime I press the rest button in my case and Windows (is supposed to) load, after Windows 10 icon, it gets black. Once it got black for a looong time and I had nothing more to do than reset settings. So, I lost all my applications...
Unusually long boot time in Drivers and Hardware
I can't quite get a handle on this issue. Why would having USB drives attached to system increase boot time from 8 seconds to 110 seconds? Never happened on old 560 box, but does on new 3847. Dell says, "That's the way it is". Sounds odd....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:05.
Find Us