Win 10 taking a really long time to boot


  1. Posts : 10
    Windows 10 Home
       #1

    Win 10 taking a really long time to boot


    I have a Dell Inspiron 3531 with the Windows 10 free upgrade (Home edition) and an Intel Celeron N2830. Since a couple of days, my laptop is taking a really long time to start up.

    After it powers on, there is a blank screen for 1-2 minutes before the Dell logo and loading circle appears. The loading screen doesn't take a long time and the logon screen comes up pretty quickly, but I'm just concerned about what is happening right after I press the power button. There is a blank screen for far too long (no cursor, ctrl-alt-del doesn't work, nothing.)

    The Task Manager says the last BIOS time is anywhere from 60-90 seconds (I got different times throughout the last few days). I have updated all drivers and turned on Fast Startup. Any other suggestions/help would be much appreciated!
      My Computer


  2. Posts : 157
    Windows 10 Home 64-bit
       #2

    My guess is that your Bios may be upset about a piece of hardware. I would try disconnecting everything, including a second hard drive if you have one installed (remove the mouse and keyboard too). If the problem goes away, start installing the disconnected devices one at a time until you find the guilty device.
      My Computer


  3. Posts : 10
    Windows 10 Home
    Thread Starter
       #3

    socklosk said:
    My guess is that your Bios may be upset about a piece of hardware. I would try disconnecting everything, including a second hard drive if you have one installed (remove the mouse and keyboard too). If the problem goes away, start installing the disconnected devices one at a time until you find the guilty device.
    Now that you mention it... I use a USB wireless adapter instead of the built-in one, and that has been malfunctioning on and off for about the same time as the boot problem has been happening. I got a shiny new USB adapter today and it's working great. I'll try to boot up later tonight or tomorrow morning and see how it goes.

    Thank you!
      My Computer


  4. Posts : 10
    Windows 10 Home
    Thread Starter
       #4

    Got it!


    It was the faulty USB adapter. I now have no blank screen after powering on and the BIOS time is down to 3.9 seconds!

    Thanks again!
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:15.
Find Us




Windows 10 Forums