Windows 10: regedit crashes when searching Solved

  1.    18 Mar 2016 #1

    regedit crashes when searching


    On one of my Win10 systems regedit crashes on any search I try. Sometimes it will find a match but then continuing the search for another instance will eventually lead to a regedit crash. The symptom is that regedit looks active and the task manager shows that it is using 25% of the cpu but it never completes. So at this point it hasn't actually crashed. Clicking "Cancel" to cancel the search brings up a windows error message claiming that regedit has crashed. An AppCrash..... file is created. Maybe it is just stuck in a loop and the Cancel makes windows think it has crashed?

    Makes me think there is an issue with the registry but the system has been running this way for some months and seems normal.

    Suggestions?

    -- Larry
      My ComputerSystem Spec

  2.    18 Mar 2016 #2

    A well-known bug for which there is a long thread here. This happens if a key exceeds a certain maximum length. Workaround= use a 3rd party registry editor (free) which have the advantage of the equivalent of an address bar.
      My ComputerSystem Spec

  3.    19 Mar 2016 #3

    Yep, a 3rd party registry editor searches just fine. Thanks for the info.
      My ComputerSystem Spec

  4.    03 Jun 2016 #4

    I have versions of the x86 and x64 regedit from Windows 10 enterprise version 10240 that work just fine. PM me if you want them.
      My ComputerSystem Spec

  5.    04 Jun 2016 #5

    dcol, Thanks for the offer but I don't need them. It may be hard to know if regedit works just fine in all cases. My Win 10 versions worked just fine until they encountered a specific condition in the registry. See post #2 in this thread.
    --Larry
      My ComputerSystem Spec

  6.    04 Jun 2016 #6

    Ok Larry. The earlier version doesn't have that bug.
      My ComputerSystem Spec


 

Related Threads
Hello. A few days ago I have found out the Regedit crashes on me while performing a search. Running w10 x64. I have run sfc /scannow and it said there were no integrity violations. Any ideas? PS - It even crashes if I hit the CANCEL...
adamax keylogger - regedit will not run in AntiVirus, Firewalls and System Security
Hit by some ugly malware that seems to prevent me from running regedit or malwarebytes. gangnamgame.net pops up after a reboot as well as adamax keylogger.When I try to run either one of them nothing at all happens. No errors, no window or anything....
When I bring up the run command (Win+R) and enter regedit or regedit.exe. It does not open. If I enter C:\Windows\regedit.exe, it opens. All other exe files in the windows directory opens fine except for regedit. Windows and System32 folders...
Hello. First of all, I don't want to start a flame war or something about "why would anyone want to disable Superfetch" and such. As gamer I like to run Windows with Superfetch off. It's just a subjective matter of taste. Anyway back on topic:...
Solved regedit changes in General Support
Made a change in HKLM, so that my numloc keys worked on start-up, previous version. Upgraded via update to 10166, Be advised for this change to become effective had to restart comp again. I know its SOP for reg changes but, on an upgrade. SO...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:03.
Find Us