Windows 10: DISM lacking Package Manager commands (Cleanup-image) Solved

  1. Posts : 2
    Windows 10 Professional
       13 Mar 2016 #1

    DISM lacking Package Manager commands (Cleanup-image)

    Hello everyone,

    I seem to have some serious problems with my Windows 10 Build 10.0.10586.113. These started after trying to take Ownership of C:/ (where I installed Windows). I tried this because on several occasions trying to move/copy files in different directories I could not do it (ownership problems seem to be not unusual after upgrading from Win 8). When trying to take ownership of C:/ and all its subdirectories I got several error messages ("Acess denied"). At first I just skipped them, but there where so many my finger just got tired (and it also seemed that something was going wrong). I downloaded a .reg which adds the option "Take Ownership" when right-clicking on a folder. Using this added my user account (with administrator rights) to the security options for the folders but the checkboxes were all empty. However I now could restart the procedure I tried before and this time there were no "Acess denied" errors and afterwards all checkboxes were filled with full acess (and all other options).

    For a couple of days all seemed to work fine.

    Yesterday I tried to open an *.jpg file and the usual W10 app would not be able to open it anymore. Same when trying to open a pdf using edge. So something was wrong with the apps. All the apps (like calculator, store etc.) just immediately crash. Of course I tried several troubleshootings for this known problem. Nothing worked.

    Now I'm trying to repair my system using DISM or an inplace-upgrade.

    After spending the last two days trying to fix these problems, I'm kindly asking for your help.

    1) I cannot run any of the DISM commands required to repair my Windows build like e.g.
    Dism /Online /Cleanup-Image /RestoreHealth
    Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:C:\sources\install.wim:1 /limitaccess (using the install.wim from the latest .iso and for esd the latest build from Media Center respectively)
    Same with ScanHealth etc.

    I am getting Error 87: cleanup-image unknown
    Dism /Online /? lacks the Package Manager commands like Cleanup-Image

    2) After running SCF /Scannow the first time it said: no corrupted files. Immediately starting Dism /Online /Cleanup-Image /ScanHealth works and reports no problems.
    Opening a new cmd and restarting Dism /Online /Cleanup-Image /ScanHealth gives Error 87: cleanup-image unknown again

    3)Trying to do an inplace upgrade with the latest .iso as well as with the Media Center gives me an error during initializing the setup (at 25%); A problem occured. I can just click "OK" here and it stops.

    4) Mounted an offline image with dism /offline and used the dism folder of this mounted build to replace it with my own Dism folder in System32 (maybe stupid, but I thought it could repair any corrupted Dism files)

    5) If I now run SCF /Scannow "some corrupted files could not be repaired"
    Log file attached.

    Please help me to get either Dism /online /Cleanup-Image or the inplace upgrade running!
    As I use a Windows build with German language I tried to translate the error messages. If something sounds weird just ask.
    I cannot attach the DISM.log. It's over 9 MB...
    DISM lacking Package Manager commands (Cleanup-image) Attached Files
      My ComputerSystem Spec

  2. Posts : 2
    Windows 10 Professional
    Thread Starter
       23 Mar 2016 #2

    Thank you for your kind help.
      My ComputerSystem Spec


Related Threads
Hi there If any of you are installing some LINUX distros as VM's I recommend if you decide on CENTOS 7 to install YUMEX - a graphical package manager. 67192 Add the nux-dextop repo to your repositories -- this is a Windows Forum so I won't...
Simply, why doesn't Dism /Online /Cleanup-Image /RestoreHealth work in Windows 10? Is there a way to get this or a similar command to self repair your installation in Windows 10? 48645
I am running the "combined command" as below at the moment. Is it OK to continue to continue to use my PC while the commands are running? When I say "use" I'm mainly talking about web browsing.
Hello I have a laptop that I took the HDD out of and connected it to another Windows 10 machine. I ran the command Dism /Image:e:\ /Cleanup-Image /RestoreHealth but get the error Deployment Image Servicing and Management tool Version:...
Hi there I know this is a WINDOWS Forum but if there are decent things to take from other OS'es shouldn't Windows at least look at them. One thing that Windows perhaps could look at is to devise a SENS IBLE software package manager for...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:36.
Find Us