Page 1 of 4 123 ... LastLast
  1.    10 Feb 2016 #1
    Join Date : Oct 2014
    Posts : 73
    Windows 10 Home

    Occasional high CPU usage on Windows 10


    Hi,

    I have recently noticed a bit of a performance issue on my HP laptop running Windows 10 Home.

    What happens is, if I am not doing anything on the laptop, but am not putting it to sleep (i.e. idling), it stays at a low CPU usage. However, after a while (usually about a minute?), the CPU usage rockets up, and also affects my CPU temperatures (goes up from ~35'C to ~50'C).

    The processes that are the culprit, as defined by the detailed tab of Task manager, are either "svchost.exe" or "System" - the latter is described as "NT Kernel and System" and is linked to ntoskrnl.exe.

    Any way of controlling this would be greatly appreciated.

    Note: the laptop came preinstalled with Windows 10 and doesn't have many programs installed.

    Spotify95
      My ComputerSystem Spec
  2.    10 Feb 2016 #2
    Join Date : Nov 2015
    Posts : 299
    Win-10 Pro x64

    Hi spotify95,

    Have a look at the below link and see if there's anything that might be of some help.
    Windows 10: How to fix system ntoskrnl.exe memory leak and high CPU usage

    b1rd
      My ComputerSystem Spec
  3.    10 Feb 2016 #3
    Join Date : Oct 2014
    Posts : 73
    Windows 10 Home
    Thread Starter

    Quote Originally Posted by b1rd View Post
    Hi spotify95,

    Have a look at the below link and see if there's anything that might be of some help.
    Windows 10: How to fix system ntoskrnl.exe memory leak and high CPU usage

    b1rd
    Hi, thanks for the informaion.

    I have just set McAfee to do a scan of the computer and I'll see what that brings up.

    Failing that, I'll look at drivers, then Runtime Broker. I think that the Windows 10 tips thing still comes up, which I don't really need. I doubt it's the drivers though, because all of the drivers for the machine are installed and Windows Update updates any drivers when required.

    Note: this only happens about 1 minute or so after my activity, i.e. it is idling. I have noticed that, the instant this happens, the CPU spikes to 100% (with svchost using some CPU as well) before settling to 25% usage; the culprit being "System".

    edit: McAfee has scanned my "C:" drive (Windows 10) without any issues. It's scanned drive F:\ (my windows 7 partition, this is dual boot) and found 1 potentially unwanted program, which I will discuss tomorrow. Driver Booster (from IoBit) has found outdated drivers, which I will install.
    Last edited by spotify95; 11 Feb 2016 at 16:26.
      My ComputerSystem Spec
  4.    10 Feb 2016 #4
    Join Date : Nov 2015
    Posts : 299
    Win-10 Pro x64

    Another semi-long shot might be one of the Start-Up programs. I did see that you don't have many programs installed, but it might be worth a look anyhow, as something is working your processor.

    If you're unfamiliar, right-click the taskbar and bring up the Task Manger. Hit the Start up tab. Those are the programs that load when Windows starts. You can disable one at a time by right-clicking them (make sure it's actually off) and check things.

    Again a long shot, but sometimes some programs can cause conflicts. I would specifically look at any security software you have running, and test it without the software running. You can always active Windows Defender if you're concerned about the temporary lack of security if you decide to try this.

    Also, perhaps take a quick peek at the Reliability Monitor/History and see if anything jumps out.

    b1rd
      My ComputerSystem Spec
  5.    10 Feb 2016 #5
    Join Date : Jan 2016
    Henderson
    Posts : 147
    Windows 10 Pro

    Quote Originally Posted by spotify95 View Post
    Hi, thanks for the informaion.

    I ahve just set McAfee to do a scan of the computer and I'll see what that brings up.

    Failing that, I'll look at drivers, then Runtime Broker. I think that the Windows 10 tips thing still comes up, which I don't really need. I doubt it's the drivers though, because all of the drivers for the machine are installed and Windows Update updates any drivers when required.

    Note: this only happens about 1 minute or so after my activity, i.e. it is idling. I have noticed that, the instant this happens, the CPU spikes to 100% (with svchost using some CPU as well) before settling to 25% usage; the culprit being "System".

    edit: McAfee has scanned my "C:" drive (Windows 10) without any issues. It's scanned drive F:\ (my windows 7 partition, this is dual boot) and found 1 potentially unwanted program, which I will discuss tomorrow. Driver Booster (from IoBit) has found outdated drivers, which I will install.
    Hey Spotify, HP owner here and what I did was uninstall most of the HP stuff, especially the support assistant and HP framework (do it from programs and features). Update the graphics driver. Let the system find and install the correct driver from intel. Every single problem I had, including high cpu disappeared. Have been running 2 months now flawlessly.
      My ComputerSystem Spec
  6.    11 Feb 2016 #6
    Join Date : Oct 2014
    Posts : 73
    Windows 10 Home
    Thread Starter

    Update: I tried turning off the notifications about help with Windows 10 (the 3rd thing in the original article), result? No improvement!

    Anything else to try before I try the Startup programs? (I will post a screenshot of my start up programs on that machine, that way you can help to see what is the problem.) Don't think it's McAfee causing the issue.
      My ComputerSystem Spec
  7.    11 Feb 2016 #7
    Join Date : Oct 2014
    Posts : 73
    Windows 10 Home
    Thread Starter

    Quote Originally Posted by AnEdge View Post
    Hey Spotify, HP owner here and what I did was uninstall most of the HP stuff, especially the support assistant and HP framework (do it from programs and features). Update the graphics driver. Let the system find and install the correct driver from intel. Every single problem I had, including high cpu disappeared. Have been running 2 months now flawlessly.
    Hi,

    I have updated all of the outdated drivers via IOBit Driver Booster. No improvement, but I do have nice new drivers

    HP Support Assistant is installed on a windows 8.1 laptop which doesn't have this issue, and it is also on the Windows 7 partition of this laptop, also without issue.

    Maybe the HP Framework is to blame?
      My ComputerSystem Spec
  8.    17 Feb 2016 #8
    Join Date : Oct 2014
    Posts : 73
    Windows 10 Home
    Thread Starter

    Hi guys,

    The issue is still present (it is fine on my windows 7 partition) - any ideas?

    Thanks
      My ComputerSystem Spec
  9.    17 Feb 2016 #9
    Join Date : Nov 2015
    Posts : 299
    Win-10 Pro x64

    Another option might be to see how things run while in Safemode. If things are fine there, then that would seem to point to one of your programs.

    Did you ever try disabling any of the start-ups to see if it's any of those? (Right-click the Taskbar > Task Manager > Start-ups tab)

    In essence, you would have to disable each start-up, one at a time and then test. If the problem is still there, then re-enable it and move down to the next one. These can be disabled and re-enabled by right-clicking each entry. Perhaps try Safemode and see if that changes anything first.


    b1rd
      My ComputerSystem Spec
  10.    18 Feb 2016 #10
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,138
    Win 10 Pro (1703)

    Quote Originally Posted by spotify95 View Post
    Hi,

    I have updated all of the outdated drivers via IOBit Driver Booster. No improvement, but I do have nice new drivers
    Hi, Could you post a screenshot of your task manager showing high CPU case with highest usage processes topmost please?

    Win 10 will most likely restore the driver versions pretty quickly to what Uncle MS deems good for you, unless you take special action. That applies to driver versions which are older or newer than Windows believes appropriate.

    It's not worth using driver scan utilities in Win 10, except for drivers for hardware you can't find not maintained by Win 10, or except to solve exceptional problems, in which case you need to take action to stop Windows replacing the driver.
    Last edited by dalchina; 20 Feb 2016 at 09:13.
      My ComputerSystem Spec

 
Page 1 of 4 123 ... LastLast


Similar Threads
Thread Forum
Solved Windows 10 -- high CPU usage is a real issue
Yesterday, I upgraded from Win 7 pro x64 to Win 10 pro x64. I have a "clean machine" without any traces of viruses or malware. My Win 7 PC ran flawlessly. My Win 7 PC used little or no CPU when it was not running programs. The new Win 10...
Performance & Maintenance
High CPU usage when moving windows
I first noticed this issue when moving a panel around in an application I'm developing, but after further testing found that whenever I move almost any application around my screen I get 20-30% CPU usage from that application. I haven't ever noticed...
Performance & Maintenance
Windows 10 HIGH CPU Usage
I have done a clean install of Windows 10 Pro 64 bit and after my computer is on for about an hour or so a process in the task manager called "system and compressed memory" takes about 25-30% of my cpu cycles for no reason.It doesn't use much ram at...
Performance & Maintenance
windows 10 high mem usage ( poolman screenshot inc )
​hello good people , My name is najeeb So iv upgraded from my good ol 8.1 to 10 a while ago , while its a pleasing os , its high memory usage issues annoy me allot . Yes i have researched before coming here , i reinstalled my all mobo drivers...
Performance & Maintenance
Windows 10 High RAM usage
Can Somone help me, i have a RAM problem. since i downloaded windows 10 i have had a Ram usage problem. when i idle to long or watch a video/stream the Ram usage goes up. when i turn of my pc the normal way it takes like 2min befor it shuts down,...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:56.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums