Windows 10: All video formats slow to load and play


  1. Posts : 2
    Windows 10 Home 64-bit
       28 Jan 2016 #1

    All video formats slow to load and play


    No matter which video player I use, nor which video format I am trying to play, the file hangs sometimes for several minutes before finally playing. Sometimes I have to manually close the program and start it again because it just takes too long. This seems to be happening with all video formats, all players. Got me stumped and it is very annoying. These are files stored on my hard drive, but it is also happening with streaming live video from the internet. I usually have to stay connected to the video site for several minutes before it starts to play. Anyone have a fix for this?
      My ComputerSystem Spec


  2. Posts : 131
    Windows XP, 7, 8.1, 10, Knoppix [Debian] linux
       28 Jan 2016 #2

    charris said: View Post
    No matter which video player I use, nor which video format I am trying to play, the file hangs sometimes for several minutes before finally playing. Sometimes I have to manually close the program and start it again because it just takes too long. This seems to be happening with all video formats, all players. Got me stumped and it is very annoying. These are files stored on my hard drive, but it is also happening with streaming live video from the internet. I usually have to stay connected to the video site for several minutes before it starts to play. Anyone have a fix for this?
    Is this a new install? First question based upon those symptoms would be if you have the proper GPU drivers installed for your video card. If not, and your CPU is doing all the video processing itself, then watching videos could be painfully slow.
      My ComputerSystem Spec


  3. Posts : 2
    Windows 10 Home 64-bit
    Thread Starter
       28 Jan 2016 #3

    Thanks for the reply Mike. It is not a new install, things were fine. Not sure when they changed, can't relate to any particular upgrade. I have used a driver scanner and all my computer drivers and programs are up to date. I will check specifically the graphics driver just in case something has changed there. Once the video is loaded and running, it runs fine, with the exception of when one runs the slider forward or back at which point regardless of video or player it will often hang and then I have to use ctrl,alt,del to kill the program and start again
      My ComputerSystem Spec


  4. Posts : 1
    Windows 10 Home Single Language
       19 Feb 2016 #4

    I have the same issue


    charris said: View Post
    Thanks for the reply Mike. It is not a new install, things were fine. Not sure when they changed, can't relate to any particular upgrade. I have used a driver scanner and all my computer drivers and programs are up to date. I will check specifically the graphics driver just in case something has changed there. Once the video is loaded and running, it runs fine, with the exception of when one runs the slider forward or back at which point regardless of video or player it will often hang and then I have to use ctrl,alt,del to kill the program and start again

    Hello,

    I have the same issue... no matter what I use to play video, it always seems to freeze for a while and then starts... this did not happen before and I cannot say that I know of any recent change that I have done.
      My ComputerSystem Spec


 

Related Threads
Hi Having recently updated to Windows 10, I am astonished (annoyed) to discover Windows 10 does not play WMV video files, particularly those created using Windows Movie Maker. There doesn't seem to be very much advice on this on the net and the...
Hi, I've just purchased a Surface 3 with a view to replacing my iPad for media and also allow me to do some work on it when not near my primary machine. I've copied across a season of TV ripped from DVD and applied all the Metadata through...
After upgrading from Windows 8.1 to 10, more often than not, if I double-click on a .mts video file it will open in "movies and TV" and give the error that this is not a supported format. If I keep double-clicking it, it will eventually play...
After Win 10 installed, everything works fine except for videos. When I try to view them using my Facebook page, I am just getting a green or black screen although I usually have audio -- but not always. I have installed and updated AMD drivers....
Video play not working after installation in Installation and Upgrade
Most kinks worked out after installing 10, but the video player doesn't want to work now. Any ideas? :shock:
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:39.
Find Us