Windows 10: msconfig>Diagnostic startup fails

Page 1 of 2 12 LastLast
  1.    19 Jan 2016 #1

    msconfig>Diagnostic startup fails


    I am trying to determine why Firefox takes 20 seconds to open. This does not happen in Safe Mode so presumably another package is causing the delay. Consequently, I wanted to start in diagnostics mode. However, as soon as I click on the button for Diagnostics startup, the blue rotating circle appears next to the mouse pointer and never advances.
    I checked in Services and found the Diagnostics Host Service is not running and cannot be started.
    Any suggestions would be appreciated.
      My ComputerSystem Spec

  2.    20 Jan 2016 #2

    I have run sfc /scannow, which reports no problems. Manual shutdown after selecting 'Diagnostic startup' means that the PC restarts in 'Selective startup'. However, then selecting 'Normal startup' and attempting 'Restart' ends up with a black screen (mouse pointer still active), so requiring a manual shutdown. Manual booting then returns the system to normal.
    I'm thinking that a System Restore may be necessary.
      My ComputerSystem Spec

  3.    20 Jan 2016 #3

    TopGeek said: View Post
    I am trying to determine why Firefox takes 20 seconds to open. This does not happen in Safe Mode so presumably another package is causing the delay. Consequently, I wanted to start in diagnostics mode. However, as soon as I click on the button for Diagnostics startup, the blue rotating circle appears next to the mouse pointer and never advances.
    I checked in Services and found the Diagnostics Host Service is not running and cannot be started.
    Any suggestions would be appreciated.
    If it does not happen in Firefox Safe Mode, this article will help to determine what causes the issue.
      My ComputerSystem Spec

  4.    20 Jan 2016 #4

    Private said: View Post
    If it does not happen in Firefox Safe Mode, this article will help to determine what causes the issue.
    Thanks for the suggestion. I have already tried disabling all Extensions and Add-ons but with no effect. If I start Firefox in Safe Mode by holding the Shift Key while clicking on the Firefox taskbar icon, it opens in 4 seconds. I should really raise this in the Firefox forum.
    What I am more concerned about is - why I cannot enter diagnostic mode through msconfig.
      My ComputerSystem Spec

  5.    20 Jan 2016 #5

    Hey TopGeek-

    I don't know if you looked over the link that 'Private' provided, but there is an option to "Refresh" Firefox, which might help.
    If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.
    However, I should add that two days ago I was also having an issue with FF (v.43) where it was taking an very long time to open and respond. I tried a few things to no avail, so I tried to refresh it. For whatever reason, after I did the refresh, my browser was a wreck. EVERYTHING was completely different.

    Rather than spending too long trying to unscrew things, I simply used a back-up image from the day before.

    I guess the point being is the Refresh option can be useful, or be problematic.

    b1rd

    Edit:

    Here's a link that might offer some help in ref to the diagnostic issue. It is for Win-8, but there might be something to help.
    http://www.thewindowsclub.com/the-di...g-in-windows-8
      My ComputerSystem Spec

  6.    20 Jan 2016 #6

    Thanks for your suggestions, b1rd. Actually, the FF issue is the least of my concerns, just a minor annoyance. However, the Diagnostic startup now seems to have resolved itself. I changed the Diagnostic Host Service to Automatic but still could not get it to run even after rebooting. Now, I suddenly find the the Service is running and Diagnostic startup works again. These weirdities are designed to drive us mad.
      My ComputerSystem Spec

  7.    20 Jan 2016 #7

    These weirdities are designed to drive us mad.
    it's working.
      My ComputerSystem Spec

  8.    22 Jan 2016 #8

    b1rd said: View Post
    it's working.
    Yes but that doesn't prevent you wracking your brains to figure out the how/why of the situation.
      My ComputerSystem Spec

  9.    22 Jan 2016 #9

    I meant the "weirdities" seem to be working, as they are driving ME mad as well .


    b1rd
      My ComputerSystem Spec

  10.    23 Jan 2016 #10

    There certainly are a lot of oddities in Firefox (and Thunderbird, for that matter) and that undoubtedly stems from the process of disseminated development. When it works, it's great but, when it goes wrong, it's a nightmare.
    I was also contemplating a 'Refresh' but I don't fancy the process of restoring the missing files afterwards. FF is evidently capable of extracting the files to be saved in the Old Firefox Data folder left on the Desktop. Why then does it not have a simple way of reimporting those files after the Refresh?
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Solved MSConfig & Selective Startup in General Support
So msconfig is driving me nuts as whenever i just click normal or diagonstic boot it reverts to selective startup. I had this issue in Windows 7 and i fixed it somehow. Any help?
In the diagnostic startup mode there's no search so I can't run msconfig. Is there another way to do run this? I got to where I'm at now by running msconfig, staying on the general tab (not the boot), unchecking normal startup, then checking...
1. If I try to select normal startup in msconfig.exe, it doesn't stick; always reverts to selective startup. 2. When I boot to the Windows 10 desktop, it always opens a Windows Explorer window at /windows/system/ which shows only a Speech folder...
Once again, I've proven my handle to be correct. Clearly the problem lies within the confines of the little plastic box and not the highly intelligent, devastatingly handsome tech sitting in front of it! Customer brought me an Aspire E1-510P...
I can't get my PC to do a normal start up. When I select normal start up in MSCONFIG and hit apply and boot it reverts to Selective start up. However everything appears to be working normally. I'm not sure if it is or if it is actually doing a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:04.
Find Us