Windows 10: Windows Search and Indexing Broken

Page 2 of 2 FirstFirst 12
  1.    07 Jan 2016 #11

    Ok, I think you have some significant permissions issues to sort out.. hmm, could be tricky!
    Mine's a clean single user Win 10 install

    Suggest before changing anything you make a disk image so you can restore it if things get sticky.
    Aomei Backupper or Macrium reflect (free versions) + boot disk - don't forget to create it- plus external backup medium
      My ComputerSystem Spec

  2.    07 Jan 2016 #12

    What do I have to do? Do I have to remove all Account Unknown users?
    When I try to apply the permissions for Administrator I get permission denied from Windows, Users, Program Files, Program Files (x86), pagefile.sys, Intel, $Recycle.bin, bootmgr, BOOTNXT, Config.msi etc.
    Is there a way to add Administrator and permissions in cmd from live boot while Windows is not running?

    Is it a good idea if I do a repair install of Windows? Would anything change?
      My ComputerSystem Spec

  3.    07 Jan 2016 #13

    I'm afraid I can't advise further on that.. clearly you can do what you can to make permissions match a good system, and you need to remove extraneous groups and user names. However, you then have the question of inherited permissions, and whether all the changes you might need to make will leave you with a useful bootable system.

    Perhaps someone who has more experience of this might be able to help, but realistically, I'd think you'd need to do a clean install.

    There are articles which try to address this to some extent, but there's absolutely no guarantee any one of them will specifically or completely resolve what you have, so I can't direct you to one.

    Example only:
    How to restore Default Security Permissions - Microsoft Community

    - and bear in mind that's Win 7, so you will be further limited on what might be available or applicable to Win 10.

    Have you created a disk image before hacking it? ... beware...!

    Two tools come to mind:
    subinacl.exe (you'll need to research it)
    and's repair tool, which does have some repairs related to permissions, but may not be adequate for your case.
      My ComputerSystem Spec

  4.    09 Jan 2016 #14

    Actually I managed to fix the indexing problem, but I got even major problem.

    I did something very stupid. I tried to add Administrator by hand and apply to all subfolders and files. Then stopped it halfway. That was my mistake.

    Then I found a free software called Permissions Time Machine. It's a great program that fixes permissions. There is an option to restore the default permissions. I chose to fix permissions for the whole drive c: It took me 10 hours.

    Click image for larger version. 

Name:	permissions.png 
Views:	15 
Size:	25.8 KB 
ID:	57822

    As a result the permissions were fixed. Indexing was working. But because of my mistake earlier my start menu and cortana got ruined. They didn't work any more. I tried some solutions like fully reinstall windows apps through powershell and in the end lost them all. So I did a clean install of Windows.
      My ComputerSystem Spec

  5.    09 Jan 2016 #15

    Interesting find.. you've done the right thing, although you've inevitably some reinstalling/configuring to do.

    Little point proceeding with a damaged OS.
      My ComputerSystem Spec

  6.    18 Apr 2016 #16

    microsoft outlook searching simply does not work.

    You can forget it. Outlook searching simply does not work. it does not work on my HP workstation, my HP laptop, my macPro, my Ipad.

    Try logging into exchange from webmail, then you won't have a problem

    zdzdz said: View Post
    After upgrading to TH2 I had an issue with windows search. The service wouldn't start at all.

    I managed to run the Windows Search service.
    I had to delete the Key RebuildIndex and change value of key SetupCompletedSuccessfully to 1.

    Attachment 57258

    Now that the search service works I have another problem. The indexing is not working:

    Attachment 57259

    In Advanced options the Index Location is blank and the button Select New is grayed out.

    Attachment 57260

    When I run the troubleshooter I get : Incorrect permissions on Windows Search directories -- Not fixed

    Attachment 57261

    The owner of folders C:\Program Data\Microsoft\Search and C:\Program Data\Microsoft\Search\Data is SYSTEM. Administrator and my user name are added with Full Control.
    What could be the problem?
      My ComputerSystem Spec

  7. Posts : 164
    Windows 10 Version 1511 (10586.164)
       17 Jun 2016 #17

    I just wanted to report that I spent a few weeks trying to get 'Windows Search' to run. I had the 'Error: 3' issue. I did an in place Windows restore of Windows 10 Pro and that did not solve the issue. DISM and SFC reported no problems. I then found this post and did the following.

    I managed to run the Windows Search service.

    I had to delete the Key RebuildIndex and change
    value of key SetupCompletedSuccessfully to 1.

    That allowed the service to start but now I had the problem of 'Indxing Options' being missing from 'Control Panel.' So, I performed the following than rebooted. It solved my problem.

    Disable and re-enable the feature through dism.
    dism /Online /Disable-Feature /FeatureName:"SearchEngine-Client-Package"
    dism /Online /Enable-Feature /FeatureName:"SearchEngine-Client-Package"
      My ComputerSystem Spec

Page 2 of 2 FirstFirst 12

Related Threads
Hi, I recently upgraded to Windows 10 and have encountered an interesting problem. I realized it initially when I would press start and begin to type a program's name in order to run it, as I was doing with Windows 7, but it would not find any...
So my cortana search is messed up because the indexing service (Windows search service) won't turn on. I get the error "Windows could not start the Windows Search service on Local Computer. Error 15: The system cannot find the drive specified." when...
dual boot system 10 on C:, 7 on D: Search indexing insists on indexing drive D: instead of C: No matter how many times I uncheck indexing locations on D: and choose proper locations on C:, when indexing starts to rebuild it reverts back to D: I...
Index - Windows Search Service I'm having a huge problem where things simply won't search on my laptop, and the Microsoft folder isn't even in Program Files, so I'm unsure if the other methods are even safe. :huh:
Windows Key Search Broken in General Support
If I click the Windows key on my taskbar and type in something like Device Manager or Control Panel, all I get are web search options. Ideas?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:01.
Find Us