Hey guys
i have a very Annoying problem
after several installing windows 10 - 7 - 8 my shutdown and startup times are awful
i have samsung 850 Pro on my laptop
before i forced to clean install windows i have a brilliant performance (about 6-7 sec cold startup and same duration for my shutdown
now its about 50 sec
there are critical errors in event log that i have paste here for you to guide me
thanks to everyone who make me to find a solution for this

Log Name: Microsoft-Windows-Diagnostics-Performance/Operational
Source: Microsoft-Windows-Diagnostics-Performance
Date: 12/27/2015 11:01:28 AM
Event ID: 100
Task Category: Boot Performance Monitoring
Level: Critical
Keywords: Event Log
User: LOCAL SERVICE
Computer: DESKTOP-QQ6VGEA
Description:
Windows has started up:
Boot Duration : 549333ms
IsDegradation : false
Incident Time (UTC) : ‎2015‎-‎12‎-‎27T07:21:00.582634400Z
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Diagnostics-Performance" Guid="{CFC18EC0-96B1-4EBA-961B-622CAEE05B0A}" />
<EventID>100</EventID>
<Version>2</Version>
<Level>1</Level>
<Task>4002</Task>
<Opcode>34</Opcode>
<Keywords>0x8000000000010000</Keywords>
<TimeCreated SystemTime="2015-12-27T07:31:28.781824000Z" />
<EventRecordID>1</EventRecordID>
<Correlation ActivityID="{232BFD28-4077-0003-3300-2C237740D101}" />
<Execution ProcessID="996" ThreadID="3908" />
<Channel>Microsoft-Windows-Diagnostics-Performance/Operational</Channel>
<Computer>DESKTOP-QQ6VGEA</Computer>
<Security UserID="S-1-5-19" />
</System>
<EventData>
<Data Name="BootTsVersion">2</Data>
<Data Name="BootStartTime">2015-12-27T07:21:00.582634400Z</Data>
<Data Name="BootEndTime">2015-12-27T07:31:26.682604500Z</Data>
<Data Name="SystemBootInstance">1</Data>
<Data Name="UserBootInstance">1</Data>
<Data Name="BootTime">549333</Data>
<Data Name="MainPathBootTime">535833</Data>
<Data Name="BootKernelInitTime">37</Data>
<Data Name="BootDriverInitTime">159</Data>
<Data Name="BootDevicesInitTime">487</Data>
<Data Name="BootPrefetchInitTime">0</Data>
<Data Name="BootPrefetchBytes">0</Data>
<Data Name="BootAutoChkTime">0</Data>
<Data Name="BootSmssInitTime">3019</Data>
<Data Name="BootCriticalServicesInitTime">484</Data>
<Data Name="BootUserProfileProcessingTime">793</Data>
<Data Name="BootMachineProfileProcessingTime">53</Data>
<Data Name="BootExplorerInitTime">0</Data>
<Data Name="BootNumStartupApps">0</Data>
<Data Name="BootPostBootTime">13500</Data>
<Data Name="BootIsRebootAfterInstall">false</Data>
<Data Name="BootRootCauseStepImprovementBits">0</Data>
<Data Name="BootRootCauseGradualImprovementBits">0</Data>
<Data Name="BootRootCauseStepDegradationBits">0</Data>
<Data Name="BootRootCauseGradualDegradationBits">0</Data>
<Data Name="BootIsDegradation">false</Data>
<Data Name="BootIsStepDegradation">false</Data>
<Data Name="BootIsGradualDegradation">false</Data>
<Data Name="BootImprovementDelta">0</Data>
<Data Name="BootDegradationDelta">0</Data>
<Data Name="BootIsRootCauseIdentified">false</Data>
<Data Name="OSLoaderDuration">446</Data>
<Data Name="BootPNPInitStartTimeMS">37</Data>
<Data Name="BootPNPInitDuration">1068</Data>
<Data Name="OtherKernelInitDuration">126</Data>
<Data Name="SystemPNPInitStartTimeMS">1187</Data>
<Data Name="SystemPNPInitDuration">113</Data>
<Data Name="SessionInitStartTimeMS">1308</Data>
<Data Name="Session0InitDuration">134</Data>
<Data Name="Session1InitDuration">26</Data>
<Data Name="SessionInitOtherDuration">2859</Data>
<Data Name="WinLogonStartTimeMS">4328</Data>
<Data Name="OtherLogonInitActivityDuration">530658</Data>
<Data Name="UserLogonWaitDuration">76</Data>
</EventData>
</Event>



Log Name: Microsoft-Windows-Diagnostics-Performance/Operational
Source: Microsoft-Windows-Diagnostics-Performance
Date: 12/27/2015 11:43:17 AM
Event ID: 200
Task Category: Shutdown Performance Monitoring
Level: Warning
Keywords: Event Log
User: LOCAL SERVICE
Computer: DESKTOP-QQ6VGEA
Description:
Windows has shutdown:
Shutdown Duration : 27367ms
IsDegradation : false
Incident Time (UTC) : ‎2015‎-‎12‎-‎27T08:09:57.279312500Z
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Diagnostics-Performance" Guid="{CFC18EC0-96B1-4EBA-961B-622CAEE05B0A}" />
<EventID>200</EventID>
<Version>1</Version>
<Level>3</Level>
<Task>4007</Task>
<Opcode>40</Opcode>
<Keywords>0x8000000000010000</Keywords>
<TimeCreated SystemTime="2015-12-27T08:13:17.233172100Z" />
<EventRecordID>2</EventRecordID>
<Correlation ActivityID="{0BA91739-407E-0000-D623-A90B7E40D101}" />
<Execution ProcessID="712" ThreadID="1804" />
<Channel>Microsoft-Windows-Diagnostics-Performance/Operational</Channel>
<Computer>DESKTOP-QQ6VGEA</Computer>
<Security UserID="S-1-5-19" />
</System>
<EventData>
<Data Name="ShutdownTsVersion">1</Data>
<Data Name="ShutdownStartTime">2015-12-27T08:09:57.279312500Z</Data>
<Data Name="ShutdownEndTime">2015-12-27T08:10:24.646356000Z</Data>
<Data Name="ShutdownTime">27367</Data>
<Data Name="ShutdownUserSessionTime">10518</Data>
<Data Name="ShutdownUserPolicyTime">0</Data>
<Data Name="ShutdownUserProfilesTime">48</Data>
<Data Name="ShutdownSystemSessionsTime">16235</Data>
<Data Name="ShutdownPreShutdownNotificationsTime">11226</Data>
<Data Name="ShutdownServicesTime">4992</Data>
<Data Name="ShutdownKernelTime">613</Data>
<Data Name="ShutdownRootCauseStepImprovementBits">0</Data>
<Data Name="ShutdownRootCauseGradualImprovementBits">0</Data>
<Data Name="ShutdownRootCauseStepDegradationBits">0</Data>
<Data Name="ShutdownRootCauseGradualDegradationBits">0</Data>
<Data Name="ShutdownIsDegradation">false</Data>
<Data Name="ShutdownTimeChange">0</Data>
</EventData>
</Event>


Log Name: Microsoft-Windows-Diagnostics-Performance/Operational
Source: Microsoft-Windows-Diagnostics-Performance
Date: 12/28/2015 11:53:58 AM
Event ID: 100
Task Category: Boot Performance Monitoring
Level: Error
Keywords: Event Log
User: LOCAL SERVICE
Computer: DESKTOP-QQ6VGEA
Description:
Windows has started up:
Boot Duration : 84736ms
IsDegradation : true
Incident Time (UTC) : ‎2015‎-‎12‎-‎28T08:21:12.614116500Z
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Diagnostics-Performance" Guid="{CFC18EC0-96B1-4EBA-961B-622CAEE05B0A}" />
<EventID>100</EventID>
<Version>2</Version>
<Level>2</Level>
<Task>4002</Task>
<Opcode>34</Opcode>
<Keywords>0x8000000000010000</Keywords>
<TimeCreated SystemTime="2015-12-28T08:23:58.625283800Z" />
<EventRecordID>6</EventRecordID>
<Correlation ActivityID="{B68600ED-4148-0003-F803-86B64841D101}" />
<Execution ProcessID="1604" ThreadID="1612" />
<Channel>Microsoft-Windows-Diagnostics-Performance/Operational</Channel>
<Computer>DESKTOP-QQ6VGEA</Computer>
<Security UserID="S-1-5-19" />
</System>
<EventData>
<Data Name="BootTsVersion">2</Data>
<Data Name="BootStartTime">2015-12-28T08:21:12.614116500Z</Data>
<Data Name="BootEndTime">2015-12-28T08:23:56.932147400Z</Data>
<Data Name="SystemBootInstance">4</Data>
<Data Name="UserBootInstance">3</Data>
<Data Name="BootTime">84736</Data>
<Data Name="MainPathBootTime">69036</Data>
<Data Name="BootKernelInitTime">40</Data>
<Data Name="BootDriverInitTime">152</Data>
<Data Name="BootDevicesInitTime">501</Data>
<Data Name="BootPrefetchInitTime">0</Data>
<Data Name="BootPrefetchBytes">0</Data>
<Data Name="BootAutoChkTime">0</Data>
<Data Name="BootSmssInitTime">66055</Data>
<Data Name="BootCriticalServicesInitTime">199</Data>
<Data Name="BootUserProfileProcessingTime">199</Data>
<Data Name="BootMachineProfileProcessingTime">34</Data>
<Data Name="BootExplorerInitTime">1330</Data>
<Data Name="BootNumStartupApps">10</Data>
<Data Name="BootPostBootTime">15700</Data>
<Data Name="BootIsRebootAfterInstall">false</Data>
<Data Name="BootRootCauseStepImprovementBits">0</Data>
<Data Name="BootRootCauseGradualImprovementBits">0</Data>
<Data Name="BootRootCauseStepDegradationBits">257</Data>
<Data Name="BootRootCauseGradualDegradationBits">0</Data>
<Data Name="BootIsDegradation">true</Data>
<Data Name="BootIsStepDegradation">true</Data>
<Data Name="BootIsGradualDegradation">false</Data>
<Data Name="BootImprovementDelta">0</Data>
<Data Name="BootDegradationDelta">32507</Data>
<Data Name="BootIsRootCauseIdentified">true</Data>
<Data Name="OSLoaderDuration">765</Data>
<Data Name="BootPNPInitStartTimeMS">40</Data>
<Data Name="BootPNPInitDuration">1070</Data>
<Data Name="OtherKernelInitDuration">133</Data>
<Data Name="SystemPNPInitStartTimeMS">1184</Data>
<Data Name="SystemPNPInitDuration">103</Data>
<Data Name="SessionInitStartTimeMS">1307</Data>
<Data Name="Session0InitDuration">62537</Data>
<Data Name="Session1InitDuration">772</Data>
<Data Name="SessionInitOtherDuration">2745</Data>
<Data Name="WinLogonStartTimeMS">67362</Data>
<Data Name="OtherLogonInitActivityDuration">109</Data>
<Data Name="UserLogonWaitDuration">5452</Data>
</EventData>
</Event>


Log Name: Microsoft-Windows-Diagnostics-Performance/Operational
Source: Microsoft-Windows-Diagnostics-Performance
Date: 12/28/2015 11:45:50 AM
Event ID: 200
Task Category: Shutdown Performance Monitoring
Level: Warning
Keywords: Event Log
User: LOCAL SERVICE
Computer: DESKTOP-QQ6VGEA
Description:
Windows has shutdown:
Shutdown Duration : 54676ms
IsDegradation : true
Incident Time (UTC) : ‎2015‎-‎12‎-‎28T08:11:58.036563000Z
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Diagnostics-Performance" Guid="{CFC18EC0-96B1-4EBA-961B-622CAEE05B0A}" />
<EventID>200</EventID>
<Version>1</Version>
<Level>3</Level>
<Task>4007</Task>
<Opcode>40</Opcode>
<Keywords>0x8000000000010000</Keywords>
<TimeCreated SystemTime="2015-12-28T08:15:50.311834800Z" />
<EventRecordID>4</EventRecordID>
<Correlation ActivityID="{B3D9371C-4147-0002-BD3C-D9B34741D101}" />
<Execution ProcessID="1672" ThreadID="1916" />
<Channel>Microsoft-Windows-Diagnostics-Performance/Operational</Channel>
<Computer>DESKTOP-QQ6VGEA</Computer>
<Security UserID="S-1-5-19" />
</System>
<EventData>
<Data Name="ShutdownTsVersion">1</Data>
<Data Name="ShutdownStartTime">2015-12-28T08:11:58.036563000Z</Data>
<Data Name="ShutdownEndTime">2015-12-28T08:12:52.712585500Z</Data>
<Data Name="ShutdownTime">54676</Data>
<Data Name="ShutdownUserSessionTime">1519</Data>
<Data Name="ShutdownUserPolicyTime">2</Data>
<Data Name="ShutdownUserProfilesTime">44</Data>
<Data Name="ShutdownSystemSessionsTime">51861</Data>
<Data Name="ShutdownPreShutdownNotificationsTime">49817</Data>
<Data Name="ShutdownServicesTime">2028</Data>
<Data Name="ShutdownKernelTime">1294</Data>
<Data Name="ShutdownRootCauseStepImprovementBits">0</Data>
<Data Name="ShutdownRootCauseGradualImprovementBits">0</Data>
<Data Name="ShutdownRootCauseStepDegradationBits">73</Data>
<Data Name="ShutdownRootCauseGradualDegradationBits">73</Data>
<Data Name="ShutdownIsDegradation">true</Data>
<Data Name="ShutdownTimeChange">38926</Data>
</EventData>
</Event>


after fresh install of windows everything is ok but after installing drivers or updating windows same problem will happened
Windows 7 x64 is same as 10 on this problem but windows 7 x86 is ok even installed on my HDD not SDD
all the drivers are installed from windows update ( OEM drivers from lenovo tested before )