1.    16 Dec 2015 #1
    Join Date : Dec 2015
    Posts : 2
    Windows 10 Pro 64-bit

    Windows Explorer takes up 40-50% CPU usage


    Hello,
    I have this problem where after some hours of use (~3, for example) the windows explorer takes up 40-50% of the CPU causing major performance loss. I do not know what is causing this problem, as it does have to do with my activity, since when this happens I am not using the explorer in the means of opening a file or moving data.

    Any help would be appreciated.
    If you need further information, I will be happy to provide it.
    Attached Thumbnails Attached Thumbnails Picture4.jpg   Picture1.jpg   Picture2.jpg  
      My ComputerSystem Spec
  2.    17 Dec 2015 #2
    Join Date : Dec 2015
    Posts : 1
    windows 10

    I see this too after deleting a large amount of files. The explorer window hangs open at 99% but 0 bytes left. Very reproducible.
      My ComputerSystem Spec
  3.    20 Dec 2015 #3
    Join Date : Dec 2015
    Posts : 2
    Windows 10 64-bit

    I had had the same issue a simple way to fix it open Task Manager find Windows Explorer right click and press Restart
      My ComputerSystem Spec
  4.    21 Dec 2015 #4
    Join Date : Dec 2015
    Posts : 2
    Windows 10 Pro 64-bit
    Thread Starter

    Quote Originally Posted by Jamesc View Post
    I had had the same issue a simple way to fix it open Task Manager find Windows Explorer right click and press Restart
    I tried this and it did not work.
    (Thanks for your contribution)
    Last edited by Argyris Patikos; 22 Dec 2015 at 11:23.
      My ComputerSystem Spec
  5.    21 Dec 2015 #5
    Join Date : Dec 2015
    Posts : 3
    Windows 10

    I'm also having this problem. Mostly happens few hours after the system started and when I have navigating through explorer a lot. Restarting explorer.exe didn't work.
      My ComputerSystem Spec
  6.    22 Dec 2015 #6
    Join Date : Dec 2015
    Posts : 2
    Windows 10 64-bit

    I would suggest contacting Microsoft about the issue as they may have better knowledge of this bug.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 10 Explorer.exe high CPU and memory usage when copying files
I recently upgraded both my PC to Windows 10, and whenever I copy large amount of files (or analyzing large amount of files before copying), with explorer.exe uses a massive amount of CPU (~50%) and memory (~up to 3 GB). System process also uses a...
Performance & Maintenance
Windows 10 Hibernate and sleep takes too long
Hello. If I may ask, since I upgrade from my Windows 8 Single Language to Windows 10 Home Single Language (64-bit), it seems that I have trouble putting the laptop to hibernate or sleep. If I choose to Sleep, it suppose to go into sleep mode and...
Performance & Maintenance
Solved Windows 10 takes a long time to boot
So, I've encountered this issue lately where Windows 10 takes considerably longer to boot than before. (Usually 4 to 5 minutes) It used to boot under 30 seconds before so I don't know what went wrong here. So, the screen with the Windows logo...
General Support
Solved Problem: Explorer 50% cpu usage
Every day, at intermittent times unrelated to anything I do , Explorer starts running with each core at about 50% cpu usage, and does not stop. Temperatures and fan speeds rise, fans become very noisy. Speedfan indicates core temps rise to ~...
Performance & Maintenance
After 53 million installs, Windows 10 takes 4.95% of the market
http://www.neowin.net/news/after-53-million-installs-windows-10-takes-495-of-the-market?utm_source=dlvr.it&utm_medium=twitter quite a good start :)
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:33.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums