Is this normal? System and compressed memory process ALWAYS at 20% cpu Solved

Page 2 of 3 FirstFirst 123 LastLast
  1. storageman's Avatar
    Posts : 483
    Windows 10 Pro 1809 17763.134
       22 Aug 2016 #11

    AncientNoodles said: View Post
    Why thanks:)

    I chose that driver for two reasons, I thought that the system and memory compression is linked to paging, and thus to the SSD. (this may or may not be, just a guess I made)
    Second, the fujitsu web page has very few drivers for win 10, only three, I checked my device manger and realized two of them were already installed, so the Intel Rapid driver was the only one left.

    I am still wondering why the SSD driver is not intel, but perhaps the intel rapid storage is not the SSD driver at all, but in fact IDE ATA/ATAPI controller? I guess I will have to check next time I have a clean install in front of me.
    I believe the Intel Rapid Storage driver is for Sata chipset on your mother board not the attached drives.
      My ComputersSystem Spec

  2.    25 Dec 2016 #12

    Is the "System and Compressed Memory Service" gone? Changed names?

    I started reading threads on System and Compressed Memory because of researching high memory and disk usage, but then I realized that I've never seen this process listed in Task Manager on my system (a Toshiba i7 laptop with 4 GB of RAM.) I also checked Services, and I don't see it listed there either? Has MS removed this service from Win 7 in recent months, or changed the name? (In all the threads I've seen, no mention of that it being removed from Win 10.)

      My ComputerSystem Spec

  3.    25 Dec 2016 #13
      My ComputerSystem Spec

  4.    26 Dec 2016 #14

    dalchina said: View Post
    dalchina, thanks for replying. In my case, I came across "System and Compressed Memory" because I was looking into high disk access and memory usage in Task Manager. I understand now that the normal function of "System and Compressed Memory" should reduce disk activity. So for those who complained of that, it is most likely something else causing heavy disk access. Still, I don't think "It runs when needed" addresses my issue.

    In my situation, I NEVER have seen "System and Compressed Memory" appear as a process in Task Manager on my Win 10 Pro system. Also, I think it's been suggested that this is a Service; however, no such service is listed in Services on my machine, even as Disabled. The closest I've come to understanding how "System and Compressed Memory" is implemented is in the article found here:

    The author, Kevin Arrows, points out that this runs as a Task under MemoryDiagnostic in Task Manager. He was also impressed enough by one of his reader's comments to add it to the end of the article. That reader said that on his system, for RunFullMemoryDiagnostic under MemoryDiagnostic, the error message, "The operator or administrator has refused the request. (0x800710E0)" appeared.

    When I checked my Task Manager, I found the same error message. For both tasks listed there, ProcessMemoryDiagnosticEvents and RunFullMemoryDiagnostic, the Status is listed as Ready and the task shows as having run very recently in both cases. (Last Run Time) However, the same error message appears in both, under Last Run Result:

    "The operator or administrator has refused the request. (0x800710E0)"

    So I suspect that this Task has never actually run on my machine, which suggests that there is either something amiss in the Task's argument, or some module that is supposed to be called which could not be found. The commenter's Win 10 system, like mine, was an upgrade from a previous version. So I am wondering if, as he suggests, this is the result of something getting scrambled in the upgrade process. If so, it may be that many people who upgraded to Win 10 have never experienced this process being called.

    Perhaps you can tell me, is my analysis correct--how SHOULD that task be set up? And what am I missing about how this process is called and run?

      My ComputerSystem Spec

  5.    26 Dec 2016 #15

    Click image for larger version. 

Name:	Snap 2016-12-26 at 14.33.47.jpg 
Views:	1 
Size:	123.6 KB 
ID:	114852
    Hi that's how the task is set up on mine as seen by Nirsoft's Taskschedulerview (free).

    You're correct- "The operator or administrator has refused the request. (0x800710E0)" is typically related to a failed scheduled task.
    Of course you can check the dll exists.

    I'd suggest running
    chkdsk C: /F
    (requires restart) and
    as a matter of course.

    But looking at my task scheduler, I now see the same error code appears...
    Click image for larger version. 

Name:	Snap 2016-12-26 at 15.00.42.jpg 
Views:	1 
Size:	100.6 KB 
ID:	114854

    By changing the start conditions (wrt idle) I got it to run, result 0x0. However System was using 25% CPU
      My ComputerSystem Spec

  6.    26 Dec 2016 #16

    Okay, thanks again, dalchina. Yes, NirSoft tools are usually simple and so sane to use. But this one seems not to capture "Last Run Result" in the same way as the actual Task Scheduler. Also, I notice that in mine the result is fully typed out--yours only shows the result code.

    Click image for larger version. 

Name:	2016_12_26_22_03_071.png 
Views:	3 
Size:	77.7 KB 
ID:	114909

    I see also under Conditions that the Task is to be run only on AC power on my laptop. However, most of the time it IS on AC, and I still have not seen that task run--ever. So I am not one of those complaining about seeing a large number of MB used by this task (as I never see the task listed in TM). I've sometimes seen a very high percent of total memory used. That lessened considerably once I restored the default in Virtual Memory--let Windows manage it instead of setting a fixed amount (apparently now OLD INFORMATION in Win 10) and also I've disabled Superfetch, though I don't yet have an SSD on this machine. Memory use seems much more reasonable after those changes.

    But--you've introduced another mystery. Your Scheduler also shows the same result code (apparently indicating the Task was unable to run)--though not expressed in text like mine. So have you ever seen it running on your or another machine? Now I am wondering whether there is anything wrong with my setup of the Task, and if so, what to change.

    Also, under Actions it's indicated that this is done by a "Custom Handler". Does that imply to you that this is not a Service at all but is handled by some built-in OS component that is called by this Task? How and when it is called, and why at those times, are also mysteries to me.

    I ran SFC not too long ago, but will run it again shortly, and also scan my C: Drive for errors. I doubt that's the problem, but I'll check.

    [Edit: I forgot to mention that, while I do not see a task call "System and Compressed Memory," I do see a task called just "System" appears a lot at the top of the list for Disk usage. This frequently uses the disk for extended periods shortly after returning from Sleep or Hibernation.]

      My ComputerSystem Spec

  7.    26 Dec 2016 #17

    PS: I checked two other systems that were also upgraded from Win 7 (mine is Pro and the other two are Home), and all of these have similar messages about "The operator or administrator has refused the request. (0x800710E0)", except in one instance the report is: 'The process terminated unexpectedly (0x8007042B)." I don't recall seeing "System and Compressed Memory" as a process in Task Manager in any of these computers. I am now trying to check with someone who has a system that was not upgraded--originally installed as Win 10.

    Also: I ran SFC--all is fine; and chkdsk on C: --no problems, some minor corrections to the file system.

    Last edited by bilateral; 26 Dec 2016 at 22:36.
      My ComputerSystem Spec

  8.    27 Dec 2016 #18

    Hi, the missing text might be related to me having history disabled in the task scheduler.

    I commented I could run the tasks successfully manually by changing the idle criteria for the task, with the effect that System used a lot of CPU time for perhaps 10 mins when I ran RunFullMemoryDiagnostic. You might like to experiment with that to see if you get a different outcome. Similarly with the idea of changing Administrators to your user name, just as an experiment.

    My Win 10 was clean installed.

    No, I've not seen the task run- the only time I'm aware of people mentioning it has been in the context of exceptional disk or CPU use- i.e. a problem/conflict. My limited understanding is it shouldn't run continuously, only on particular events, and that it isn't a service. And I don't see it in task manager even when both those tasks are running.
    Last edited by dalchina; 27 Dec 2016 at 01:13.
      My ComputerSystem Spec

  9.    28 Dec 2016 #19

    @dalchina: I've been looking at quite a few other threads on this System and Compressed Memory process issue. (You were present in several, dalchina.) I only recently started reading about it, but I see it emerged around beginning of this year, was talked about most heavily April till July, and much less after August. It's hard to create a clear history of what happened with it, but I think I'm beginning to understand why researching this has been such a pain. Most helpful threads have been here on TenForums, and on SuperUser, like these:

    System and compressed memory

    (A very short thread, but see the posts by swarfega and TairikuOkami.)

    *The idea that the error message in Task Scheduler has something to do with it being an upgraded system does not hold up. Both you and my Brother-in-law have clean installed systems and have the same error message in the Last Run Result--except mine and his are typed in full and yours is just the error code. (Why??) ...But does EVERYONE have that same message in their Task Scheduler? I've never seen an indication that it HAS run successfully. Is that the way it looks in everyone's system now?

    dalchina said: View Post
    ...the missing text might be related to me having history disabled in the task scheduler.
    *Not likely. My History is also disabled, and I noticed that for just about every other task I looked at, History was disabled. I think this must be the default--I'm guessing you have to turn it on if you want to observe it.

    *At least one other person besides us confirms this process/task is not a service.

    *The main thing that confuses this is that many reported (in many threads) a process called "System and Compressed Memory" but you and I have not seen that process. That could be because we were not looking at the right time,...but I suspect it's actually because Microsoft has changed the name, and we weren't looking for it before they did so. ...My theory is that after they got a lot of flack, and fixed the main issues, they also removed the reporting of memory size that was compressed and changed the name to simply "System". The memory compression thing is now hidden inside the "System" process, which may show a lot of disk accessing or CPU for various reasons--but it doesn't show you how much memory is compressed any more. What's puzzling is that in my reading I did not find one instance where someone mentioned that such a change has taken place.

    I guess I will have to break down (as I have resisted for a long time) and learn how to use Process Explorer if I want to look at the details under "System".

    You mentioned the idea of running the task manually. I have not tried that yet. I may do that, but my main concern has been to understand if this was something that's relevant to problems I was noticing, or if I was missing something that should be obvious--why was I not locating the very thing that so many people were talking about? And then, why are they not talking about it much any more? And why doesn't anyone know why they aren't talking about it? ...Or another way to say it, is this just another easy way to be misled while researching a computer issue, because the bug was partly corrected and partly confused by being changed or hidden?

    The older it gets, Microsoft's flagship Consumer OS gets more and more confusing, more confused, and less possible to really manage by the average consumer.

      My ComputerSystem Spec

  10.    28 Dec 2016 #20

    I like the idea of checking the effect in the performance tab of the task manager.

    It is interesting that reports of difficulties are negligible now. It was, after all , a new feature, and MS has issued a number of major updates.

    MS relying increasingly on users documenting their OS doesn't help at all. We struggle with partial understanding.

    Philosophy: ideally we wouldn't have to worry about the OS. We should benefit from levels of abstraction and move on- if only MS would isolate the OS from consumers - on a hidden normally inaccessible partition - and not muddle along with a legacy registry and C: structure where installing software can write to a number of OS folders, and user data and temporary files are on the same partition by default. The OS should be separately and independently maintained from installed programs for the most part (compatibility issues aside). That would mean (e.g.) splitting the registry, placing 'user' related parts on (say) D: with all user data, drivers, etc etc. That way you could freely reinstall the OS and still have everything 'installed'.

    tenforums would be a lot quieter, and maintaining PCs simplified.
      My ComputerSystem Spec

Page 2 of 3 FirstFirst 123 LastLast

Related Threads
Process taking up alot of memory. in Performance & Maintenance
Hey guys, so I have this process it's taking up alot of memory. 45464 My computer Stats: 45465
Memory Management, system secuiry service etc. in BSOD Crashes and Debugging
hello, i've been having random bsod issues. and i can not seem to figure out the trigger of these bsod's. i get memory management when im browsing, playing a game or when i dont even use the laptop. The system security bsod i have no clue on. My...
Hi everyone, in Task Manager, the "System" sometimes starts eating 14~20% CPU and that persists until a reboot. "System interrupts" (which is a pseudo process?) seems to do the same. It doesn't happen from boot, and I don't know what triggers...
I see a lot people talking about memory leaks with this, mine never goes that high except when I game it'll jump up higher than the game itself sometimes. Just curious is this the case for everyone?
I seem to have an issue with one of my system processes using up an inordinate amount of RAM. It isn't causing a lot of issues right now, but it definitely bogs things down here and there. Pictures are of my task manager window on relevant tabs. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:23.
Find Us