1.    16 Nov 2015 #1
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)

    Corrupted files - DISM or SFC results more accurate?


    I've just built a completely fresh installation of the latest build of Win 10 Pro x64 (10586.3, also referred to as 1511).

    I've done the necessary apps installs, software configuration and ended up with running SFC scan, which suggested my 'opencl.dll' library (related to some remote VPN, not nVidia drivers) was corrupted. I've run DISM that wasn't able to repair the issue by itself but when linked to source, it fixed the problem (well, at least it claimed to have fixed it). However SFC scans still end up with presenting the same issue...

    I've tried DISM repair multiple times, each time apparently with success, but SFC still returns a hash mismatch for this dll. At the same time DISM integrity scans show no errors.

    I've read that DISM is commonly considered a more reliable tool than SFC and SFC can sometimes return false positives when run. However, all discussions I've scanned referred to Windows 7 or 8/8.1 - none of them addressed the issue in Windows 10.

    Moreover - I run SFC on my other machine that had been upgraded to Win 10 (from 8.1) some time ago and the same error appeared. Surprisingly here, after running DISM fix, SFC doesn't find any errors! The machine runs Win 10 Pro x64, exactly the same build! The only difference is that this one was upgraded and the other was freshly installed.

    Thus, the question is - shall I be bothered by the fact SFC returns an error? Or shall I rather stick to DISM output which say everything is fine?
      My ComputerSystem Spec
  2.    16 Nov 2015 #2
    Join Date : Jun 2015
    Posts : 1,929
    Windows 3.1 to Windows 10

    I would not worry about the hash mis-match.. if that is the only error sfc is pulling
      My ComputerSystem Spec
  3.    16 Nov 2015 #3
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    Thanks, Kyhi! Yes, that's the only error - occurs twice in the CBS.log, but each time related to the same file (opencl.dll) and it's described as a hash mismatch.

    However, it's a super-fresh install, so it would be nice to have it without any errors... Is that even possible with Windows?

    That's the part of the output file:
    Code:
    2015-11-16 19:19:01, Info                  CSI    00004e23 [SR] Repairing 1 components
    2015-11-16 19:19:01, Info                  CSI    00004e24 [SR] Beginning Verify and Repair transaction
    2015-11-16 19:19:01, Info                  CSI    00004e26 [SR] Cannot repair member file [l:10]"opencl.dll" of microsoft-windows-RemoteFX-clientVM-RemoteFXWDDMDriver-WOW64-C, version 10.0.10586.0, arch Host= amd64 Guest= x86, nonSxS, pkt {l:8 b:31bf3856ad364e35} in the store, hash mismatch
    2015-11-16 19:19:01, Info                  CSI    00004e29 [SR] Cannot repair member file [l:10]"opencl.dll" of microsoft-windows-RemoteFX-clientVM-RemoteFXWDDMDriver-WOW64-C, version 10.0.10586.0, arch Host= amd64 Guest= x86, nonSxS, pkt {l:8 b:31bf3856ad364e35} in the store, hash mismatch
    2015-11-16 19:19:01, Info                  CSI    00004e2a [SR] This component was referenced by [l:125]"Microsoft-Windows-RemoteFX-VM-Setup-Package~31bf3856ad364e35~amd64~~10.0.10586.0.RemoteFX clientVM and UMTS files and regkeys"
    2015-11-16 19:19:01, Info                  CSI    00004e2d [SR] Could not reproject corrupted file [l:23 ml:24]"\??\C:\Windows\SysWOW64"\[l:10]"opencl.dll"; source file in store is also corrupted
    2015-11-16 19:19:01, Info                  CSI    00004e2f [SR] Repair complete
    Last edited by mikolajek; 16 Nov 2015 at 16:52.
      My ComputerSystem Spec
  4.    16 Nov 2015 #4
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,207
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
      My ComputerSystem Spec
  5.    16 Nov 2015 #5
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    Thank you, topgundcp! Apparently a miracle has happened and it... worked!!! Kudos for you!

    I can't tell if that's the particular image you proposed or anything else (as I did the trick with mounting files from the original installation media, created with the media creation tool - no luck though ), but the successful outcome is the most important!

    Out of curiosity and for future reference - are you able to comment about the reason behind this? I mean that files extracted from this particular image work while the ones extracted from the original installation media (ESD USB stick) fail? Since the build is the same, I'd say the file source should make no difference...
      My ComputerSystem Spec
  6.    16 Nov 2015 #6
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,207
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    They are not the same. The one downloaded from Media Creation Tool (install.esd) is in compressed format and cannot be mounted with DISM.
      My ComputerSystem Spec
  7.    18 Nov 2015 #7
    Join Date : Nov 2015
    Posts : 54
    Windows 10

    There is no point to restore opencl.dll because it will be overwritten again by NVIDIA driver installation, so this error will return back.

    In details:

    The correct fix will be to remove wrongly installed and activated by Microsoft wow64_microsoft-windows-r..xwddmdriver-wow64-c_31bf3856ad364e35_10.0.10586.0_none_3dae054b56911c22 directory (Microsoft RemoteFX Display driver, 32bit part, which contains opencl.dll with reduced functionality, which overwrites correct Nvidia/ATI/Intel \SysWoW64\opencl.dll on upgrade or attempt of DISM recover from install.wim) from WinSxS (64bit counterpart is in amd64_rdvgwddmdx11.inf_31bf3856ad364e35_10.0.10586 .0_none_5fcf2a87752df0d7 directory, but is inactive and does no harm). But I know no tool for correct selective remove or deactivate of specific directory from WinSxS. Since \SysWoW64\opencl.dll is hardlink to WinSxS one, attempt to install Nvidia/ATI/Intel driver corrupts two Microsoft opencl.dlls at once (so sfc /scannow fails to recover), and attempt to recover WinSxS one from install.wim damages Nvidia/ATI/Intel display driver's opencl.dll from other hand.
    Last edited by Ache; 01 Dec 2015 at 10:38.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved sfc - corrupted files but could not fix them.
Hi, This is a fresh install of Windows 10 and when i run sfc/scan now i get the message that there is corrupt files. Ive done a reset and a in Place upgrade both which failed to fix the problems. I've ran some commands in command promt, can't...
Performance & Maintenance
Solved sfc /scannow found corrupted files but could not fix them.
Hello. For quite a while, my computer had slow boot up and shutdown times and I searched online that sfc /scannow could probably help. I've tried every method regarding sfc /scannow and nothing worked. I've also included a CBS Log file to help me...
Performance & Maintenance
SFC /Scannow will not repair files - nor does DISM work
This is on a new pc I bought today. Bad news! Where can I get an ISO 10240 which I can use on my external disk as a source file to repair - or where can I go for a source file? Appreciate any help. Thanks!
Performance & Maintenance
SFC and DISM error when trying to fix corrupt windows files
Hello, I ran "SFC /scannow" and got an error saying the System File Checker found errors but couldn't fix them. Afterwards I ran "DISM /Online /Cleanup-Image /RestoreHealth" and DISM threw the error 0x800f081f saying that the source files could...
General Support
Windows Corrupted files sfc and DISM image recovery fails
Hello everyone I have been trying to fix my windows 10 corrupted files but I have been unabled to recover it. I tried every possible way of recovering using DISM commands, but to no avail. I tried also the sfc /scannow but as usual this command...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:37.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums