Windows 10: SFC not working and neither is DISM Solved

  1.    15 Nov 2015 #1

    SFC not working and neither is DISM

    Hey, I'm new here.
    Maybe I should start a new post, but let me just start here, as this thread is the closest to my problem that I can find.
    I have a very old laptop, but despite the age it has worked relatively fine for my needs with just an HDD change. I bought this at the very end of Vista lifespan with an almost immediate Win7 upgrade offered. I then skipped Win 8 totally, but rolled a Win 10 when it came, and it has been working well. But you get the picture. This machine is old.

    Onto the point: I'm getting an occasional fan rev up, with the CPU at 100%. The process is Service Host: Local System (Network Restricted). Recently, I also lost all sound on the computer, which chkdsk /f /r was able to salvage. I have a feeling these might relate to a same problem.
    I researched, and found out that sfc /scannow will help. OK. It starts the verification process, but fails at 18% saying corrupt files exist. When I export the sfcdetails.txt from the log, it does not really report which files are corrupt so as to replace them. 00000e22 [SR] Beginning Verify and Repair transaction and then the logfile ends.

    Because I cannot complete SFC, I'm told to run DISM, and that is how I ended up here.
    When I run Dism /Online /Cleanup-Image /RestoreHealth

    Image version 10.0.10240.16384
    At 20% an error 1726 with remote procedure call failed.

    So I go to dowload the ISO and mount it. It will then give me the .esd
    so I'm having my fingers crossed while running Dism /Online /Cleanup-Image /RestoreHealth /Source:esd:F:\Sources\Install.esd:1 /limitaccess

    ... only to get Image version 10.0.10240.16384
    20% an error 1726. Remote procedure call failed.

    Help me out here. What is going on with this machine and how can I get healthy system files without wiping the machine?

      My ComputerSystem Spec

  2.    16 Nov 2015 #2

    Problem solved with the Windows 10 fall update 1511.
    Alhough installing the update would always fail after 22% and revert back to the old Windows.

    I only managed to run through the install when I let the program delete every program file, setting and driver I had, leaving only my own files intact.

    Took a lot of time and patience, but SFC now runs without errors, so the system is fine.
      My ComputerSystem Spec


Related Threads
Error DISM restorehealth in Performance & Maintenance
Hello I use the Windows DVD 10 and option 3 with IMAGE_HEALTH and have an error 50: 0x800f081f and operation not fix !!
DISM Repair not working in Performance & Maintenance
I recently installed Windows 10 Pro 64-bit from an in-place upgrade. After doing so, I've been encountering numerous issues such as long login times and the Store not opening due to an error I'm getting which states "This app can't open." I've...
10547. Really weird behavior. Dism and sfc scannow are not working. I type them in and then cursor goes to next line and nothing happens. A second cmd window opens for less than a second and closes out. Not sure why that is happening. Other weird...
DISM COMException Error in Performance & Maintenance
I've discovered a weird issue on Windows 10x64 10525 Any solution yet?
Hello all, I recently upgrade from 8.1 Pro to 10 Pro. All was well in the beginning but now things have gone haywire. I want revert back to 8.1 pro but I dont want to lose my apps. I have critical settings in my apps... I do pro...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:33.
Find Us