Windows 10: "WMI Provider Host" high cpu usage Solved

  1.    14 Nov 2015 #1

    "WMI Provider Host" high cpu usage


    even with the new update "WMI Provider Host" process is consuming high % of the cpu.

    is there any possibility to resolve this problem?! serached on internet and it's quite common

    thanks
      My ComputerSystem Spec

  2.    23 Nov 2015 #2

    up....
      My ComputerSystem Spec

  3.    23 Nov 2015 #3

    removing optional the component "multipoint connector" seems to resolve
      My ComputerSystem Spec

  4.    03 Dec 2015 #4

    pietro said: View Post
    removing optional the component "multipoint connector" seems to resolve
    Hi, could you explain what you did please? I've just found this using 6% CPU or so maybe after the most recent update (today). Thanks.
      My ComputerSystem Spec

  5.    03 Dec 2015 #5

    dalchina said: View Post
    Hi, could you explain what you did please? I've just found this using 6% CPU or so maybe after the most recent update (today). Thanks.
    sure, really simple... if i install the component "multipont connector" i get the "wmi provider host" comsuming 100% cpu... removing this component i get cpu at 0%...i had to remove compontents and drivers one by one to find a solution
      My ComputerSystem Spec

  6.    03 Dec 2015 #6

    Thanks- so it's a physical device? (sorry, not sthg I'm familiar with).

    I found this- post by SB77 was helpful.
    http://answers.microsoft.com/en-us/w...63d3a4b?page=2

    It appears to be a small adblocking program I recently installed..

    (And then there's this:
    WMI: How to troubleshoot High CPU Usage by WMI Components - Ask the Performance Team - Site Home - TechNet Blogs

    which I'd prefer not to have to tackle..)
      My ComputerSystem Spec


 

Related Threads
Solved Photos Background Task Host - High CPU usage! in Performance & Maintenance
Hello! I'm new here so I will make this short. I installed Windows 10 (10130 build) and I love it. The only problem that I'm having with it is this Photo Background app that eats my cpu(30-40%)! When I start up windows I need to kill it in task...
Can anyone explain what is happening here? From the moment I switch ON my desktop until switching OFF (working for 12 hours) the local system service host is always between 30% to 40% regarding CPU usage. Why? How to stop it? This does not happen...
Hello Everyone, I've never seen this problem with the previous O.S., Windows 7, but Windows 10 is throwing me this error message approximately 70% of the time when I run the network troubleshooter...either from the Control Panel, or by right...
Now the bug is fixed and here is the report.. Summary part first and then the detail on word usage..:cool: *>----------------------------------------------------------------------------<* *> Summary Report - Change a Letter Game...
Very high memory usage by "system" in Performance & Maintenance
Hi all. Im having an issue with my "System" Screenshot by Lightshot This is after 30-60min of having the computer running. Late last night it was at almost 6GB!! wtf is going on? i had Killer Networking - Home those drivers for me e2200...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:30.
Find Us