Cannot Boot from Hibernate

  1. Posts : 2
    Windows 10

    Cannot Boot from Hibernate

    This is on a fresh Windows 10 install, using a 60 GB SSD and a pair of 1 TB HDD's. No folders were moved off the SSD (C:\) outside of what Windows supports. (That is, I moved all user folders to the HDD that I was allowed to, and installed all programs to the HDD that I was able to.)

    I enabled hibernation via the Power Options > System Settings section in the control panel. The C:\ drive has 25 GB free space; well more than enough for hiberfil.sys to work normally. When hibernating, the system appears to behave normally and hibernate as it should.

    When booting from a hibernated system, the computer POSTs normally and then brings up the Windows 10 logo and loading screen briefly before powering off very suddenly. I have to turn on the system again, and when I do, it boots normally but the hibernation state is lost.

    I've attempted disabling fast startup, which seems to have no effect. I've updated my video drivers to 15.9 beta, but I recall this being a problem on 15.7 as well. Full system specs are in my profile. This machine was running Windows 7 in the past before upgrading, but I had to run a fresh install of Windows 10 after encountering some problems. (So the system is currently on a fresh install.) Google is also currently unable to deliver any relevant results for this problem. Windows Update reports being up to date.

    Thoughts? Thanks.

    Edit: Additionally, this has never been a problem on Windows 7. The SSD is in decent condition too, and has not exhibited any problems.

    Edit: This problem was happening on shutdown and restart as well. I disabled fast startup, which corrected the problem when shutting down. Here's a summary of the behavior now:

    Shutdown, no fast startup: Able to start up normally without any unexpected behavior.

    Shutdown, fast startup enabled: Computer immediately shuts off just after reaching the Windows boot screen. Has to be powered on again and then will boot normally.

    Hibernate, regardless of fast startup setting: Same behavior as above.

    Conclusion: From my understanding, fast startup acts as a subset of hibernate. Windows 10 is not able to properly hibernate the driver(s) and/or some other system state. I might have to go through the drivers via process of elimination to see what's causing the problem.

    Edit: I found the problem!

    So despite no BSOD ever appearing, I ran the BlueScreenView utility to view the system dumps. Got the driver IRL not less than or equal error, found that it was from sptd2.sys; the SPTD (a SCSI bypass driver) I installed with Daemon Tools. I found a separate uninstaller for the driver and got rid of it; it's not something I need anyway. (Lots of Google searching will find you these utilities and solutions.)

    Would be nice if it showed an error or BSOD in the first place! I was about to go whack-a-mole on the drivers, but I would've never found the root cause.

    Anyway, hopefully this helps someone Googling around or something.
    Last edited by CA99; 18 Oct 2015 at 13:47.
      My Computer

  2. Posts : 1
    10 64bit Enterprise

    Good work

    Thanks A LOT. This problem really drove me crazy. I was just about to do a clean install of windows.
    I did a lot of things, so I'm gonna list them and I hope it will be helpful to someone. My problem was exactly like the OP. Could not return from a hibernate. Sleep worked fine.
    - uninstalled Power4Gear which is a set of power plans for my Asus N53SN laptop. Since Win10 is not officially supported by this model, I guessed maybe the power plans were not 'suited' for Win10
    - uninstalled Nvidia Driver (from control panel AND device manager) to have only Intel HD graphics driver.
    - disabled all startup programs
    - disabled and enabled hibernate feature
    - CHKDSKed the C partition
    - uninstalled ESET AV.
    - uninstalled all windows updates
    - uninstalled Office 2013
    - disabled all windows services
    - uninstalled all recently installed softwares, including Daemon tools and alcholo 120%. In fact I installed and re-uninstalled them again, separately just to be sure.
    What was interesting was that, the hibernation feature worked fine within safe mode!
    To uninstall the aforementioned driver, search the driver in google and head to the Duplex Secure site and download the suitable driver.

    It's interesting to me that 50% of the times what I'm doing is fixing things on my laptop.
      My Computer

  3. Posts : 2
    Windows 10
    Thread Starter

    Wow, that must've taken an eternity. I was specifically trying to avoid indiscriminately uninstalling things and kept Google searching how to find various errors and sources. For anyone else that bumps into this thread with the same issue, I highly recommend that approach; it saved me a lot of time.

    Hpefully the upcoming updates improve on these issues. I'm finding Windows 10 to be a lot more annoying with driver concerns than before, although technically that's the fault of the hardware manufacturers not keeping their stuff up to date and supporting W10. We really need more and more things to go UPnP.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:58.
Find Us

Windows 10 Forums