Page 1 of 3 123 LastLast
  1.    08 Oct 2015 #1
    Join Date : Feb 2015
    Posts : 157
    Windows 10 Pro

    High CPU usage


    Hi All,
    Running Windows 10 Pro x64
    Just noticed a lot of lag on my online game when I was logging into it. I closed it and noticed my computer was slow responding.
    I opened Task Manager to see CPU was 90% I looked to see what was causing this and did notice the Service Host: Local System (20). This is moving from 47% to 65% and slowly my CPU is now bouncing around with that Percentage. When I open a application if skyrockets to 90%.
    One of the 20 is Windows update but when I go and manually check for updates it just keeps 'searching for updates' and after 5 mins I closed it.
    I can't remember if that is normal to have CPU at that percentage. Anyone Know?
    Also is it normal to have Service Host: Local System at (20) ?

    cheers
      My ComputerSystem Spec
  2.    08 Oct 2015 #2
    Join Date : Jun 2015
    N.Y.
    Posts : 3,056
    Windows 10 Pro 64 bit

    Do full system scan with your AV for starters. Sometimes difficult to locate what process is using this from service host, good article here,although applies to Windows 8 can be used to track the process.

    http://www.online-tech-tips.com/comp...igh-cpu-usage/
      My ComputerSystem Spec
  3.    08 Oct 2015 #3
    Join Date : Feb 2015
    Posts : 157
    Windows 10 Pro
    Thread Starter

    Thank you for the reply. I shall read that link and perform a full scan.
      My ComputerSystem Spec
  4.    08 Oct 2015 #4
    Join Date : Jun 2015
    N.Y.
    Posts : 3,056
    Windows 10 Pro 64 bit

    Quote Originally Posted by Scramjet View Post
    Thank you for the reply. I shall read that link and perform a full scan.
    Your welcome, hard to identify these as can be used by any program on PC, first rule out infections. Try free malwarebytes to.
    If you can you should also post the Task Managers screen capture of Process, Details and Performance Tabs
      My ComputerSystem Spec
  5.    08 Oct 2015 #5
    Join Date : Feb 2015
    Posts : 157
    Windows 10 Pro
    Thread Starter

    Done a full scan with ESET Smart Security and got nothing so that's good. After 10 mins of searching for updates I finally got an error: 0x800705b4 which is strange cause it is related to Defender and that is disabled by ESET. So now I have to deal with that I guess First time I ever had that error.
    My screen is not big enough to display the long list in process tab and I also opened the 3 that had the processes inside them. Attached in this reply are 5 Processes pics for you to view. I will post another reply with the other 3. Greatly appreciate if you can see anything there that should not be there.
    Click image for larger version. 

Name:	process5.jpg 
Views:	34 
Size:	212.4 KB 
ID:	41757cheersClick image for larger version. 

Name:	process1.png 
Views:	18 
Size:	1.18 MB 
ID:	41752Click image for larger version. 

Name:	process3.png 
Views:	16 
Size:	1.57 MB 
ID:	41754Click image for larger version. 

Name:	process2.png 
Views:	10 
Size:	650.5 KB 
ID:	41753Click image for larger version. 

Name:	process4.jpg 
Views:	8 
Size:	209.1 KB 
ID:	41755
      My ComputerSystem Spec
  6.    08 Oct 2015 #6
    Join Date : Feb 2015
    Posts : 157
    Windows 10 Pro
    Thread Starter

    Sorry for different backgrounds they change with each pic I saved lol.
    Here are the last 3
    Click image for larger version. 

Name:	details1.jpg 
Views:	4 
Size:	263.0 KB 
ID:	41758Click image for larger version. 

Name:	details2.jpg 
Views:	7 
Size:	263.5 KB 
ID:	41759Click image for larger version. 

Name:	performance.jpg 
Views:	6 
Size:	243.9 KB 
ID:	41760

    I hope you can see them clearly.
      My ComputerSystem Spec
  7.    08 Oct 2015 #7
    Join Date : Jun 2015
    N.Y.
    Posts : 3,056
    Windows 10 Pro 64 bit

    Sorry but this does not really help me to know what is using Service Host: Local System (18) which is one shows at times to be using 47% of CPU, expand it in task manager. Needed to try to use link first provided. Do have quite a few processes running, 72
    Try to limit startup items.
      My ComputerSystem Spec
  8.    08 Oct 2015 #8
    Join Date : Feb 2015
    Posts : 157
    Windows 10 Pro
    Thread Starter

    The problem I see when I expand the Service Host: Local System (18) is that it don't show which ones are using what
    It just list them underneath. I will look into the Task Manager again and see. I don't know how to display what each of the 18 processes are using
    I have no idea why I have 72 total. I am thinking most of them are windows applications.

    Thanks for the reply
      My ComputerSystem Spec
  9.    08 Oct 2015 #9
    Join Date : Oct 2014
    Posts : 357
    Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64

    In Task Manager / Performance Open Resource Monitor.
    On the CPU tab select the process that is using a lot of CPU.
    Look at the Services listed for that process.
    Maybe you can find the Service(s) using a lot of CPU, and that will help figure out where the issue is ?

    Also, look at Task Manager / Startup.
    See what you have listed, and temporarily disable any unneeded programs for testing.

    Don't disable your auto start security programs.
      My ComputerSystem Spec
  10.    08 Oct 2015 #10
    Join Date : Feb 2015
    Posts : 157
    Windows 10 Pro
    Thread Starter

    ok that was weird. I went into the Services and found the svchost.exe file that was taking 49% of my cpu and ended it. Now all is working fine and I am back to 1% - 10% cpu usage.
    I don't know unless there was a process that was stuck and never ended. I also clicked the windows update and it checked in a few seconds and I got no error.
    Knock on wood that it stays there. I will wait and see.
    Greatly appreciate all your patience and help.
    PS. yes I have disabled a few of the startup applications I don't need and tomorrow I will uninstall some that I can do without.

    thanks
    cheers
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Win10 high RAM Usage
So i installed win10 a day or so ago and i seem to have ram problems, it tends to go up to 90%+ without anything substantial open http://gyazo.com/590b77727f3fcb3cc710babc4774fdc8 if someone could help or if i need more info let me know
Performance & Maintenance
My ram and cpu usage is very high
Hey guys my cpu and ram usage is pretty high when im not even doing anything. http://prntscr.com/8kgnt8 its on swedish but next to CPU is Memory. i found something called poolmon in windows kits where i could see if there was a driver that...
Performance & Maintenance
Solved high ram usage
most of the time i have ram usage like 40-60, but all of the processes are using like 400 mb and i have 4gb ram. 362463624736248
Performance & Maintenance
High Memory Usage
Hello, I have a question. The system process (ntoskrnl.exe) using excessive amount of RAM. So, how do I fix that? Thanks
Performance & Maintenance
Solved iastordataSvc 32 bit high cpu usage
Hello, My laptop as a problem where IAStorDataSvc (32bit) as unusual high cpu usage. I tried to find new updates but i couldn't find anything related to intel Rapid storage technology. I also installed the update finder from Intel but that...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:11.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums