Windows 10: Sudden Decrease in Performance? Solved

  1.    02 Sep 2015 #1

    Sudden Decrease in Performance?


    Ok, first off, I upgraded to the insider preview a long time ago from Win7 Ulti. I can't recall exactly when, but it was sometime between November and January. When I was still on 7, I was having some intermittent issues, and was thinking about wiping, but then I just upgraded.

    Since then, things have been awesome. (With the exception of the issue with full-screen DX9 apps since 10130 or somesuch. Can't wait for them to fix that.) However, just recently I started having a really odd performance issue. I notice it mostly when I'm opening a browser or Steam. Well, I take that back. The PC will sometimes take a few minutes longer to start up than normal. I forget that one though because I hardly ever turn the PC off or reboot it.

    I have monitored the system when I'm seeing this huge delay, but cannot for the life of me narrow down the cause. CPU is between 3 and 8%. RAM is around 22%, and nothing seems to be hung or clocking. Yet it's taking 3-5 times longer for the application to open up. As if the CPU was busy doing a bunch of other tasks, or the RAM is full and dumping, but neither is the case.

    I'm currently running the standard build and turned off the insider updates. My CPU is an i7-3930, 16GB RAM, and a GTX660Ti GPU. I can upload a Speccy if that would help. I'm leaning towards doing a wipe, but really would like to avoid that if at all possible. I hate spending a week restoring everything and then realizing I missed something in the export.
      My ComputerSystem Spec


  2. Posts : 2,033
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       03 Sep 2015 #2

    Notice that you are using a mechanical HD for Windows. Your HD might be badly fragmented or corrupted.
    Try:
    1. CCleaner - PC Optimization and Cleaning
    2. TFC Temporary file removal tool (Run as Admin)
    3. and defrag your Windows OS HD.
      My ComputerSystem Spec

  3.    03 Sep 2015 #3

    topgundcp said: View Post
    Notice that you are using a mechanical HD for Windows. Your HD might be badly fragmented or corrupted.
    Try:
    1. CCleaner - PC Optimization and Cleaning
    2. TFC Temporary file removal tool (Run as Admin)
    3. and defrag your Windows OS HD.
    Those were the first steps I took, but I don't recall offhand if I ran the TFC. I'll have to give that a shot when I get home.
      My ComputerSystem Spec


  4. Posts : 2,033
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       03 Sep 2015 #4

    In addition you might want to run: chkdsk /r C:
    and also from admin command prompt:
    1. Dism.exe /online /Cleanup-Image /StartComponentCleanup
    2. dism /online /cleanup-image /restorehealth
    3. sfc /scannow
      My ComputerSystem Spec

  5.    03 Sep 2015 #5

    When it happens, bring up task manager and check your disk IO. I've noticed that win 10 loves to peg it a 100% after sign-in for 60 secs or so. So I set steam to not start on signin. I wait for the disk to IO to stop.

    Others have suggested that some 3rd party anti-virus cause problems. If you upgraded and left it on, try removing it.
      My ComputerSystem Spec


  6. Posts : 4,338
    Win 10 Pro x64
       03 Sep 2015 #6

    Having the same issue recently. Upon boot up, the system goes to black screen for about 30 seconds before opening up to desktop. I think it's because of Steam. It's like an OS within an OS or something.
      My ComputerSystem Spec

  7.    04 Sep 2015 #7

    SFC didn't find anything wrong, but running an integrity check on the drive from Partition Manager did show that it was "dirty" and it repaired the file system errors. I also additionally defragged the MFT. After performing all 6 steps, my PC is back to how it was running previously.

    Thanks guys!
      My ComputerSystem Spec


 

Related Threads
Solved 2 User names on logon screen all of a sudden in User Accounts and Family Safety
I just recently reinstalled Windows 10 Pro from scratch 2 days ago. All of a sudden I noticed yesterday evening I have 2 usernames on the logon screen. It normally boots directly into Windows (I turn off requiring password on NETPLWIZ screen). ...
Hello everyone!. I've read a lot issues about this problem. In my case all Fn keys works but the keys related with increase/decrease brightness doesn't works. Also I tried change the brightness by Windows options but the problem continues. ...
hey guys, i used to open several IE screens together, this is no longer possible. What can be done is open a new session via file and then New Window or New Session, but it was easier to open other IE screens via the right mouse click. I...
Any idea what causes this ? Really strange . Works for a while then all of a sudden I get the message stating it doesn't work and hit escape ?
DVD Drive all of a sudden missing in Drivers and Hardware
So according to my bios the dvd drive is there but as soon as Windows 10 boot its not listen anywhere. Anyone else had this issue?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:40.
Find Us