Page 23 of 37 FirstFirst ... 13212223242533 ... LastLast
  1.    02 Apr 2017 #221
    Join Date : Dec 2015
    Athens, Greece
    Posts : 141
    Windows 10 Pro x64

    Quote Originally Posted by lx07 View Post
    When I said one directory level "lower" I may have meant "higher".

    Closer to the root anyway.
    I got that, from reading the script... but thanks for clarifying!
      My ComputerSystem Spec
  2.    02 Apr 2017 #222
    Join Date : Dec 2015
    Athens, Greece
    Posts : 141
    Windows 10 Pro x64

    Quote Originally Posted by fdegrove View Post
    Hi,



    No such issues on 15063 when set to OFF. Service is set to start automatically (delayed start) by default.

    At times it seems problems like these are "machine dependent" which makes computing a bit less uh.... scientific. LOL.

    Cheers,
    I wouldn't know about 15063, I'm in 14393.969 and I had set it to OFF to avoid the nagging toast notification "Your account settings are out-of-date", sometime like 8 months ago!
    Apparently since then MS fixed the problem with the notification, but I didn't know and had left the setting to OFF. That's why since last August, I had something more than1800 of these 7023 errors.... since the setting affected the default Automatic (delayed start) of the Service, which was failing to start and was producing the error. And not only that, but I couldn't even start it manually...
    Since changed it back to ON, the Service starts as it supposed to and NO errors!!!

    I guess it's the definition of the upgrade: "Old bugs out...New bugs in"
    Last edited by ddelo; 02 Apr 2017 at 17:30.
      My ComputerSystem Spec
  3.    02 Apr 2017 #223
    Join Date : Oct 2015
    Posts : 2,114
    Windows 10 Pro X64

    Hi,

    I guess it's the definition of the upgrade: "Old bugs out...New bugs in"
    Yep. Except this time there are far less bugs then ever before in W10 it seems.

    That said, I do not have an extremely complex set up, just a decent pc or two.

    Cheers,
      My ComputersSystem Spec
  4.    02 Apr 2017 #224
    Join Date : Aug 2015
    Posts : 14
    Windows 10 Pro

    Quote Originally Posted by ddelo View Post
    And to close another issue, since I was also battling with this one too....
    Errors 7023 and 10010

    The 7023 error is produced, because the Connected Devices Platform Service fails to start, Automatically by default, in version 1607 and above (in 1511 was set to "Disabled")

    To resolve that, navigate to: Settings > Privacy > General
    Make sure you have the “Let apps on my other devices open apps and continue experiences on this device” to ON and either get into Services and start "Connected Devices Platform Service" which most likely is not running or reboot.

    This will take care of all the 7023 errors and consequently the 10010 produced from this one.
    Thank you! After doing this I no longer get 7023 or 10010 errors.
      My ComputerSystem Spec
  5.    02 Apr 2017 #225
    Join Date : Dec 2015
    Athens, Greece
    Posts : 141
    Windows 10 Pro x64

    You're very welcome!
      My ComputerSystem Spec
  6.    02 Apr 2017 #226
    Join Date : Jan 2016
    Posts : 25
    windows 10

    Quote Originally Posted by RoopeSeta View Post
    Thank you! After doing this I no longer get 7023 or 10010 errors.

    To put "Connected Devices Platform Service" on Automatic in Services.msc ? or just Started with Manual Triggered ?
      My ComputerSystem Spec
  7.    02 Apr 2017 #227
    Join Date : Dec 2015
    Athens, Greece
    Posts : 141
    Windows 10 Pro x64

    Quote Originally Posted by x7007 View Post
    To put "Connected Devices Platform Service" on Automatic in Services.msc ? or just Started with Manual Triggered ?
    If you're on version 1607 it should be "Automatic (Delayed Start)"
      My ComputerSystem Spec
  8.    04 Apr 2017 #228
    Join Date : Nov 2015
    Brunswick, Maryland, USA
    Posts : 31
    Windows 10 Pro x64

    Event ID 10016 DCOM

    I follow the instructions below, and after that I do not get a single error/warning in the System event log.

    You will need to take ownership then set rights against these keys. Make the Administrators the owner of these keys. Give Administrators and System Full Control.

    The keys are:

    HKEY_CLASSES_ROOT\AppID\{9CA88EE3-ACB7-47c8-AFC4-AB702511C276}
    HKEY_CLASSES_ROOT\AppID\{F72671A9-012C-4725-9D2F-2A4D32D65169}
    HKEY_CLASSES_ROOT\AppID\{4839DDB7-58C2-48F5-8283-E1D1807D0D7D}

    HKEY_CLASSES_ROOT\CLSID\{D63B10C5-BB46-4990-A94F-E40B9D520160}
    HKEY_CLASSES_ROOT\CLSID\{8D8F4F83-3594-4F07-8369-FC3C3CAE4919}
    HKEY_CLASSES_ROOT\CLSID\{6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}

    Change DCOM Permissions

    Open DCOMCNFG as an Administrator

    Navigate to Component Services\Computers\My Computer\DCOM Config

    Find these Applications

    RunTimeBroker
    F72671A9-012C-4725-9D2F-2A4D32D65169 (Located near the bottom of the list in 'Detailed View'.
    ShellServiceHost

    Right Click, Properties, Security Tab, Launch and Activation Permissions, Edit

    Add these accounts and give them full control.

    Administrators
    All Application Packages
    Interactive
    Local_Service
    Network
    System

    While changing permissions I was prompted several times to remove bad account references. I did this as the computer knows which accounts have been removed. Give your computer a reboot and away you can go.
      My ComputerSystem Spec
  9.    02 May 2017 #229
    Join Date : Jun 2015
    Posts : 548
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon

    Hello...

    I have decided to try to fix this error, as it is the only one left in my Event Viewer. I have already copied @lx07 's PowerShell script and replaced the Registry keys according to the error I am getting:

    The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {9BA05972-F6A8-11CF-A442-00A0C90A8F39} and APPID {9BA05972-F6A8-11CF-A442-00A0C90A8F39} to the user MYCOMPUTER\Me SID (S-1-5-21-3364268583-2186901574-852866347-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.


    What confuses me, and I am asking for your help, is this:

    - Which Application in the Component Services / DCOM Config corresponds to the Application ID of my error? - And how do I find this?

    Thank you! As soon as someone will reply to me, I will apply the fix.


    Windows 10 Pro, 1703 (build 15063.250) 64 bit

    PS: I have already looked at Runtime Broker and Immersive Shell, in my DCOM Config, but those Applications have different IDs. So which one should I "touch"?

    EDIT: Okay, so after searching my Registry using that ID I found that it has to do with this:

    Click image for larger version. 

Name:	12.png 
Views:	46 
Size:	14.5 KB 
ID:	133056



    I will start the procedure now and report back.
    Last edited by Joanne; 02 May 2017 at 10:27.
      My ComputerSystem Spec
  10.    02 May 2017 #230
    Join Date : Jun 2015
    Posts : 548
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon

    Okay, it seems that it works: I have rebooted twice and powered on, after completely shutting down, three times and no errors at all in my Event Viewer

    One last question, please, and apologies if it has been already answered. This is how I have set it:

    Click image for larger version. 

Name:	OK.png 
Views:	12 
Size:	102.2 KB 
ID:	133059


    The highlighted user is the one I have added, after checking the name.

    - Are the permissions I have set, shown in the screenshot, appropriate / enough? Should I set the two "Remote..." permissions, as well?

    Thank you!
    I am glad I resolved this, no matter how temporary it will be.
      My ComputerSystem Spec

 
Page 23 of 37 FirstFirst ... 13212223242533 ... LastLast


Similar Threads
Thread Forum
Event 10016, DistributedCOM
Since upgrading to Windows 10, my error log is flooded with this message. Over 520 incidents in the past week. The instructions provided for that error in Windows 8 do not work with 10, since it is impossible to grant full permission to the...
Performance & Maintenance
Weird event viewer errors
Hello, Event Viewer is showing the following errors: The User Data Storage_Session1 service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 10000 milliseconds: Restart the service. The User...
Performance & Maintenance
Event Log 7031 Errors on Shutdown
This appears to be a general issue with windows 10, I always get the following errors on shutdown: The VMware Workstation Server service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000...
General Support
Worried about event viewer errors
hi guys managed to install windows 10 and everything seems to be working great. I looked in event viewer and I'm getting loads of errors, the same over and over. one is that keeps coming up is kernel-power event id 137 The system...
Performance & Maintenance
ESENT errors in my Event Log
On Windows 10 Pro x64 I am getting quite a few ESSENT errors in my Event Log after I start up W10. I see Event ID's 413, 455, 488, and 489. If these are indicative of a problem does anyone know the fix? Thanks
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:32.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums