Page 10 of 17 FirstFirst ... 89101112 ... LastLast

  1. Joined : Oct 2015
    Posts : 1,393
    Windows 10 Pro X64
       02 Aug 2016 #91

    Hi,

    Looks good to me.
    Only a few things I want to add for your convenience: no need to close the registry editor whilst your are in DCOM console.
    A reboot is not required immediately. At next restart the error(s) should no longer appear.

    DCOM errors are pretty harmless to begin with. Don't be surprised that they or some of them keep coming back with every update MS releases for as long as MS don't fix these (and they can't seem to be bothered at this point in time) all the configuring we did now will be overwritten.

    You did a great job Marco. This way it should be easier to understand for others as well.

    Cheers,
      My System SpecsSystem Spec


  2. Joined : Nov 2015
    Posts : 14
    Windows 10
       02 Aug 2016 #92

    fdegrove said: View Post
    Hi,

    Looks good to me.
    Only a few things I want to add for your convenience: no need to close the registry editor whilst your are in DCOM console.
    A reboot is not required immediately. At next restart the error(s) should no longer appear.

    DCOM errors are pretty harmless to begin with. Don't be surprised that they or some of them keep coming back with every update MS releases for as long as MS don't fix these (and they can't seem to be bothered at this point in time) all the configuring we did now will be overwritten.

    You did a great job Marco. This way it should be easier to understand for others as well.

    Cheers,


    Thank you fdegrove. So I tried it, and in the first instance, that is RuntimeBroker, method worked just fine, no more DistributedCOM errors. Whereas in the second instance, that is Immersive Shell, it did not work. I'm sure I did everything exactly as described above in my previous post, but the DistributedCOM error keeps coming back as before. Any ideas or suggestions?
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 69
    10 Ent 64
       02 Aug 2016 #93

    New one with redstone upgrade: The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {8D8F4F83-3594-4F07-8369-FC3C3CAE4919} and APPID {F72671A9-012C-4725-9D2F-2A4D32D65169} to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
    Has to do with CDP Activity Store, whatever that is.
      My System SpecsSystem Spec


  4. Joined : Oct 2015
    Posts : 1,393
    Windows 10 Pro X64
       03 Aug 2016 #94

    Hi,

    Whereas in the second instance, that is Immersive Shell, it did not work. I'm sure I did everything exactly as described above in my previous post, but the DistributedCOM error keeps coming back as before. Any ideas or suggestions?
    No suggestions really. The procedure is basically always the same.
    Maybe do it once more and check everything thoroughly ?
    @csmdew : the first hive key is granted to System not TrustedInstaller. The second key is also the DCOM container.
    You will have to add System as a user because it's missing in DCOM.


    Cheers,
      My System SpecsSystem Spec


  5. Joined : Aug 2015
    Posts : 69
    10 Ent 64
       03 Aug 2016 #95

    OK I already had system added but who should be the owner so I can edit the security, it's still grayed out with system as owner. How can I edit the batch file used for runtime broker to fix this one, thanks.
      My System SpecsSystem Spec


  6. Joined : Oct 2015
    Posts : 1,393
    Windows 10 Pro X64
       03 Aug 2016 #96

    Hi,

    In regedit ownership should temporarily be granted to Administrators (plural) for both keys then returned to the original owners after you're done in dcomcnfg.

    In your particular case original ownership of the first key belongs to SYSTEM so you have to keep that in mind.

    Cheers,
      My System SpecsSystem Spec


  7. Joined : Aug 2015
    Posts : 69
    10 Ent 64
       03 Aug 2016 #97

    made changes and after this reboot the 10016 was gone but now the 10010 is back, you would think with all the problems in this area that MS would have fixed it in the upgrade. thanks for the 10016 help now back to solving the other one.
      My System SpecsSystem Spec


  8. Joined : Nov 2015
    Posts : 14
    Windows 10
       04 Aug 2016 #98

    fdegrove said: View Post
    Hi,



    No suggestions really. The procedure is basically always the same.
    Maybe do it once more and check everything thoroughly ?
    @csmdew : the first hive key is granted to System not TrustedInstaller. The second key is also the DCOM container.
    You will have to add System as a user because it's missing in DCOM.


    Cheers,


    Thanks Fdegrove. So, I was reading this thread on EightForums Solved Numerous event id 10016 errors win 8 pro 64 bit when I remembered that, right after assigning ownership from TrustedInstaller to Administrators, there were these other two options, which are supposed to give you permission on all sub-keys:

    - Replace owner on subcontainers and objects

    - Replace all child object permission entries with inheritable permission entries from this object


    Click image for larger version. 

Name:	Cattura38.1.jpg 
Views:	2 
Size:	132.0 KB 
ID:	94049

    Do you think I need to select said options maybe? Will it make a difference with my "Immersive Shell" issue?



    As a side note, on Microsoft Answers forum one user suggested an alternative way as to take ownership and allow permissions without modifying the registry. That is, by launching Component Services as administrator, then
    navigating to My Computer node > Right click > Properties > COM Security tab > Edit Limits.

    Click image for larger version. 

Name:	Cattura39.JPG 
Views:	93 
Size:	57.0 KB 
ID:	94038 Click image for larger version. 

Name:	Cattura40.JPG 
Views:	93 
Size:	33.1 KB 
ID:	94040

    But I cannot tell if this is reliable as a method. Do you think it is safe to try it as a last resort for "Immersive Shell" DistributedCOM error? Needless to say, I'm quite reluctant and hesitant



      My System SpecsSystem Spec


  9. Joined : Oct 2015
    Posts : 1,393
    Windows 10 Pro X64
       04 Aug 2016 #99

    Hi,

    Do you think I need to select said options maybe? Will it make a difference with my "Immersive Shell" issue?
    I don't think so but you can try it out. Basically when you're able to add the user in DCOM and grant the local permissions to that and then return the registry keys to the original owner then that's it.

    The so called second method allows you to add a user but then that user would be added to all the containers ?
    I don't see the point in doing that.

    The Immersive shell DCOM error has been there for a long time but I can't remember it being present with the Anniversary Upgrade.
    Either way, if you follow the basic guidelines and you're able to grant the local permissions for the user in the Event Viewer error message then that's all there's to it.

    One thing I can think of why it doesn't stick is when fast boot is enabled. You could try disabling it, see if that helps and re-enable it once the problem is gone.

    Cheers,
      My System SpecsSystem Spec


  10. Joined : Jul 2015
    Posts : 86
    Dual-boot Win 7 & 10, both Pro 64-bit
       04 Aug 2016 #100

    Hey all, and thanks again for help many months ago.
    With the Anniversary Update, I am now getting the following, and have a new sub-question:

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    {8D8F4F83-3594-4F07-8369-FC3C3CAE4919}
    and APPID
    {F72671A9-012C-4725-9D2F-2A4D32D65169}
    to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
    My sub-question is: why does it say "running in the application container Unavailable SID (Unavailable)"? Should I do anything special because it's "Unavailable SID (Unavailable)"?

    Thanks.
      My System SpecsSystem Spec


 
Page 10 of 17 FirstFirst ... 89101112 ... LastLast


Similar Threads
Thread Forum
Event 10016, DistributedCOM
Since upgrading to Windows 10, my error log is flooded with this message. Over 520 incidents in the past week. The instructions provided for that error in Windows 8 do not work with 10, since it is impossible to grant full permission to the...
Performance & Maintenance
Weird event viewer errors
Hello, Event Viewer is showing the following errors: The User Data Storage_Session1 service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 10000 milliseconds: Restart the service. The User...
Performance & Maintenance
Event Log 7031 Errors on Shutdown
This appears to be a general issue with windows 10, I always get the following errors on shutdown: The VMware Workstation Server service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000...
General Support
Worried about event viewer errors
hi guys managed to install windows 10 and everything seems to be working great. I looked in event viewer and I'm getting loads of errors, the same over and over. one is that keeps coming up is kernel-power event id 137 The system...
Performance & Maintenance
ESENT errors in my Event Log
On Windows 10 Pro x64 I am getting quite a few ESSENT errors in my Event Log after I start up W10. I see Event ID's 413, 455, 488, and 489. If these are indicative of a problem does anyone know the fix? Thanks
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:20.
Find Us
Twitter Facebook Google+



Windows 10 Forums