1. Joined : Aug 2015
    Posts : 5
    Windows 10 Pro
       25 Aug 2015 #1

    COM Surrogate using too much CPU, Thumbnail and Icon problem.


    Hey guys i've been using Windows 10 for almost a month now, and I'm having some issues with it at the moment. I have too much videos and picture for work, that most thumbnail just won't load or generate.

    Issues:
    • Thumbnail not generating
    • This PC/My Computer keeps loading and saying "Working on it" (File Explorer)
    • High CPU usage for COM Surrogate, using 10% of my CPU all the time.


    The way to solve it for me at the moment is killing the COM Surrogate process. But I'm looking for a permanent fix, which doesn't involve me killing the process all the time.

    Killing the process of COM Surrogate will make:
    • Thumbnail and icon to generate (although sometimes it still doesn't)
    • This PC/My Computer instantly loads properly, without it saying "Working on it"


    Any solution guys?
      My System SpecsSystem Spec


  2. Joined : Dec 2013
    England
    Posts : 837
    Windows IP 15007 Windows 14393.693
       25 Aug 2015 #2
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 5
    Windows 10 Pro
       25 Aug 2015 #3

    brummyfan said: View Post
    Does the icaros thumbnailing solve the issue? I'll try that standalone icaros thumbnailing and see how it goes.
    I'm currently using Media Player Classic with combined community codec pack.

    Edit: Looks like using Icaros solves the issue. Less CPU usage from COM Surrogate, and generating thumbnails instantly like on Windows 7 and 8.
      My System SpecsSystem Spec


  4. Joined : Sep 2015
    Chernivtsi
    Posts : 2
    Windows 10
       10 Sep 2015 #4

    Your player is incompatible with your system


    wanabrar said: View Post
    Hey guys i've been using Windows 10 for almost a month now, and I'm having some issues with it at the moment. I have too much videos and picture for work, that most thumbnail just won't load or generate.

    Issues:
    • Thumbnail not generating
    • This PC/My Computer keeps loading and saying "Working on it" (File Explorer)
    • High CPU usage for COM Surrogate, using 10% of my CPU all the time.


    The way to solve it for me at the moment is killing the COM Surrogate process. But I'm looking for a permanent fix, which doesn't involve me killing the process all the time.

    Killing the process of COM Surrogate will make:
    • Thumbnail and icon to generate (although sometimes it still doesn't)
    • This PC/My Computer instantly loads properly, without it saying "Working on it"


    Any solution guys?
    Your player is incompatible with your system. I just solved this issue by uninstalling 32 bit VLC Player and installing 64 bit version.
      My System SpecsSystem Spec


  5. Joined : Oct 2016
    Dallas
    Posts : 1
    Windows 10
       02 Oct 2016 #5

    am13 said: View Post
    Your player is incompatible with your system. I just solved this issue by uninstalling 32 bit VLC Player and installing 64 bit version.
    Thanks! I did this and it took care of the problem!
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Photo thumbnail picture
When opening a folder containing pictures how do I get win 10 to show a thumb nail size image
General Support
Thumbnail Cache - Clear and Reset in Windows 10
How to Clear and Reset the Thumbnail Cache in Windows 10 Windows keeps a copy of all your folder, picture, video, and document thumbnails in a cache so they can be displayed quickly when you open a folder instead of having to manually scan and...
Tutorials
Windows 10 and 768x768 thumbnail size?
Hi Everyone, I'm not sure if this is something coming to windows 10 or if its there but not available on my system. I was under the impression with windows 10 came the extra extra large icon sizes (512 and 768) to better support higher resolution...
General Support
COM Surrogate has stopped working error, No sound
Recently I started getting the pop-op error stating "COM Surrogate has stopped working". At the time I was running Windows 7 and had recently updated my video drivers. I went ahead and updated to Windows 10, hoping that the update would fix the...
BSOD Crashes and Debugging
Problem with USB eject icon
On windows 10 (10240 build with all updated), lately I have a problem with the "eject usb" icon in taskbar, when I have a External HDD or USB in my PC (any USB 2.0 or 3.0 port) and then I do click in "safely remove hardware" in the eject icon, I...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:50.
Find Us
Twitter Facebook Google+



Windows 10 Forums