Windows 10: HPET automatically re-enabling itself after every startup

  1.    20 Aug 2015 #1

    HPET automatically re-enabling itself after every startup


    Hello,
    One of the games I play (Warthunder) only runs smoothly when the High Precision Event Timer is disabled through the elevated cmd command:

    Code:
    bcdedit /deletevalue useplatformclock
    After the command completes, I restart. At this point, HPET has been successfully disabled and everythings fine. But for some reason every time I restart without entering the CMD command beforehand, it turns itself on again. Is this an intended effect, and is there any way I can keep HPET disabled throughout multiple restarts?

    Also, in the BIOS, there is an option called ACPI HPET table, which was by default enabled. I tried disabling it but it seemed to have no effect on whether HPET was enabled or disabled.

    Thanks for your help.
      My ComputerSystem Spec

  2.    07 Sep 2015 #2

    me too, since I had Windows 7. Also on my system the useplatformclock even with hpet on bios disabled cause freeze.

    It's unbeliaveble that a parameter for debug purpose (said by Microsoft) it's enabled by default maybe by the Amd drivers.
      My ComputerSystem Spec


 

Related Threads
How to Automatically Sign in to User Account at Startup in Windows 10 Windows 10 has a new sign in screen that is more modern and touch friendly. By default, you need to dismiss the lock screen and enter your credentials on the Sign-in screen to...
Hello everybody. What started out as a request for guidance ended up with me solving my own problem. Thought I may as well pass on my findings anyway just in case it helps somebody else in the same situation. So over the weekend, through a series...
Hi all, After upgrading to Windows 10, my PC will not go to sleep automatically nor will the displays turn off after the specified time (10 minutes). If I put it to sleep manually from the Start menu, it will go to sleep and usually stays that...
Whenever I activate Cortana either by clicking the little microphone icon near Ask me anything bar or by WinKey + C, the sound level of my microphone changes to 62, so I several times went to Recording Devices -> Right click on Microphone ->...
Hello, My wife is currently using build 10130, and is trying to use her SATA HDD (which was her 2nd HDD) externally, with a SATA to USB adapter. However, on plugging the HDD in, all that shows as new in Devices and Printers is the following "USB...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:05.
Find Us