Cortana/Windows Search Issue: default directory, crumb argument error?

  1. Posts : 4
    Windows 10 Home 64-bit

    Cortana/Windows Search Issue: default directory, crumb argument error?

    I'd like to be able to search for the term "maxthon" and have the shortcut I keep in my Links folder (Users > Coaxsist > Links) show up as the first result so that I may hit return to select that result, follow the shortcut and run the program. This exact process worked perfectly in my Windows 7 installation before my Windows 10 upgrade.

    I've outlined the process that I encounter that I'd like to fix below
    1. I type "maxthon" expecting my shortcut within the "Links" folder to appear as the first result
    2. instead a link to is displayed as the top result immediately followed by the directory in which I keep the installer for the maxthon browser
    3. below those two results are a bunch of web search suggestions
    4. not having found what I intended to search for, I click "My Stuff"
    5. this returns only (with the default, widest search parameters active) the aforementioned directory in which I keep the maxthon installer
    6. still not having found what I intended to search for, in the section "Other places to look" I click "File Explorer"
    7. a window opens with "Search Results in Local Disk (C:); .minecraft" in the address & title bars. the results displayed are the aforementioned directory in which I keep the maxthon installer, the installer itself and FINALLY the shortcut I was expecting to find in the beginning... even though that, or the other files I've confirmed are not in that directory.
      1. note the actual file path for this window is the following file I've attached: Search Issue Address Bar.txt

    Why does it appear Windows is searching only the ".minecraft" directory?
    Why are files that aren't in that directory being displayed as if they were?
    How can I fix this so it behaves as I expect? Is this an error on my part somehow?

    I've already done these to try and fix this myself:
    1. rebuild the index
    2. deselected some unnecessary folders & removed ".minecraft" from the indexed locations
    3. ensured the folders I wanted indexed were indeed selected
    4. reinstalled cortana via a powershell command I found (even though that's a bit above my skill level)

    Any help is greatly appreciated. Thanks.
    Last edited by Coaxsist; 20 Aug 2015 at 02:24. Reason: added steps I've taken to fix this myself
      My Computer

  2. Posts : 4
    Windows 10 Home 64-bit
    Thread Starter

    My Solution

    After browsing this thread and trying some things, my search capabilities function just as I want.

    I noticed search was fixed immediately after I followed this procedure I found on page 13 of the above linked thread:
    • anonclay03 said:
      Windows + R" and then typing "services.msc" find "windows search" and then double -click
    • In the window that popped up I saw an option with a check box "Allow service to interact with desktop"

    After checking that box and testing search, I noticed. I then UN-checked the box and search still worked though :/. I figured I'd at least post MY fix as it seems to have worked for me.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:13.
Find Us

Windows 10 Forums