Windows 10 only using half the installed RAM

Page 2 of 2 FirstFirst 12

  1. Posts : 5,829
    Win 11 Pro (x64) 21H2
       #11

    Those AMD boards (systems) give me fits so I'm not going to venture what's going on there - strictly familiar with Intel.

    That said, under System Configuration, "Boot" tab, "Advanced options". Does the OP have that "Maximum Memory:" box checked? If so, uncheck it and go from there. Might also uncheck "Number of processors:" if checked.
      My Computers


  2. Posts : 4,594
    Windows 10 Pro
       #12

    Hell, my Z170 only uses 61.2 MB for Hardware Reserved.

    I was looking to see if the CPU or the Board could be the culprit but they check out, so that only leaves the GPU, but dam 32GB.

    AMD Ryzen™ 7 1800X Processor | AMD

    GA-AX370-Gaming K7 (rev. 1.0) Specification | Motherboard - GIGABYTE U.S.A.
      My Computers


  3. Posts : 16,140
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install
       #13

    Hello @digdug,


    Just for information.

    [1] Have a look to see if there is a BIOS update. Sometimes this can affect how the memory is designated for use.
    [2] Have a look at this => SOLVED: Windows 10 Won’t Use Full RAM

    I hope this helps.
      My Computer


  4. Posts : 7,484
    Windows 10 Home 20H2
       #14
      My Computer


  5. Posts : 4,594
    Windows 10 Pro
       #15

    I`ve seen this before when the CPU has a built in GPU, if you go into the Bios and disable it, maybe that would work.
      My Computers


  6. Posts : 3
    windows 10 pro 20h2
    Thread Starter
       #16

    Ok so the problem with two sticks being stuck in reserved resolved itself magically. I'd like to think it was due to some ubernerding, but no. This board has a dual BIOS, and as I mentioned in the OP, I had one of the BIOS already flashed to the latest (and most likely last) version (F50d). I switched back to it, reconfigured a few things unrelated to memory, had issues with windows booting from the new NVMe M.2, did the old RAM stick shuffle and pulled out two, did a windows update past 20H2, updated the graphics drivers, slid the other two sticks of RAM back in and BAM! It just works now.Windows 10 only using half the installed RAM-winmemperf2.jpg
      My Computers


  7. Posts : 5,200
    Windows 11 Home
       #17

    Try this, run CMD as admin and copy/paste, restart.
    Code:
    bcdedit /deletevalue {current} removememory
    bcdedit /deletevalue {current} truncatememory
    bcdedit /deletevalue {default} removememory
    bcdedit /deletevalue {default} truncatememory
    Matthew Wai said:
    Why does the OP's hardware use as much as 32.1 GB? Mine uses only 99.8 MB.
    Integrated GPU in CPU/motherboard uses RAM as VRAM, but it can be used by other devices.
      My Computer


  8. Posts : 4,594
    Windows 10 Pro
       #18

    Awesome
      My Computers


  9. Posts : 17,349
    Windows 11 Pro
       #19

    The Ryzen 7 1800X does not have integrated graphics.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:10.
Find Us




Windows 10 Forums