PC slow performance after Restoring from "System Image" backup..Help!!


  1. Posts : 17
    win 10
       #1

    PC slow performance after Restoring from "System Image" backup..Help!!


    Hello,

    I recently restored from a earlier full system image backup and since then the pc is acting somewhat slowly,


    • right click on a folder takes longer time
    • right click on hard disk in "My computer" takes long time
    • clicking on nvidia control panel takes very long time
    • Opening a jpg file via photos app takes long time.


    I tried reinstalling graphics driver via DDU, ran sfc /scannow, ran system maintenance troubleshooter and the issue persists...So far ive seen only these issues..

    Can someone please help me how to fix this hiccup? I don't want to reinstall everything from scratch...

    My windows version is 1909 (OS build 18363.418)
      My Computer


  2. Posts : 6,194
    Windows 11 Pro - Windows 7 HP - Lubuntu
       #2

    As you restored to an old build (1909) WU is downloading and preparing to upgrade to 2010 (20h2). You can try to open WU page and install the update ASAP.
      My Computers


  3. Posts : 17
    win 10
    Thread Starter
       #3

    Megahertz said:
    As you restored to an old build (1909) WU is downloading and preparing to upgrade to 2010 (20h2). You can try to open WU page and install the update ASAP.
    Actually I disabled Windows update, in group policy and in other ways...Its working fine in safe mode without issues, Anyways i finally reset the pc which installed everything new and removed all my softwares...
      My Computer


  4. Posts : 6,194
    Windows 11 Pro - Windows 7 HP - Lubuntu
       #4

    josephkarthic said:
    Actually I disabled Windows update, in group policy and in other ways...Its working fine in safe mode without issues, Anyways i finally reset the pc which installed everything new and removed all my softwares...
    Is it now working as it should?
      My Computers


  5. Posts : 17
    win 10
    Thread Starter
       #5

    Megahertz said:
    Is it now working as it should?
    Yes it does, But it seemed like a new installation to me..took so much time than a normal clean install and most of the settings have changed except desktop icons and such...
      My Computer


  6. Posts : 6,194
    Windows 11 Pro - Windows 7 HP - Lubuntu
       #6

    Good
    Please mark this thread as Solved.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:54.
Find Us




Windows 10 Forums