why is W10 so slow ?


  1. Posts : 69
    windows 10
       #1

    why is W10 so slow ?


    Just upgraded to 10 from 7 and it went pretty well except for one thing. Everything from the browser (especially youtue vids which take long to start playing) use to windows itself seems slow and buggy like what you get when you have too little memory. And i DO have a fairly low amount (8GB) but not for things like browsing and windows. For gaming, sure thats low, but even thats less laggy/slow than windows and browsing. I have turned a lot of things off but to no avail.
    Also, i am the only person on this PC and therefore considered admin and the PC does say i am. Yet it doesn't let me turn some things off in services. Why is that and is there a way to change that? I never had that issue with 7. Turning certain things off may well help me figure this out but when i can't it's just that much harder to fix this thru process of elimination. Thanks for any help u can give.
    Last edited by hepme; 22 Jul 2020 at 11:42.
      My Computer


  2. Posts : 7,484
    Windows 10 Home 20H2
       #2

    hepme said:
    And i DO have a fairly low amount (8GB) but not for things like browsing and windows.
    I have 6 GB only. Both Windows and my browser work fine. Try clean installing Windows 10.
      My Computer


  3. Posts : 69
    windows 10
    Thread Starter
       #3

    Matthew Wai said:
    I have 6 GB only. Both Windows and my browser work fine. Try clean installing Windows 10.
    That would be like asking to level a major US city and rebuild it from scratch. Not gonna happen even if i have to live with the issue.
      My Computer


  4. Posts : 2,487
    Windows 10 Home, 64-bit
       #4

    Youtube made a major change perhaps 2 or 3 months ago that causes a video page to load more slowly than previously. I read the details, but don't recall them.

    As far as I know, the change affects everyone equally, regardless of OS.

    In my case, the time for the page to load went from perhaps 2 seconds to perhaps 6. A video still begins playing as quickly as ever once you poke the play arrow, but the first access to that web page takes longer.
      My Computer


  5. Posts : 69
    windows 10
    Thread Starter
       #5

    ignatzatsonic said:
    Youtube made a major change perhaps 2 or 3 months ago that causes a video page to load more slowly than previously. I read the details, but don't recall them.

    As far as I know, the change affects everyone equally, regardless of OS.

    In my case, the time for the page to load went from perhaps 2 seconds to perhaps 6. A video still begins playing as quickly as ever once you poke the play arrow, but the first access to that web page takes longer.
    Not the case for me. I never had and issue with 7 even up till i upgraded to 10 just a few days ago. Then on 10 it now takes about 15- 20 seconds for a youtube video to load.
      My Computer


  6. Posts : 25,076
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #6

    hepme said:
    Everything from the browser (especially youtue vids which take long to start playing) use to windows itself seems slow and buggy like what you get when you have too little memory. And i DO have a fairly low amount (8GB) but not for things like browsing and windows....

    Welcome to Ten Forums hepme.

    I have some machines with just 4GB that have no trouble playing Youtube videos.

    One question is which Browser are you using? Both the Legacy Edge and IE seem a little slower to start playing a Youtube video than Firefox that I use as my default browser, but only by a second or so. You could try another browser or upgrading to the new Chromium Edge.

    More generally, slow/jerky video suggests you need to check you have the latest video drivers installed, especially if you use Nvidia.
      My Computers


  7. Posts : 2,487
    Windows 10 Home, 64-bit
       #7

    Hepme:

    How long ago did you upgrade to 10?

    What does Task Manager say about disk activity and RAM usage?

    Do you have 50 processes running or 150?
      My Computer


  8. Posts : 69
    windows 10
    Thread Starter
       #8

    I have minimal processes running, thats something i am anal about. Anyways, Youtube works fine now after I updated firefox much as i hate to do that. (because it usually seems to wipe out some things i need) Windows seems a bit better after finding a youtube video about settings to turn off and that apparently helped. Not sure how much just yet but so far nothing is as slow as it was. So i think i'm good now but we shall see and if not, as arnold would say, i'll be back...
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:22.
Find Us




Windows 10 Forums