Found something new in Build 2004 with Defragment and Optimize Drives

Page 7 of 8 FirstFirst ... 5678 LastLast

  1. Posts : 4,224
    Windows 10
       #61

    I saw a comment at Win10.Guru today claiming that the TRIM operation did not actually run, asking me to look at my Event Viewer status. I did, and while I can't speak to the poster's system, here's what event viewer told me when I fired off a TRIM on my system/boot SSD just now:
    Found something new in Build 2004 with Defragment and Optimize Drives-image.png
    As far as I can tell, the status message means the TRIM operation completed successfully on that PC. Anybody know otherwise?
    Thanks,
    --Ed--
      My Computers


  2. Posts : 4,026
    Windows 10 Pro x64, Various Linux Builds, Networking, Storage, Cybersecurity Specialty.
    Thread Starter
       #62

    EdTittel said:
    I saw a comment at Win10.Guru today claiming that the TRIM operation did not actually run, asking me to look at my Event Viewer status.
    I did, and while I can't speak to the poster's system, here's what event viewer told me when I fired off a TRIM on my system/boot SSD just now:

    Found something new in Build 2004 with Defragment and Optimize Drives-image.png

    As far as I can tell, the status message means the TRIM operation completed successfully on that PC. Anybody know otherwise?
    How much time had elapsed on the person's system, since the last TRIM?

      My Computer


  3. Posts : 13,934
    Windows 10 Pro X64 21H1 19043.1503
       #63

    EdTittel said:
    I can now confirm this status is resetting on my 2004 PCs (all of which have SSD boot/system drives). Despite running TRIM yesterday, here's what I see this morning. Note: all drives, both SSDs and HDDs, are affected.
    Attachment 284162
    Thanks for brining this to everybody's attention @Compumind. Wonder how long it'll take MS to fix this?
    --Ed--
    Exactly what I saw. Ran Optimize on all drives, now it looks like this:

    Found something new in Build 2004 with Defragment and Optimize Drives-image.png

    I'll check it again tomorrow and see what it looks like.
      My Computers


  4. Posts : 43
    Win 10 Pro x64 2009 (20H2)
       #64

    The Optimize panel on my machine shows 6 volumes which are spread across 4 physical SSDs. I only have SSDs. When I try to disable automatic optimize I can only disable any 5 out of the 6. If I deselect all volumes then the OK button becomes disabled. Anyone else have this problem?
      My Computers


  5. Posts : 13,934
    Windows 10 Pro X64 21H1 19043.1503
       #65

    Mine are back to Never run already, just two hours:

    Found something new in Build 2004 with Defragment and Optimize Drives-image.png
      My Computers


  6. Posts : 7,089
    Windows 10 Pro 64 bit
       #66

    Ztruker said:
    Mine are back to Never run already, just two hours:

    Found something new in Build 2004 with Defragment and Optimize Drives-image.png
    Same here. This is an obvious bug which should have been fixed prior to release.
      My Computers


  7. Posts : 123
    Ten
       #67

    That's what I saw too. I ran mine and then a day or two later it said that I need to run it. Back in 1909 I do recall that my schedule was once a month and it stuck to that and I saw the date and time stamp. But on 2004 this "Needs optimization" just after running again is strange.

    I checked my logs again and the time stamps were about 15-30 minute apart; and that time was when I just booted up and was just searching the web, downloading some updates and updating Excel files. Never got advised that optimization was going on.

    Hopefully this will get resolved, bad enough when the Samsung "Unsafe Shutdown" issue cropped up. Now this
      My Computer


  8. Posts : 109
    Windows 10 Pro
       #68

    From what I read this is an old bug. Since windows doesn't remember when was the last time it ran the fragmentation it runs it everyday. Even more, I've read somewhere that it performs defragmentation on SSDs. That's why I turned it off for now and perform Trim by ssd's vendor program.
      My Computer


  9. Posts : 4,026
    Windows 10 Pro x64, Various Linux Builds, Networking, Storage, Cybersecurity Specialty.
    Thread Starter
       #69

    Microsoft really need to fix this.
    What a PITA!

      My Computer


  10. Posts : 19,215
    W11+W11 Developer Insider + Linux
       #70

    Compumind said:
    Microsoft really need to fix this.
    What a PITA!

    This is certainly a great confusion. Is Defrag and Optimize actually working right and onlynot showing or is it doing some underhanded things like actually defragging what should not be defraged like SSDs even when it's turned off ?
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:42.
Find Us




Windows 10 Forums