Page 1 of 3 123 LastLast

  1. Joined : Aug 2015
    Posts : 12
    Windows 10
       11 Aug 2015 #1

    Incredibly slow file transfer


    It starts at around 300MB/s but after a second it drops to 20MB/s. On Windows 7 it was usually around 100MB/s. This is for transferring to second hard drive. It's even slower transferring to USB drive, about 2 MB/s.
      My System SpecsSystem Spec


  2. Joined : Aug 2015
    Posts : 1
    Windows 10
       18 Aug 2015 #2

    Same issue


    nights said: View Post
    It starts at around 300MB/s but after a second it drops to 20MB/s. On Windows 7 it was usually around 100MB/s. This is for transferring to second hard drive. It's even slower transferring to USB drive, about 2 MB/s.
    Hey man, Im having the same issue as you. everything else is running fine, but im getting extremely low transfer rates across the board. Im getting similar results when transfering files between internal drives with SATA connections as i am with external drives connected through USB. I didnt see any answers on here yet, but I hope someone chimes in.
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 3
    Windows 10 Pro 64-bit
       02 Sep 2015 #3

    Also having this issue. 8 second to 2 minute startup, one or the other at random. Since the OS drive is an SSD I have quite a lot of programs using both drives and it's really been interfering with my productivity.

    The WD 2TB drive that is averaging 13MB/s on read and 70MB/s on write with Crystal Disk Mark. It went through a ~13 hour diagnostic with the manufacturer utility software and came out flying colors. I searched for more comprehensive testing software and tripped over a thread of someone using the same model HDD. At the very least the results should be comparable, but they are not even close:

    Click image for larger version. 

Name:	ComparisonHDD.JPG 
Views:	24 
Size:	237.8 KB 
ID:	35292

    The chipset drivers have been updated with the latest Intel has to no effect.

    My next move is to switch cables and move the drive to another SATA port, but I doubt it will make any difference. After that I'm ready to just wipe the drive and do a clean install.

    It might also be worth noting that my SSD IOPS has been chopped nearly in half since the upgrade:
    Click image for larger version. 

Name:	SSDBench.JPG 
Views:	7 
Size:	46.6 KB 
ID:	35297

    Keep in mind that this is with Rapid Mode enabled, and I had to use the 4.4-4.7 method of installation/update to get it working, so it might not be connected at all.
      My System SpecsSystem Spec


  4. Joined : Aug 2015
    Posts : 3
    Windows 10 Pro 64-bit
       02 Sep 2015 #4

    Welp, I was wrong, changing the port had a drastic effect. It isn't near what it should be, but it's serviceable. The OS SSD is now the only drive on the Intel 6Gb/s port(s); it had slight gains on IOPS (not worth showing). After using the Magician benchmark tool quite a bit today, the results seem a little too random to be reliable. The secondary shares the 3Gb/s with a blu-ray drive:

    Click image for larger version. 

Name:	SecondaryDriveIntel3Gbp_s.png 
Views:	294 
Size:	43.5 KB 
ID:	35358

    Click image for larger version. 

Name:	MagHDD_IntelSATA3Gb_s.JPG 
Views:	296 
Size:	45.3 KB 
ID:	35353

    Just for giggles I turned the Marvell controller on (never has been reliable on my board) and tested throughput.

    Click image for larger version. 

Name:	MagHDD_MarvellController.JPG 
Views:	296 
Size:	45.2 KB 
ID:	35354

    Something is definitely holding it back, and it's tied to Windows 10 and the particular upgrade path and/or the driver set being used. I'll have to research the symptoms a bit more before I get a good idea as to what is really going on. I also have an HP laptop with a WD secondary drive and an 840Pro OS drive. Now that the desktop secondary drive is on a different port set, it has nearly the same throughput as the laptop secondary drive. A pattern is starting to form. I'm really tempted to do a clean install of the OS. Has anyone encountered this problem after a clean install?
    Last edited by Aeroflux; 03 Sep 2015 at 11:22.
      My System SpecsSystem Spec


  5. Joined : Oct 2015
    Posts : 1
    windows 10
       11 Oct 2015 #5

    i too have the same problem...


    every usb i have tried external hdd or usb 3.0 pendrive, all slow down to usb 2.0 transfer speed....there is an initial burst speed but the speed soon decreases to about 10 mbps....i am fed up of it....i have a transcend hdd and and same hdd gives constant speed of over 90 mbps on windows 8 or 7...i also tried connecting my laptop and pc both running win 10 pro 64 bit via ethernet cable, both are gigabit ethernet but yet the transfer speed was about 10 mbps-15 mbps...i have all latest drivers and also tried intel rapid storage drivers but all in vein....another problem i have is that windows 10 restarts sometimes instead of shutting down and i have to shut it down again. this windows is the buggiest windows till date
      My System SpecsSystem Spec


  6. Joined : Nov 2015
    Posts : 1
    Win 10
       09 Nov 2015 #6

    I am having the same problem. I get excellent file transfer speeds on my windows 7 machines but not windows 10. If I transfer a file from my win7 desktop to my win10 desktop its super fast 100+ megabytes per second. If I transfer from my win10 to ANY other device on my network it goes incredibly slow.

    This is transfering from win7 to win10.
    Click image for larger version. 

Name:	from 7 to 10.PNG 
Views:	261 
Size:	27.5 KB 
ID:	47139

    This is from win10 to win7.
    Click image for larger version. 

Name:	from 10 to 7.PNG 
Views:	260 
Size:	9.4 KB 
ID:	47140

    Why is it that my windows 10 desktops can receive files at top speeds but can't transfer out?
      My System SpecsSystem Spec


  7. Joined : Nov 2015
    Posts : 2
    Win 10
       29 Nov 2015 #7

    I had this same problem in windows 7 so I went to windows 10 hoping this problem was fixed but no such luck. I am thinking that the slow speed is because windows is updating the file indexing feature (to allow for fast file name searches) during the copy process and slowing everything to a crawl. Does anyone know how to turn that feature off? - maybe that would help solve the problem.
      My System SpecsSystem Spec


  8. Joined : Nov 2015
    Posts : 2
    Win 10
       29 Nov 2015 #8

    Indexing may not be the problem - look at this post on how to disable Write-cache Buffer Flushing - this solved my problem but it comes with a concern if power goes out.

    Windows 10 10240 Slow Copy
      My System SpecsSystem Spec


  9. Joined : Dec 2015
    Posts : 1
    Windows 7 x64
       23 Dec 2015 #9

    Just wanted to point out that I've also noticed Windows 10 USB copying is very slow.

    Prior to Win10 upgrade, on Win7x64 I transfer from my USB 3.0 external drive to internal RAID0 (or to another external USB 3.0 drive) is around 150 MB/s for 8GB filesize. After upgrade to Win10x64, that transfer speed drops down to no more than 80 MB/s (require several reboots). Most of the time transfer speed is 30-50 MB/s. Because of this (and among other app problems), I reinstalled Win7x64 and plan to stay Win7 for until end of support.

    I am not sure if it has something to do with Win7 upgrade to Win10. I have not tried a clean Win10 install....yet.
      My System SpecsSystem Spec


  10. Joined : Jan 2016
    Posts : 3
    Windows 10 x64
       04 Jan 2016 #10

    I registered just to add to, and follow this thread.

    I'm having the same issues, though not consistently. I am trying to copy roughly 2.5TB of movies from a five disk RAID5 array in a port-multiplier enclosure (via a RocketRAID 2314 card) to a 4TB Seagate USB 3.0 external drive. It would start out around 100MB/s, but then drop to 8-9 MB/s until I canceled the transfer. At first, I thought maybe it was an issue with USB, but further testing showed it was happening across all drives in the system (one SSD, two spinning disks, the two USB 3.0 drives, and the external eSATA RAID array).

    I went through an painstakingly updated all the drivers. I say "painstakingly" because I was able to determine the AMD chipset installer did not install over the older Microsoft USB 3.0 drivers.... so I had to change the hardware controller and hub within the drivers manually. I already had the newest RocketRAID drivers... so not much I could do there. I also double-checked that all the write-caching options were enabled (they were).

    After all that, things changed a little. Sometimes things go fast, sometimes they crawl. I at least having seen the 8-9MB/s transfer again... but things still aren't right:

    - From my RAID array to the USB drive now, I got a speed that fluctuated between 50-80MB/s
    - From my 4TB WD USB 3.0 drive to my 5TB Seagate USB 3.0 drive, I got 150MB/s
    - From one spinning disk to another, an 18GB transfer started at a solid 160MB/s, then dropped to 130MB/s until it was done
    - From a spinning disk to a 5TB x 3 Storage Spaces array (in parity mode), it'll start off fast, then drop to 35MB/s or so

    By biggest concern right now is the horrible read speed I'm getting from my external RAID5 array, which is composed of five 2TB WD Red drives, connected to the PC with a RocketRAID 2314 card that supports port multiplication. I typically get around 150MB/s read speeds from it, and only slightly lower for write speeds. But since installing Windows 10 (clean install), it sucks terribly.

    Transfers to the SS array are the slowest. This *could* be due to parity-related CPU usage, which I can see spike pretty quickly after starting a transfer.... but I don't think so. It is able to maintain a good speed in the 130-140 range before dropping down to 35MB/s. Here is a video of it happening

      My System SpecsSystem Spec


 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
File Explorer extremely slow and unstable.
So I just took part in the Windows 10 Insider Preview a couple of days ago, and I have to say, Windows 10 is a great step up from Windows 8, they did an excellent job so far. There's just one problem: File Explorer is extremely hard to use. Not only...
General Support
Solved File explorer slow with loading thumnails and files
I installed Windows 10 last week as an upgrade from Windows 7, and the internet part is working good. But something with the file explorer didn't work. The Document, Pictures, Music, and Video files are still there, but the thumbnails load slowly,...
General Support
Solved slow complicated file copying
I am using Win10 10240. I have a problem copying a large number of big files. The setup is a bit tortuous. The source is an old WD Cloud NAS on ethernet via my ethernet connected router. The destination is an external hard drive on USB3.0 ...
General Support
Data Transfer from 7 to 10
Hello Everyone, with the new WIN 10 RTM right around the corner, and everyone seem to be getting their systems ready for WIN 10, I was wondering about the Transfer of my current genuine WIN 7 Data on my current machine, to a new install of WIN 10...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:28.
Find Us
Twitter Facebook Google+



Windows 10 Forums