How can I delete $Windows.~BT\NewOS (usual methods don't work)


  1. Posts : 57
    Windows 10 home
       #1

    How can I delete $Windows.~BT\NewOS (usual methods don't work)


    I know this has been asked and answered many times, but I'm still having problems.

    I used windows disk cleanup of system files and this deleted all the folders inside $Windows.~BT except for one (NewOS), but this is a large folder (13.46G containing 84,503 files)!. Disk cleanup never gives me an option to delete old versions of windows. I have tried deleting stuff inside the NewOS folder but I always get "permission denied" despite using all the suggested attrib, takeown, and icacls commands. I've also tried to give myself ownership with full control using the security tab (from folder properties) but it "failed to enumerate objects in the container. Access is denied."

    I have reason to suspect that the NewOS folder is corrupt, but chkdsk and the windows disk scanner all say that there are no disk problems. I also ran the IObit disk checker and it also said that the disk was fine.

    Is there a way to delete $Windows.~BT/NewOS even if the folder is corrupted?

    Thanks
    ~Paul
      My Computer

  2. SIW2's Avatar
    Posts : 1,662
    trying to install win10
       #2

    boot media
      My Computer


  3. Posts : 38,344
    windows 10 professional version 1607 build 14393.969 64 bit
       #3

    If the computer is running low on free space this tutorial has additional options:

    Free Up Drive Space in Windows 10
      My Computer


  4. Posts : 53
    Windows 10
       #4

    Unlocker Portable will let you delete it. You may need to reboot, but it'll remove that stubborn folder.Download Unlocker Portable - MajorGeeks
      My Computer


  5. Posts : 57
    Windows 10 home
    Thread Starter
       #5

    To Siw2 who suggested "Boot Media" - thanks for you suggestion. I know what a boot media is, but what I don't know is what is the relevance to my question. You would have to be more specific before your comment would be useful.

    None of the windows tools was able to delete any of the files in the $Windows.~bt folder. The storage tab from "system" showed that there was about 10G of temporary files, but when I clicked on temporary files it scanned them and then offered a set of selections that totaled far less then 1G. There was no selection in that list for old windows installations. It seems like windows did not recognize those files even though it was pretty clear to me that they were an old windows installation.

    In the link provided by zbook I found this DOS sequence:
    >takeown /F "C:\$Windows.~bt" /A /R /D Y>icacls "C:\$Windows.~bt" /grant *S-1-5-32-544:F /T /C /Q>RD /S /Q "C:\$Windows.~bt"

    That was somewhat different than similar sequences I had found before - especially the cryptic *S-1-5-32-544:F.
    Wow, who would guess that something so wild looking would be required, but this sequence worked where I had only met with complete failure before.

    Unfortunately however, the success was not 100%. It deleted everything except a few dozen folders and files totaling a mere 20 megabytes or so. When I tried to delete the remaining files manually it reported that they were locked, so I loaded LockHunter as was suggested. When I tried to delete them with the unlocker it reported that it can't delete the files but that it could put them on a list of files to be deleted on the next restart. However none of these files were able to be removed by rebooting the system.

    Even though the space taken up by these files is insignificant, I'm highly motivated to remove the rest of the files from $Windows.~bt because I think they are corrupt and are the reason I can't create a system backup using either EaseUsTodoBackup or with AOMEI backuper. (Both programs hang at about 10% completion creating a partial backup file of nearly identical size, and require a reboot to start the computer again). Of course there could me other reasons for this, but I'm guessing both of these programs hang when attempting to backup the $Windows.~BT folder.

    Does anyone have any other idea how to remove these files? Oh, and to make the situation more complicated, I'm trying to fix this computer (owned by my 93-year-old father) remotely using teamviewer. This means I can't fix the problem by booting to a linux rescue disk. I could make the rescue disk, but I don't think I could talk him thru how to use it (given that he is nearly deaf). I was thinking of trying to fix the problem in person, but the facility where he lives is in lockdown and won't let in any visitors.

    ~Paul
      My Computer

  6. idgat's Avatar
    Posts : 909
    Windows 10 Pro
       #6

    pmennen said:
    To Siw2 who suggested "Boot Media" - thanks for you suggestion. I know what a boot media is, but what I don't know is what is the relevance to my question. You would have to be more specific before your comment would be useful.
    When you use a boot media, it doesn't "activate" your OS, so boot media (e.g. Linux Puppy or Mint) allows access to folders/files that may be otherwise "locked" while the OS is running.

    I've actually installed Win 10 on an SSD, then removed it from the computer and stuck it in a USB case. I can boot from that and access a lot of files/folders that are locked/hidden/etc in the booted device's OS.
      My Computer


  7. Posts : 38,344
    windows 10 professional version 1607 build 14393.969 64 bit
       #7

    Run these commands to check the status of the operating system, component store, drive file system an users:

    1) Open administrative command prompt and type or copy and paste:
    2) sfc /scannow
    3) dism /online /cleanup-image /scanhealth
    4) dism /online /cleanup-image /restorehealth
    5) sfc /scannow
    6) chkdsk /scan
    7) net user

    8) When these have completed > right click on the top bar or title bar of the administrative command prompt box > left click on edit then select all > right click on the top bar again > left click on edit then copy > paste into the thread

    9) There are log collectors used in another ten forums room.
    Run each V2 and DM and upload results into this thread:
    BSOD - Posting Instructions
    Last edited by zbook; 21 Mar 2020 at 01:52.
      My Computer

  8. Bastet's Avatar
    Posts : 1,714
    Windows 10 Pro 64bit
       #8

    I would try booting in to safe mode & then delete the folder.
    If this doesn’t work then try the boot device suggestion by SIW2.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:40.
Find Us




Windows 10 Forums