Slow(ish) boot up from M.2 drive...


  1. Posts : 56
    Windows 10. Version 1903. OS Build 18362.239
       #1

    Slow(ish) boot up from M.2 drive...


    Hello,

    I recently fitted an Adata SX8200Pro M.2 drive in my Dell Optiplex. The main C drive is a Liteon SSD. Iíve used Casper to create a bootable clone of the C to the M.2 (the E drive) and by changing the boot up order in the BIOS the Optiplex boots from the M.2 drive. However whereas I expected a quicker boot the actual boot up time is very similar to the C drive.

    For normal computer use that does not involve shifting large amounts of data I wouldnít be expecting a big speed increase but I Ďdidí expect a quicker boot... Iíve checked the M.2 drive using CrystalDiscMk6 and the drive is pretty fast.

    Anyone with any ideas why?

    Thanks.
      My ComputerSystem Spec

  2. Plankton's Avatar
    Posts : 1,337
    Windows 10 Pro
       #2

    Depending on how the M.2 is tied into the mobo. Some M.2 slot are tied into a PCIe lane that the SATA ports use, which there by negates a couple of sata ports. This inturns limits the speed of the NVMe drive. Some have there own PCIe lane and there's no worries. You'll need to find you Dell product specs and see what you mobo is capable of.
    https://www.dell.com/support/home/us/en/19/products/

    Then as I like to call it....the cloning fad. Which is OK for most users.....but what ever issues that data has is then transfer ed to the new drive.Which most of IT guru's like a new clean install on a brand new SSD for maximum performance. Just my personal opinion and what I personally do with new drives.
      My ComputerSystem Spec


  3. Posts : 56
    Windows 10. Version 1903. OS Build 18362.239
    Thread Starter
       #3

    Thanks Plankton.

    Perhaps I should have mentioned the M.2 is a PCIe. My system disc (the C) failed a couple of weeks ago so my present system disc is only a few days old and has very little installed, the OS and a handful of programmes.

    I know some people don't like clones but they've been my preferred means of backup for years. Drive fails - into the BIOS to change the order of boot and bingo - I'm back on the air! Horses for courses as they say.

    Thanks for your input again.
      My ComputerSystem Spec

  4. Plankton's Avatar
    Posts : 1,337
    Windows 10 Pro
       #4

    Is it installed in the M.2 slot of the mobo? So you actual have a NVMe that fits into a PCIe slot?

    It it's installed in the PCIe slot....you'll need to check out the PC specs for that information on lane speed.
      My ComputerSystem Spec


  5. Posts : 56
    Windows 10. Version 1903. OS Build 18362.239
    Thread Starter
       #5

    Thanks Plankton.

    From the OptiPlex Manual:-

    One M.2 PCIe SSD
    M.2 PCIe 256 GB Solid State Drive Class 4
      My ComputerSystem Spec

  6. Megahertz's Avatar
    Posts : 401
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu
       #6

    M.2 is just a connector that uses PCIe fast lake.
    You can attach to it a WiFi card, a SATA SSD or a AHCI or NVMe drive.
    It seams your drive is not a NVMe but a SATA SSD on the M.2 slot, so it will have about same speed of a normal 2.5" SATA disk connected to a SATA port.
    I have a fast AHCI PCIe card. It's very fast on the benchmark test (1950R / 600W), but I can't see the difference from a 2.5" SSD on daily use (same boot times etc)
      My ComputerSystem Spec



  7. Posts : 56
    Windows 10. Version 1903. OS Build 18362.239
    Thread Starter
       #7

    Thanks for your inputs.

    >>> It seams your drive is not a NVMe but a SATA SSD on the M.2 slot, so it will have about same speed of a normal 2.5" SATA disk connected to a SATA port. <<<

    I think I'm right in saying the key ways on the NVMe and SATA M.2 drives are different. My drive is an Adata M.2 2280 PCIe Gen 3x4 SSD and only has one slot or key way in the end which plugs into the socket which would confirm itís an NVMe?

    All the buzzwords confuse me but I Ďthinkí Iím right...

    Iíve run CrystalDisk and the figures seem to confirm the drive is pretty fast.

    I thought I could copy the pretty graphics but somehow theyíve been changed to text, the figures should still be apparent though. Iíve included figures from both the SATA SSD and the M.2 drives for comparison.
    Firstly the SATA SSD :-

    CrystalDiskMark 6.0.2 x64 (C) 2007-2018 hiyohiyo
    Crystal Dew World : Crystal Dew World
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
    * KB = 1000 bytes, KiB = 1024 bytes

    Sequential Read (Q= 32,T= 1) : 559.282 MB/s
    Sequential Write (Q= 32,T= 1) : 495.998 MB/s
    Random Read 4KiB (Q= 8,T= 8) : 402.687 MB/s [ 98312.3 IOPS]
    Random Write 4KiB (Q= 8,T= 8) : 318.797 MB/s [ 77831.3 IOPS]
    Random Read 4KiB (Q= 32,T= 1) : 224.856 MB/s [ 54896.5 IOPS]
    Random Write 4KiB (Q= 32,T= 1) : 205.829 MB/s [ 50251.2 IOPS]
    Random Read 4KiB (Q= 1,T= 1) : 40.306 MB/s [ 9840.3 IOPS]
    Random Write 4KiB (Q= 1,T= 1) : 84.491 MB/s [ 20627.7 IOPS]

    Test : 1024 MiB [C: 25.6% (60.8/237.9 GiB)] (x5) [Interval=5 sec]
    Date : 2019/09/12 9:42:16
    OS : Windows 10 Professional [10.0 Build 18362] (x64)

    Then the M.2 drive:-

    CrystalDiskMark 6.0.2 x64 (C) 2007-2018 hiyohiyo
    Crystal Dew World : Crystal Dew World
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
    * KB = 1000 bytes, KiB = 1024 bytes

    Sequential Read (Q= 32,T= 1) : 3151.428 MB/s
    Sequential Write (Q= 32,T= 1) : 1188.912 MB/s
    Random Read 4KiB (Q= 8,T= 8) : 839.288 MB/s [ 204904.3 IOPS]
    Random Write 4KiB (Q= 8,T= 8) : 664.673 MB/s [ 162273.7 IOPS]
    Random Read 4KiB (Q= 32,T= 1) : 330.610 MB/s [ 80715.3 IOPS]
    Random Write 4KiB (Q= 32,T= 1) : 299.724 MB/s [ 73174.8 IOPS]

    The time it took the M.2 drive to clone my C drive would suggest it's very fast - I'm just intrigued why the PC does not boot up any faster...

    Thanks for your help - and your patience!
      My ComputerSystem Spec

  8. Megahertz's Avatar
    Posts : 401
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu
       #8

    As I wrote on my previous post, a M.2 is just a slot. What you put in the slot will be treated differently depending on the hardware stick.
    Basically, there are two types of M.2 SSD:
    - SATA SSD. It uses the PCIe lane but it's treated by the MB as SATA and the speeds are limited to 600 MB/s. Windows uses SATA drivers.
    - NVMe (Non-Volatile Memory Express) it is much faster. Windows use a dedicated driver, related to the controller it use.

    By the CrystalDiskMark, your disk is a NVMe but as I wrote before, on daily use, it's hard to notice the difference from a regular 2.5" SATA SSD.
      My ComputerSystem Spec


 

Related Threads
Boot Time painfully slow on WD m.2 SSD Drive in Performance & Maintenance
I recently built my PC from scratch and decided to use the: WD Blue 3D NAND 1TB PC SSD - SATA III 6 Gb/s M.2 2280 Solid State Drive - WDS100T2B0B As my Boot Drive / Steam Library. I am however noticing that my System Boot time can exceed 60...
Windows Version 1803 (OS Build 17134.48) From switch-on to desktop start-up sound takes nearly two minutes, and after that there's still a lot of disc activity. Shutdown is equally slow. Once the system has started it takes 30 seconds...
Hello, Today, I was messing around with a PS2 emulator (PCSX2) on my computer, and when I decided to restart the computer to move some files (the file explorer was saying "this folder is in use by another program"), my computer took a whopping...
I updated my system from a Dell XPS 8700 to a Dell XPS 8900. My 8700 had an SSD boot drive and 3 internal HDDs and several USB externals for backup. It worked well for backups. 8900 came with SSD but it was not setup as boot. Boot was a HDD. I moved...
Hi all, I'm using an Intel SSD 240GB 520 series. Always loading very fast, i.e., about 8 seconds from cold boot. Since windows 10 is installed, boot time is about 20 seconds and desktop icons take some time to refresh and load their images. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 05:26.
Find Us