DISM.exe cannot restore health (open handle?) Solved

Page 1 of 2 12 LastLast
  1.    #1

    DISM.exe cannot restore health (open handle?)


    I tried to to a Windows Update. There was an error 0x800f0922. I ran sfc /scannow and there were errors reported that according to sfc Windows could not repair.
    The Windows update troubleshooter did not find any problems.

    I ran dism.exe. It reported that "the component store is repairable". However, dism.exe /Online /Cleanup-image /Restorehealth reported an error 6815 and that "the handle has been invalidated by a transaction. The most likely cause is an open handle when the transaction ended or rolled back to savepoint."

    I would appreciate some help on how to fix this problem.
      My ComputerSystem Spec

  2.    #2

    Try DISM with a clean boot or with a Safe Boot (try Clean boot first - I'm unsure about how it works in Safe Mode :):
    Clean: https://support.microsoft.com/en-us/...oot-in-windows
    Safe: https://support.microsoft.com/en-us/...c-in-safe-mode
      My ComputerSystem Spec

  3.    #3

    Thank you for the suggestion. Finally after reading some postings in Tenforums I followed the steps to do a repair-install of Windows with an in-place upgrade (link: Repair Install Windows 10 with an In-place Upgrade).

    One of the two problematic Windows updates was fixed after the whole lengthy process, but the other one was not automatically updated and when I try to install it in Windows Update it ends with a message that "2019-07 Cumulative Update for .NET Framework 3.5, 4.8 for Windows 10 Version 1903 for x64 (KB4506991) - Error 0x80071a9f". I cannot find anything relevant about this error code. Even installing the update directly from the Windows updates catalog fails.
      My ComputerSystem Spec

  4.    #4

    Try the .NET repair tool: https://www.microsoft.com/en-us/down....aspx?id=30135
    If that doesn't work, uninstall .NET 4.8 and remove .NET 3.5 using the "Turn Windows Features on or off" in the left sidebar of appwiz.cpl

    Did you try DISM w/a clean boot?
      My ComputerSystem Spec

  5.    #5

    Hello, in your case I would try uninstalling .Net frameworks, if possible.

    Here's one find on doing it:

    How to remove and reinstall the Microsoft .NET Framework | AutoCAD | Autodesk Knowledge Network

    That .Net framework repair tool: good idea!

    More that might help:

    4 Ways to Repair or Remove Microsoft .NET Framework • Raymond.CC
      My ComputerSystem Spec

  6.    #6

    I tried Dism with a clean boot. The parameters that I mentioned earlier (
    /Cleanup-image /Restorehealth) which I found on a website do not appear on the command line help for dism (dism /?). So I'm not sure if it worked correctly. Anyway, it reported the same error as before, that is "Error: 6815The handle has been invalidated by a transaction. The most likely cause is the presence of memory mapping on a file or an open handle when the transaction ended or rolled back to savepoint."

    Trying to uninstall .Net by disabling it in Windows Features does not work and I get an error about it.0x800F0922. There are instructions here https://support.microsoft.com/en-gb/help/2734782/net-framework-3-5-installation-error-0x800f0906-0x800f081f-0x800f0907
    , but I don't know where the .Net Framework installation files are located!

      My ComputerSystem Spec


  7.    #7

    DISM should be run with this command:

    DISM.exe /Online /Cleanup-Image /RestoreHealth

    As for the installation files - Search the hard drive for a folder named "Sources" (without the quotes)
    I only seem to have them in the Windows Kits folders (where I installed Debugging Tools and the ADK).
    Dunno if that'll help.

    Found v4.5 installation folders here (on my system): C:\Program Files (x86)\Microsoft SDKs\Windows\v8.1A\ (there'll be other folders than the v8.1A - as I have multiple installed versions on my system)
    Didn't find any install stuff for v3.5 - even though it's on my system (I suspect that's because it was a part of the original installation of Windows)
      My ComputerSystem Spec

  8.    #8

    Thanks for the assistance.

    I couldn't locate a Sources folder on my PC. I have a Microsoft.NET directory in C:\Windows with many subdirectories in but none of them is named "Sources".

    - - - Updated - - -

    Good news!

    Although I didn't expect it the problem was caused by ReHIPS. I had it disabled, yet the problem with Windows Update persisted as I described earlier. After I uninstalled ReHIPS and did a Windows Update, I rebooted the computer and everything is in order.

    Now, back to reinstalling reHIPS.
      My ComputerSystem Spec

  9.    #9

    Good to know. Glad you located it!!!

    FYI - when you install a program such as reHIPS, it installs drivers.
    Drivers load when Windows starts. Then, after a bit, any that you have disabled are disabled - but they are still resident in memory. Although it's not very common, they can still cause problems even when they are disabled.
      My ComputerSystem Spec

  10.    #10

    If dism fails while running while your OS is online, consider running it offline. Boot with either a recovery drive usb or install media to command prompt:

    SFC /scannow /offbootdir=X:\ /offwindir=X:\windows

    DISM /image:X: /ScratchDir:X: /cleanup-image /checkhealth

    DISM /image:X: /ScratchDir:X: /cleanup-image /scanhealth

    DISM /image:X: /ScratchDir:X: /cleanup-image /restorehealth
    where X: is your drive letter

    Here's a little .cmd file I created and put in my C: drive so I can automate the commands:

    Pause
    BCDEdit
    Pause
    SFC /scannow /offbootdir=%1\ /offwindir=%1\windows
    Pause
    DISM /image:%1 /ScratchDir:%1 /cleanup-image /checkhealth
    Pause
    DISM /image:%1 /ScratchDir:%1 /cleanup-image /scanhealth
    Pause
    DISM /image:%1 /ScratchDir:%1 /cleanup-image /restorehealth
    Pause

    It's executed as : winresfcdism.cmd C:

    it's passing the C: to the %1
    the bcdedit command is to determine the correct drive letter to use
    diskpart list volume could also be used or
    wmic logicaldisk get deviceid, volumename, description


    or if you can create your own bootable usbfd winpe using the win10 ADK and add powershell to the image and use these powershell commands:

    CheckHealth: Repair-WindowsImage -CheckHealth
    ScanHealth: Repair-WindowsImage -ScanHealth
    RestoreHealth: Repair-WindowsImage -RestoreHealth
    Last edited by shockwaveriderz; 13 Jul 2019 at 13:03.
      My ComputersSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
DISM Restore Health Error in Performance & Maintenance
Unsure if this is the right forum so apologies if not. Been doing my weekly maintenance and came across this when running DISM commands: 150639 Basically the "Restore Health" says No component store corrution has been found etc" but it only...
DISM Restore Health "source files not found" in Performance & Maintenance
Forgive the redundancy with other threads on this topic, many of which I have read, with no solution... 1. Mounted the ISO from which 1703 Pro was installed. Converted the \sources\install.esd file to a .wim file. 2. Placed install.wim in...
Hi always i install windows from the iso created whith media creation tool i have problems whith dism or sfc, always says i have to repair system. that not happen whith normal iSO. I see iso created whith MCT are install.esd i need to download ...
I downloaded build 15046 with no problems. I like to use Kyhi's program for the DISM utilities. Question: with the new build will "restore health" run? I keep getting can't find "source" error. If so, what is the procedure please?
Been trying for weeks to get the DISM to work despite lots of help in forums...here's my latest discovery: I am running : Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:H:\sources\install.wim:1 /limitaccess Hopefully this is...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:16.
Find Us