1. Joined : Aug 2015
    Posts : 87
    Microsoft Windows 10 Pro 64-bit 10586 Multiprocessor Free
       06 Aug 2015 #1

    Slow boot time on SSD and slow Desktop icons loading


    Hi all,

    I'm using an Intel SSD 240GB 520 series.
    Always loading very fast, i.e., about 8 seconds from cold boot.

    Since windows 10 is installed, boot time is about 20 seconds and desktop icons take some time to refresh and load their images.

    Regarding the boot time:
    I've narrowed it down the an unexplained read/write access on my external HDD eSATA which is used for backups, though currently all backup process are stopped.
    When I remove / turn off my external HDD, boot time is about 8 seconds.
    I can't figure out why all of a sudden it required this access to this HDD.

    As for the slow icon refresh.. I have no idea how to fix this and I was hoping to get some assistance on this as well.


    Thanks!
      My System SpecsSystem Spec


  2. Joined : Jul 2015
    Posts : 1,097
    Windows 10 Pro (64 bit)
       19 Nov 2015 #2

    Sorry it's an old thread. Just wanted to re assure you on the slow icon refresh. Fast startup is enabled on my machine (I have Samsung evo SSD 500 gb as boot drive plus secondary 3TB drive). I never timed it but literally load up of Windows is instant after BIOS. I never used an SSD before, I can't believe how fast it is and wonder whether it's fast startup working some magic or it's the SSD flexing its muscles. However back on topic, I do notice a slight lag on desktop icon refresh. Most are instantly visible but random ones can be generic for a few seconds before flashing up with their proper icon. I think it's relatively normal.
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 87
    Microsoft Windows 10 Pro 64-bit 10586 Multiprocessor Free
       19 Nov 2015 #3

    Thanks for the reply.
    I have sorted this one out.
      My System SpecsSystem Spec


  4. Joined : Jul 2015
    Posts : 39
    win 10 insider preview 10166
       03 Jan 2016 #4

    howdy, gil could you tell us how you sorted your desktop load out as mine is very slow also, boot is only 7 seconds but desktop programs/icons painfully slow
      My System SpecsSystem Spec


  5. Joined : Aug 2015
    Posts : 87
    Microsoft Windows 10 Pro 64-bit 10586 Multiprocessor Free
       03 Jan 2016 #5

    7 seconds is great boot time. That was my issue. Once logged in, I made sure I disabled any startup services and apps which are not required for Windows.
    I then enabled each one until I found the app that caused slow login time.

    As for slow booting, it was a hidden partition that Win10 installation process created on my external HDD. This partition wasn't necessary after Win10 installation was completed. Once I deleted the hidden partition, the boot time went from 24 seconds to about 10 seconds.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Solved File explorer slow with loading thumnails and files
I installed Windows 10 last week as an upgrade from Windows 7, and the internet part is working good. But something with the file explorer didn't work. The Document, Pictures, Music, and Video files are still there, but the thumbnails load slowly,...
General Support
Slow warm boot & Fast cold boot
Hello, My Lenovo laptop is pretty fast at cold boot. It takes about 12 seconds from initial bios screen to desktop. On the other hand, warm boot is really slow. The same period takes about 51 seconds, involving a long black screen. ...
Performance & Maintenance
Slow booting. How do I see drivers loading at boot?
I have a laptop that is about 3 years old. It started to boot very slow (running Windows 7) a few months ago. I updated to Windows 10 (fresh install) hoping it would be fixed. The boot just drags and drags. It might be a hard drive issue...
General Support
Slow boot & shutdown time
10 doesn't seem to be booting very nicely. What I mean is that it seems to be having a difficult time initilizing my SSD, so upon boot I get a blank black screen for anywhere from 60-180 seconds, where the primary drive activity LED is inactive,...
General Support
Very Slow Boot
Until yesterday (New Updates) i have Very Slow Boot and Installed Applications needs so much time to opens. I have Intel Core i5 4670K, SSD Samsung 840 EVO 250GB and 8 GB RAM. Yesterday Computer works normally until today.
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:03.
Find Us
Twitter Facebook Google+



Windows 10 Forums