Windows 10 suddenly takes almost 10 minutes to boot Solved

Page 1 of 2 12 LastLast
  1.    6 Days Ago #1

    Windows 10 suddenly takes almost 10 minutes to boot

    My Windows 10 usually boot from SSD within 30 seconds. Now it takes almost 10 minutes just to get to the login screen. Already tried the following fix with no success:

    - chkdsk
    - sfc /scannow
    - dism /online /cleanup-image /restorehealth
    - driver update
    - cold boot with all startup program disable
    - safe mode (also take very long to boot)

    I also tried using WPA and WPR to capture boot sequence but lacking the knowledge to analyze it.
    Any help would be appreciated.

    WPR Files:
    WPR - Google Drive
      My ComputerSystem Spec

  2.    6 Days Ago #2

    After taking a look at your boot trace, I noticed that there is a lot of disk I/O !
    The call stack shows that these high I/O are caused by iaStorAC.sys module, which is an Intel Rapid Storage file.
    You have the version on your system. There is a newer one ( on the Intel Website

    I'd recommend you first check for this version on your computer's manufacturer site. if there is no newer version there, then download it from the Intel website.

    Hope this will solve your problem.

    Click image for larger version. 

Name:	Capture.PNG 
Views:	5 
Size:	47.7 KB 
ID:	220384
    Click image for larger version. 

Name:	Capture1.PNG 
Views:	98 
Size:	27.4 KB 
ID:	220385
    Click image for larger version. 

Name:	Capture2.PNG 
Views:	1 
Size:	11.4 KB 
ID:	220386
      My ComputerSystem Spec

  3.    5 Days Ago #3

    Thank you for your help. But even after updating Intel Rapid Storage Technology to version the boot time is still the same. I've also attached new WPR after updating driver for you to take a look.

    WPR (01-12-2019).zip - Google Drive
      My ComputerSystem Spec

  4.    4 Days Ago #4

    How about uninstalling Intel's RST and trying MS AHCI driver?
      My ComputerSystem Spec

  5.    4 Days Ago #5

    Yes, sometimes using the ms driver works better than IRST
      My ComputerSystem Spec

  6. Faith's Avatar
    Posts : 642
    Windows 10 Home October 2018 Update 64-bit
       4 Days Ago #6

    Intel rapid storage technology is not needed. Just extract the download to the device manager, hit update (IDE ATA/ATAPi) and it will install the necessary files without the controller interface. Or simply use the Microsoft's ACHI driver instead, which should be automatically installed with the OS.
      My ComputerSystem Spec

  7. Callender's Avatar
    Posts : 902
    Windows 10 Home 1809 32-bit
       4 Days Ago #7

    Try disabling App Readiness Service via Winkey + R then type services.msc

    Disable service then reboot and test.


    Should have said power off completely rather than reboot. Then power on and test.
      My ComputerSystem Spec

  8.    4 Days Ago #8

    Thanks, everyone for your help. Unfortunately, both using Microsoft Standard AHCI and disable App Readiness services also doesn't fix the problem. However when I'm looking in event viewer log. I found a lot of warning with the following messages:

    The application \Device\HarddiskVolume4\Windows\System32\svchost.exe with process id 80 stopped the removal or ejection for the device PCI\VEN_8086&DEV_A102&SUBSYS_79961462&REV_31\3&11583659&0&B8.
    Do you think this is the cause of the long boot time problem?
    Click image for larger version. 

Name:	Annotation 2019-01-13 083853.jpg 
Views:	4 
Size:	214.6 KB 
ID:	220771
      My ComputerSystem Spec

  9. Callender's Avatar
    Posts : 902
    Windows 10 Home 1809 32-bit
       4 Days Ago #9

    I cannot answer your event log question. You should re-enable App Readiness Service.

    Maybe try a clean boot?

    Perform a Clean Boot in Windows 10 to Troubleshoot Software Conflicts | Tutorials
      My ComputerSystem Spec

  10.    3 Days Ago #10

    The device ID "PCI\VEN_8086&DEV_A102&SUBSYS_79961462&REV_31\3&11583659&0&B8" in the event log, corresponds to the Intel SATA AHCI Controller

    Attachment 220861

    Are you sure you are using the Microsoft AHCI driver and not the Intel driver?
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
I've recently started a couple of other threads due to an absurd level of Windows 10 design and implementation screw-ups, but there was nothing that could be done. So I bit the horrifically evil and murderous bullet and re-installed the latest...
Windows 10 build 1709 , restart takes 2-3 minutes. Boot is instant , and shutdown is instant too , only when i try to restart it takes alot to shutdown. However , if i modifi registry to ClearPageFileAtShutdown 0 (1 originally ) and ...
So as the title says, when i want to shutdown or restart my pc it stays on "shutdown" screen for well 30 minutes, i need some help figuring out what causes it. I thought of reinstalling windows but i guess since booting is fine that i don't need...
Boot from Hibernate takes 20+ minutes in Performance & Maintenance
Since fixing my Hanging at Verifying DMI Pool Data issue, I've noticed that if I hibernate my PC instead of shutting down, it takes around 20+ minutes for it to restart. The circle of dots moves very, very slowly. While starting from hibernate,...
HP desktop I just put new hard drive in and installed Windows 10. The Windows 7 hard drive was failing, had no backup or image. Tried to access drive with USB but drive too far gone. Decided to install Windows 10 as an upgrade. After a few minor...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:56.
Find Us