Can't boot Win10 with hyperthreading enabled (dual Xeon)


  1. Posts : 1
    Windows 10
       #1

    Can't boot Win10 with hyperthreading enabled (dual Xeon)


    Hi,
    for a while now I have been unable to enable my hyperthreading and start windows 10 .
    When Hyperthreading is enabled in BIOS, it loads up to the point where the windows logo appears, then loads a couple seconds more, then reboots... in a loop up to the point where you need to recover, but then it still can't recover until I disable HT.

    I can remember in the beginning when I assembled the computer, to test rendering performance on cinema4D with Vray, I was being recommended to disable HT for better performance, so I did some testing with HT on and off. It was better with HT off for vray, so I left it off

    However I recently switched to Corona renderer, but for some reason now I can't get HT back enabled anymore...

    The guys at the computer hardware store had no solution for me, and I really wanted to see if I can benefit from HT on such a powerful machine, therefore I tried posting here too... I feel like I'm missing out on 40 cores... Sad


    Here is a quick overview of the components, built in 12/2016 :

    2x INTEL XEON E5-2698 V4 14NM 2.2-3.6GHZ 50MB 20 CORES --> so a maximum of 80 cores with HT
    ASUS Z10PE-D16 WS --> Bios latest version
    8x KINGSTON 16GB 2400MHZ REG ECC DDR4 KVR24R17D4/16
    SAMSUNG 2000GB 2.5 INCH 850 EVO SERIES MZ-75E2T0B
    CORSAIR HYDRO SERIES H80I V2
    MICROSOFT 64 NL WINDOWS 10 PRO 64BIT OEM - up to date
    CORSAIR AX1500i
    ASUS GEFORCE GTX 1080 STRIX A8G

    now here is the mind breaker:

    When i set msconfig > boot > advanced options > number of cores > unticked
    I cannot boot with hyperthreading, so leaving HT disabled, then

    device manager reads 40 CPU's
    task manager: 2 socket, 40 physical cores, 40 logical cores
    CPU-Z recognizes 2 CPU's with 20 physical/20 threads for each CPU
    render a testframe in 5min54


    When i set msconfig > boot > advanced options > number of cores > 40 (which seems to be the maximum in the list)

    I CAN boot with hyperthreading enabled, but then

    device manager reads 80 CPU's
    task manager: only 1 socket, 20 physical cores, 40 logical cores (so one processor with hyperthreading)
    CPU-Z recognizes only 1 CPU with 20 physical/40 threads
    render a testframe in 5min41, yet somehow cinema4D and windows feel a bit faster

    and msconfig > boot > advanced options > number of cores > still has a maximum of 40


    I already tried clearing CMOS and upgraded BIOS to last available version
    Also for now, I reset BIOS Settings, so everything is at default exept for the HT and boot configuration
    Are there other settings in the BIOS I must change from defaults?

    Any tips are most welcome!
    Feel free to ask more info.
    thanks!
      My Computer


  2. Posts : 1,142
    Windows 10
       #2

    If you want honesty i doubt anybody on the forum been close to such specs to recommend you anything , so this is where you call microsoft hotline , most probably they havent tested windows for such specs either .
      My Computer

  3. EdTittel's Avatar
    Posts : 4,109
    Windows 10
       #3

    Why not run the Windows 10 Pro for Workstations version? This should get you past limitations on the Pro-only version.
    HTH,
    --Ed--
      My Computers


  4. Posts : 38,381
    windows 10 professional version 1607 build 14393.969 64 bit
       #4

    See this link on the pro and con of hyperthreading:
    Hyper-threading - Wikipedia

    Some options for additional information are Intel forums and support.
      My Computer


  5. Posts : 1
    win10
       #5

    Hello there. I haven't been an a+ person for too long but I agree with Mr. Tittle and Nightmayor...This sounds like a software issue with win 10...I'd try a more robust version of win 10 or maybe use a different OS...ie; Linux....try a dual boot. Also check with Microsoft. It sounds to me your version of win 10 just cant handle the power of your system.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:36.
Find Us




Windows 10 Forums