1.    31 Jul 2015 #1
    Join Date : Jul 2015
    Posts : 901
    Windows 10 Home x64

    EnableSuperfetch=0 won't stick after using Regedit


    Hello.

    First of all, I don't want to start a flame war or something about "why would anyone want to disable Superfetch" and such. As gamer I like to run Windows with Superfetch off. It's just a subjective matter of taste.

    Anyway back on topic: Up to Win8.1 I could edit the EnableSuperfetch value in Regedit and set it up as follows:

    0: Disabled
    1: Apps only
    2: Boot only
    3: Apps and Boot (default)

    Now, under Windows 10 everytime I reboot the computer the EnableSuperfetch value gets reset to 3 (default value).

    Any ideas?
      My ComputerSystem Spec
  2.    15 Aug 2015 #2
    Join Date : Jul 2015
    Posts : 901
    Windows 10 Home x64
    Thread Starter

    So far, the only way for me to stop Superfetch is to disable the Superfetch service altogether. Too bad because I have lost the prefetch ability (create .pf and layout.ini files). OTOH I haven't noticed anything performance degrading wise so far. And I have noticed a lot fewer HD accesses. HD seems more silent too. Boot time is still 40s from a SATA2 mechanical HD. Anyways MS should fix this issue or at least tell us why EnableSuperfetch=0 keeps resetting itself after each boot (when the SF service is active).
      My ComputerSystem Spec
  3.    15 Aug 2015 #3
    Join Date : Oct 2014
    Trnava
    Posts : 2,958
    10.4 Home 1709 x64

    Create a batch file with the command and create a task to run it at startup or/and at regular intervals.

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters" /v "EnableSuperfetch" /t REG_DWORD /d 0 /f
      My ComputerSystem Spec
  4.    16 Aug 2015 #4
    Join Date : Jul 2015
    Posts : 901
    Windows 10 Home x64
    Thread Starter

    Thanks.

    I will keep that command for future references. Meanwhile I have left Superfetch managed by Windows. Slightly annoying but it seems to work quite well under w10, even while playing games.
      My ComputerSystem Spec
  5.    20 Aug 2015 #5
    Join Date : Jul 2015
    Posts : 901
    Windows 10 Home x64
    Thread Starter

    Tried the batchfile with the reg command and although it works at session login, Windows keep resetting the value (it actually deletes the EnableSuperfetch=0 value altogether). MOST ANNOYING. I want to disable Superfetch because I am not really interested in the preload feature, but keeping the prefetch one (I have a hybrid rig: mechanical hd + ssd). The OS is on the mechanical hd. This could be done nicely up to w8.1 Too bad Microsoft is shoving Superfetch down our throats.
      My ComputerSystem Spec
  6.    20 Aug 2015 #6
    Join Date : Oct 2014
    Posts : 401
    Windows 10 Pro

    Hm, I might be wrong but shouldn't that be set under "controlset001" instead of "currentcontrolset"? I disabled it there and on my system the setting survives a reboot.
      My ComputerSystem Spec
  7.    20 Aug 2015 #7
    Join Date : Oct 2014
    Posts : 772
    Windows 7

    "CurrentControlSet" is correct. Normally you would never make changes in any of the numbered control sets. There can be several control sets, there being another registry entry determining which one is active. Typically that will be "ControlSet001" but that will not always be the case. Making changes in an inactive control set will do nothing.

    Periodically resetting the registry entry will accomplish nothing as it is only consulted at system bootup.

    Sorry I do not have a solution to your problem.
      My ComputerSystem Spec
  8.    21 Aug 2015 #8
    Join Date : Jul 2015
    Posts : 901
    Windows 10 Home x64
    Thread Starter

    I think there is no solution right now. Windows enforces Superfetch to have its default values. On the bright side, since w7/8.1 Superfetch is quite tamed compared to Vista times. On a dark side, it's too bad we cannot customize it anymore. It's either ON or OFF altogether.
      My ComputerSystem Spec
  9.    11 Sep 2015 #9
    Join Date : Jul 2015
    Posts : 901
    Windows 10 Home x64
    Thread Starter

    Well, I have been able to make Supefetch=0 stick as a registry value (sort of). The trick is delaying the scheduled task for 1 minute. Now, everything is slightly slower but at least the hard disk is quiet now.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Connect To Roku Streaming Stick
I'm on build:10240 and I was wanting to connect my computer to my Roku Streaming Stick. Is there a way to do this on 10240?If so how?
Drivers and Hardware
Solved Can I keep my data & app settings when upgrading from a USB stick ISO?
My system install of build 10162 won't activate, as they pulled the validation from these builds. Unfortunately, I can't upgrade to 10240, which can, I was told by Windows support, be activated. This is because Windows isn't already activated!!!...
Installation and Upgrade
Solved regedit changes
Made a change in HKLM, so that my numloc keys worked on start-up, previous version. Upgraded via update to 10166, Be advised for this change to become effective had to restart comp again. I know its SOP for reg changes but, on an upgrade. SO...
General Support
Bay Trail-powered USB Stick launched
This sounds very tempting but maybe too late for me since I already have a Win 8.1 tablet with Intel Bay Trail CPU (ASUS T-100). Intel launches Bay Trail-powered USB stick which is capable of running 32-bit Windows 8.1 Read more here.
Chillout Room
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:22.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums