What else can I do to fix the corrupt files? Solved

Page 2 of 3 FirstFirst 123 LastLast
  1.    23 Feb 2018 #11

    Bree said: View Post
    If that diskpart command was run from a command prompt at boot, looks like it's C:.
    The command was run via PowerShell. Volume 3 is the recovery partition because the two Chinese characters mean "recovery". Is it the partition/volume where my system boot files are stored?
      My ComputerSystem Spec

  2.    23 Feb 2018 #12

    dalchina said: View Post
    extremely short- seems incomplete?
    Click here to download the much longer, complete one.
    Last edited by Matthew Wai; 23 Feb 2018 at 09:32.
      My ComputerSystem Spec

  3. Bree's Avatar
    Posts : 9,176
    10 Home x64 (1809) (10 Pro on 2nd pc)
       23 Feb 2018 #13

    You need to boot to advanced options and the Command prompt at boot, then run diskpart. The drives may well be assigned different letters when you are not running from the windows system. Then run sfc from the same command prompt to do an offline repair.

    Open Command Prompt at Boot in Windows 10
      My ComputersSystem Spec

  4.    23 Feb 2018 #14

    Looks like the issue is here (all the errors are on last page of your log):
    Code:
    2018-02-23 21:44:02, Info                  CSI    00006063 [SR] Repairing corrupted file \??\C:\Windows\System32\zh-hk\zh-hk\ChtAP.sdc from store
    2018-02-23 21:44:02, Info                  CSI    00006064 [SR] Repairing corrupted file \??\C:\Windows\System32\zh-hk\zh-hk\chtzhy.spd from store
    2018-02-23 21:44:02, Info                  CSI    00006065@2018/2/23:13:44:02.764 Primitive installers committed for repair
    2018-02-23 21:44:02, Info                  CSI    00006066 [SR] Repairing corrupted file \??\C:\Windows\System32\zh-tw\zh-tw\ChtAP.sdc from store
    2018-02-23 21:44:02, Info                  CSI    00006067 [SR] Repairing corrupted file \??\C:\Windows\System32\zh-tw\zh-tw\chtzhy.spd from store
    The error is making a link between these two files:
    Code:
    C:\Windows\System32\zh-hk\zh-hk\ChtAP.sdc
    C:\Windows\WinSxS\amd64_microsoft-onecore-t..-dictionaries-zh-hk_31bf3856ad364e35_10.0.16299.15_none_8b3df0c77dcfde67\zh-hk\ChtAP.sdc
    Code:
    2018-02-23 21:44:04, Error                 CSI    00006071 (F) STATUS_OBJECT_NAME_NOT_FOUND #34685417# from Windows::Rtl::SystemImplementation::CSystemIsolationLayer_IRtlSystemIsolationLayerTearoff::OpenFilesystemDirectory(flags = (SharingViolationIsOk|TransactionalConflictIsOk|DeletePendingIsOk), da = (FILE_GENERIC_READ), dn = [l:36 ml:45]'\??\C:\Windows\System32\zh-hk\zh-hk\', sa = (FILE_SHARE_READ|FILE_SHARE_WRITE|FILE_SHARE_DELETE), oo = (FILE_DIRECTORY_FILE|FILE_SYNCHRONOUS_IO_NONALERT|FILE_OPEN_FOR_BACKUP_INTENT), dir = NULL, disp = Invalid)
    [gle=0xd0000034]
    2018-02-23 21:44:04, Info                  CSI    00006072 Error STATUS_OBJECT_NAME_NOT_FOUND while executing operation HardLinkFile on [l:181]'\SystemRoot\WinSxS\amd64_microsoft-onecore-t..-dictionaries-zh-hk_31bf3856ad364e35_10.0.16299.15_none_8b3df0c77dcfde67\zh-hk\ChtAP.sdc, \??\C:\Windows\System32\zh-hk\zh-hk\ChtAP.sdc'
    There are a few problems with this (for example here: Windows 10 bug of setting the ZH-HK as the primary language ). It may be a problem with secondary keyboard layout in Chinese installation (secondary keyboard works OK for me with en-US install).

    You could try this fix from Superuser:
    The workaround would be to create the directories. Copy the the two files ChtAP.sdc and chtzhy.spd from C:\WINDOWS\System32\zh-hk\ to C:\WINDOWS\System32\zh-hk\zh-hk\ and from C:\WINDOWS\System32\zh-tw\ to C:\WINDOWS\System32\zh-tw\zh-tw\ respectively to the new directories.
    Sfc should now show no corrupt files.
    After Windows 1709 update (Fall Creators Update), there are when running sfc /scannow - Super User
      My ComputerSystem Spec

  5.    23 Feb 2018 #15

    Click image for larger version. 

Name:	DiskPart.jpg 
Views:	2 
Size:	1.45 MB 
ID:	178275
    I ran the above from a Windows USB drive.
    The result was "Windows Resource Protection found corrupt files but was unable to fix some of them".
      My ComputerSystem Spec

  6.    23 Feb 2018 #16

    Thinking about it just check these 2 directories exist (with the language twice):

    C:\Windows\System32\zh-hk\zh-hk\
    C:\Windows\System32\zh-tw\zh-tw\

    If they don't and like me you only have these:

    C:\Windows\System32\zh-hk\
    C:\Windows\System32\zh-tw\

    Then create the subdirectories.

    Normally you don't have language folders containing a subfolder of the same name. If you create the extra subdirectories and run sfc again it should find the path it wants and copy the files from WinSxS. That is what I think the CBS log is saying anyway.

    I'm not sure though as I have no *.sdc files at all so I'm just taking it from what the CBS.log says and badly translated websites.

    Please update the thread if you try it as there aren't any proper answers - it would be interesting if you can fix it and creating the directories would be a good test.
      My ComputerSystem Spec


  7. Posts : 21,460
    windows 10 professional version 1607 build 14393.969 64 bit
       23 Feb 2018 #17

    Consider performing an in place upgrade repair with using a Windows 10 iso:
    Download Windows 10
    Repair Install Windows 10 with an In-place Upgrade Windows 10 Tutorials
      My ComputerSystem Spec

  8.    23 Feb 2018 #18

    Thanks to all of you. Post #14 and #16 are the solution.

    Click image for larger version. 

Name:	Okay.jpg 
Views:	21 
Size:	198.9 KB 
ID:	178377
      My ComputerSystem Spec


  9. Posts : 21,460
    windows 10 professional version 1607 build 14393.969 64 bit
       24 Feb 2018 #19

    Open administrative command prompt and type or copy and paste:
    1) dism /online /cleanup-image /restorehealth
    2) sfc /scannow
    3) chkdsk /scan
    4) When these have completed > right click on the top bar or title bar of the administrative command prompt box > left click on edit then select all > right click on the top bar again > left click on edit then copy > paste into the thread
      My ComputerSystem Spec

  10.    24 Feb 2018 #20

    Microsoft Windows [Version 10.0.16299.248]
    (c) 2017 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>dism /online /cleanup-image /restorehealth
    Deployment Image Servicing and Management tool
    Version: 10.0.16299.15
    Image Version: 10.0.16299.248
    [==========================100.0%==========================]
    The restore operation completed successfully.
    The operation completed successfully.

    C:\Windows\system32>sfc /scannow
    Beginning system scan. This process will take some time.
    Beginning verification phase of system scan.
    Verification 100% complete.
    Windows Resource Protection did not find any integrity violations.

    C:\Windows\system32>chkdsk /scan
    The type of the file system is NTFS.
    Volume label is ● Windows 10.
    Stage 1: Examining basic file system structure ...
    219648 file records processed.
    File verification completed.
    8100 large file records processed.
    0 bad file records processed.
    Stage 2: Examining file name linkage ...
    190 reparse records processed.
    289514 index entries processed.
    Index verification completed.
    0 unindexed files scanned.
    0 unindexed files recovered to lost and found.
    190 reparse records processed.
    Stage 3: Examining security descriptors ...
    Security descriptor verification completed.
    34934 data files processed.
    CHKDSK is verifying Usn Journal...
    38214424 USN bytes processed.
    Usn Journal verification completed.
    Windows has scanned the file system and found no problems.
    No further action is required.
    63011839 KB total disk space.
    31457060 KB in 176429 files.
    132240 KB in 34935 indexes.
    0 KB in bad sectors.
    332159 KB in use by the system.
    65536 KB occupied by the log file.
    31090380 KB available on disk.
    4096 bytes in each allocation unit.
    15752959 total allocation units on disk.
    7772595 allocation units available on disk.
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
Corrupt Win 10 Files in Performance & Maintenance
Hello! Powering on my PC this morn I got a "preparing windows" message, then it made me sign out and sign back in. I googled the error and it suggested I run a windows scan via the command prompt. I did and this was the result: ...
Solved SFC Corrupt Files on CBS.Log ? in Performance & Maintenance
Can someone please help...my sfc command says it can't fix some files...but I don't know what files or how to fix them...looked at CBS.log but doesn't mean much to me. Tried to attach CBS log but am getting this error: CBS.log: Your file of...
When I run sfc /scannow, these are the problems that can't be fixed: 2016-04-17 17:10:09, Info CSI 000051ab Cannot repair member file "Snipping Tool.lnk" of Microsoft-Windows-SnippingTool-App, version 10.0.10586.0, arch...
Why do my files keep getting corrupt? in Performance & Maintenance
So every couple of months I seem to have a problem... Something acting a bit weird, or my whole computer is amazingly slow, etc.. So I usually go for chkdsk /f /r and sfc /scannow Now when running sfc, I ALWAYS seem to have some corrupt...
Solved SFC Corrupt Files in Performance & Maintenance
Windows search doesn't work. I ran SFC /scannow and there is corrupt files, the log is attached.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:01.
Find Us