Windows 10: Failed to start service WMS - Error Id 1010

Page 2 of 4 FirstFirst 1234 LastLast
  1.    4 Weeks Ago #11

    Dear TMSharks:
    Here's another, very interesting response from fellow MVP Greg Carmack:
    Tracing Logged events to Task Manager Processes guided by this has solved it in cases I've had before: https://www.howtogeek.com/332838/what-is-the-wmi-provider-host-wmiprvse.exe-and-why-is-it-using-so-much-cpu
    Attached link: What Is the WMI Provider Host (WmiPrvSE.exe), and Why Is It Using So Much CPU?. Click to open in new tab. The WMI Provider Host process is an important part of Windows, and often runs in the background. It allows other applications on your computer to request information about your system. This process shouldn’t normally use many system resources, but it may use a lot of CPU if another process on your system is behaving badly.
    This looks worth digging into: I've found the HowToGeek enormously helpful over the years.
    --Ed--
      My ComputersSystem Spec

  2.    4 Weeks Ago #12

    I've run sfc /scannow again, just to be sure, but I hadn't ran Dism /Online /Cleanup-Image /RestoreHealth yet.

    Having done so, it unfortunately seems that neither commands find anything. sfc /scannow comes up with no corrupted files, and Dism /Online /Cleanup-Image /RestoreHealth does its thing but the issue persists. I do appreciate the suggestions, though!

    Edit: Am currently trying the HowToGeek fix. I can already say that the process ID in the errors links to the MalwareBytes application. I'll try uninstalling that, see how it goes
      My ComputerSystem Spec

  3.    4 Weeks Ago #13

    Okay, so the HowToGeek method didn't fully solve my issue, but did give some insight. I uninstalled MalwareBytes, but now a new process is identified by Event Viewer in the errors for Windows Management Instrumentation: svchost.exe. I'd assume that this is the Service Host for WMI. Unsure what could be done to fix that error.

    But here's the thing I'm confused about. In Services, I can three relevant separate services: Windows Management Instrumentation, WMI and WMI Performance Adapter. Windows Management Instrumentation starts and stops without problem. However, it is the Service called WMI that cannot be started, giving the aforementioned "WmiPrvSE.exe cannot be found". Yet, when I click on properties for this WMI service, it says that the display name is WMI, yet its service name is WMS.

    So here's where I'm stuck, is this WMI (or WMS) different from Windows Management Instrumentation? This WMI (I'll call it WMS from now on to avoid confusion) has a path to C:\Windows\wmi\netmon.exe. Yet, this folder doesn't exist on any PC but my own. Do you guys see the WMS service (with a display name of WMI), or is me seeing that service maybe indicative of the larger problem?

    Click image for larger version. 

Name:	image.png 
Views:	20 
Size:	22.6 KB 
ID:	174103
    Screenshot of the WMS process with its path to executable. This is the Service that gives the error "WmiPrvSE.exe not found" when I attempt to start it (which always fails)


    UPDATE: Source of the error for WMS (WMI display name) comes from "nssm", shown below:
    Click image for larger version. 

Name:	image.png 
Views:	21 
Size:	24.6 KB 
ID:	174105
    Doing some research, that's something called the "Non-Sucking Service Manager". Now, I'm not sure if that comes with Windows 10, but I don't remember installing it. Is this program the cause of the issues, or may it just be the program reporting the error?
      My ComputerSystem Spec

  4.    4 Weeks Ago #14

    TMSharks, I can't believe it, you have described to the letter exactly where I have come from. All the points you highlight are on my system right down to the existence of the netmon.exe file which I was looking at being very suspicious at first but, it "seems" harmless all beit it shouldn't by rights even be there.

    I will run the diag tool you mention above and maybe we could compare lists to see if there are even more comparisons. I suppose it is just possible that it could be case of what is loaded/running on our systems which is causing a "perfect storm"?
      My ComputerSystem Spec

  5.    4 Weeks Ago #15

    Well...........here is one of my printouts from the WMI Diag prog. I think this may need some detective work to figure out what is going on, apart from the fact that 1 machine is 100% not working correctly. ??

    Click image for larger version. 

Name:	image.png 
Views:	20 
Size:	49.7 KB 
ID:	174160
      My ComputerSystem Spec

  6.    4 Weeks Ago #16

    Ed, I am showing WmiPrvSE.exe in all the places you highlighted as well.

    Don't make no sense...................
      My ComputerSystem Spec

  7.    4 Weeks Ago #17

    Yep, this is crazy. Exactly the same errors here.
    Click image for larger version. 

Name:	image.png 
Views:	2 
Size:	135.2 KB 
ID:	174168
    Honestly I'm kind of befuddled by this. There's no way we're the first and only people to have ended the WmiPrvSE.exe in Task Manager, yet there's absolutely no info that I can find anywhere on this issue.

    It gets even weirder with the WMS (display name WMI) service, which doesn't exist on the normal reference PC I checked, as well as the C:/Windows/wmi folder that also does not exist on that normal PC. Did ending the process create a new service entirely? At this point, I honestly don't know.

    The most likely fix for this would be a complete reset of the PC. I've already tried a repair using the Windows 10 setup tool (in order to keep all my files), but that didn't fix anything. I'm just reluctant about that, as it'd be a lot of effort to get everything set up again as I don't have a backup from before this issue got started.

    Looking through the event viewer, this problem has apparently been going on for over a week. Only reason I figured it out is because I tried to install the Battle.net launcher by Blizzard Entertainment for some videogames, which wouldn't install. After going to System Information to find the details required in a support ticket, I found that WMI wasn't working, leading me to here.

    Besides this one failed installation, I haven't found any direct issues that this problem has caused. All programs, apart from obviously System Information and this Battle.net, seem to work just fine. I've installed other programs in the meantime as well, which was completely without any issues. pdoth, have you experienced any loss in functionality because of this issue yet?
      My ComputerSystem Spec

  8.    4 Weeks Ago #18

    I can't be absolutely certain but it would appear that the first instance I can find of the 1010 error appearing was on 22/01/18 after several hours use. I'm trying to think back if that was the date/time I first noticed the high CPU use and stopped the service ?

    The problem is my event log only starts 22/01/18 but has 5,575 events logged.

    From Event Viewer 'Admin' log
    15:19 event ID 7024 - "The WMS service terminated with the following service-specific error: The system cannot find the path specified."
    15:21 - "The WMI service terminated with the following service-specific error: The system cannot find the path specified."

    From Event Viewer 'Windows System log'
    15:24 event 1010 - "Failed to start service WMS. Program C:\Windows\wmi\WmiPrvSE.exe couldn't be launched. CreateProcess() failed: The system cannot find the file specified."
      My ComputerSystem Spec

  9.    4 Weeks Ago #19

    To answer your last question TMSharks, I don't 'think' there are any major issues that I have become aware of as a result on the situation but, from experience simple problems seem to have a habit of escalating fairly quickly into major system shutdowns unless they are addressed as soon as you find them.

    You can bet your life that something will go wrong at the exact time you need it most.
      My ComputerSystem Spec

  10.    4 Weeks Ago #20

    Sounds like nothing seriously bad is going on, so with no easy or well-documented fixes at hand, all you can do is to keep an eye on things, and report back here if stuff goes weird in a hurry. This is starting to remind me of the well-known DCOM errors that show up in Event Viewer. They keep recurring but Windows keeps chugging along and working anyway. I'm starting to think that you should either decide to go with the current flow, or perhaps try an in-place upgrade repair install to see if that helps.
    HTH,
    --Ed--
    Last edited by EdTittel; 4 Weeks Ago at 10:40. Reason: Fix typo
      My ComputersSystem Spec


 
Page 2 of 4 FirstFirst 1234 LastLast

Related Threads
explorer.exe won't run on startup. On the "Welcome" screen, there's only half startup jingle playing, then it goes black, and the only thing I see is the Command Prompt. I took a look at the Event Viewer. Here's what I found: The WMS service...
I have an Samsung 850 EVO installed, it lets Windows do the optimization. In doing so the indexing service was disabled. But now I can't get the Streaming service to start. I get the 1068 error when trying to start it.
Hello there I am new here but I have this event viewer ERROR. The IOMap service failed to start due to the following error: The system cannot find the file specified. Event ID 7000 My PC SPECS: MB: Asus P9X99 Deluxe II CPU: Intel I7...
(edited the zip folder in) Hey, so I tried searching everywhere for the answer to this issue, I posted on the answer.microsoft.com forum and this indian guy said I had to do a clean boot, did that, and it didn't work, and they haven't responded...
Solved Windows Defender updates failed, service won't start in AntiVirus, Firewalls and System Security
The last few days, Defender has been trying and failing to update its definitions. A manual update from Defender fails. Now Defender isn't working. Pressing Defender's Start button gives the message that the underlying service isn't running. The...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:10.
Find Us