Event ID 10016, CLSID and APPID

Page 1 of 2 12 LastLast

  1. Posts : 226
    Windows 10

    Event ID 10016, CLSID and APPID

    This is unfortunately not the 5th or 100th such post on this topic in these forums.

    But I've followed the advice on many of the threads, believe in my heart of hearts that I've done it right, and the problem is persisting.

    At each computer restart, my event log logs the following four times:

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    and APPID
    to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    Before I tried to fix it, I was getting it two times. So wow, what a (non) good fixer am I!

    Solved Numerous event id 10016 errors win 8 pro 64 bit (yes, I know that is from a Windows 8 forum) is the most recent guidance I followed. It parallels the general guidance I have read here, which is:
    • Open regedit
    • Navigate to the keys being flagged (in my case, that is CLSID {6B3B8D23-FA8D-40B9-8DBD- B950333E2C52} and APPID {4839DDB7-58C2-48F5-8283-E1D1807D0D7D})
    • For each key, change the ownership, then grant "full control" permission to the corrected key owner
    • Go into DCOM Config
    • Edit the security properties of WPN Srumon Server to give proper launch and activation permissions to the user
    • Reboot

    And yet I'm failing. I reviewed the tutorial referenced above, and what I did, and that the changes took place, but I am still getting those errors on restart - again, same error repeated four times.

    Can someone, specific to my own case described above, give me very clear step-by-step instructions on what to do?

    I've even seen it said in this forum that simply deleting the keys that are being flagged has solved the problem for some people, although I would rather avoid that unless I get some assurance that the problem can be solved that simply.
      My Computer

  2. Posts : 1,471
    Win10 Home x64 - 1809

    Hey asus2016,
    4839DDB7-58C2-48F5-8283-E1D1807D0D7D is ShellServiceHost

    You don't have to do the RegEdit stuff if you use PowerRun ... it's a standalone program (no install)
    1. Download PowerRun - PowerRun v1.1 (Run with highest privileges)
    2. Unzip the file and run PowerRun.exe or PowerRun64.exe
    3. Add Dcom Config by clicking the + Gear Icon
    Location - %SystemRoot%\System32\dcomcnfg.exe
    Working Dir - %SystemRoot%\System32
    Click Apply List
    4. Double Click on the dcomcnfg.exe you just added to open Dcom Config
    5. When in Dcom Config click View > Detail so you know you're working on the right App ID
    6. Right Click on ShellServiceHost > Properties > Security Tab > Customize > Edit
    7. Add LOCAL SERVICE (if need be) and check Local Launch and Local Activation
    8. Close Dcom Config
    9. Close PowerRun
    10, Reboot PC
      My Computers

  3. Posts : 4,526
    Windows 11 Pro 64-bit

    1. Please type Regedit into Start Menu.
    2. Go to HKEY_Classes_Root\CLSID\*CLSID*.

    Note: *CLSID* stand for the ID that appears in your event viewer error. In your case, it's {6B3B8D23-FA8D-40B9-8DBD- B950333E2C52}.

    3. Right click on it then select Permission.
    4. Click Advance and change the owner to Administrators. Also click the box that will appear below the owner line.
    5. Click Apply and grant full control to Administrators.
    6. Close the tab then go to HKEY_Local_Machine\Software\Classes\AppID\*APPID*.

    Note: *AppID* is the ID that appears in your event viewer. In your case it's {4839DDB7-58C2-48F5-8283-E1D1807D0D7D}.

    7. Right click on it then select Permission.
    8. Click Advance and change the owner to Administrators.
    9. Click the box that will appear below the owner line.
    10. Click Apply and grant full control to Administrators.
    11. Close all tabs and go to Control Panel --> Administrative Tools.
    12. Open Component Services.
    13. Click Computer, click My computer, then click DCOM Config.
    14. Look for the corresponding service that appears on the error viewer.

    Note: For this step, look for the one that appeared at the right panel of the RegEdit. For example, the AppID {4839DDB7-58C2-48F5-8283-E1D1807D0D7D} registry key contains the "ShellServiceHost" data with a (Default) as a value name. Now look for "ShellServiceHost".

    15. Right click on it then click Properties.
    16. Click Security tab then click Customize in the Launch and Activation permissions section. Click Edit. Click Add. Add a Local Service. Then Apply.
    17. Tick the Local Activation box.
      My Computer

  4. Posts : 226
    Windows 10
    Thread Starter

    FreeBooter, thanks - you have helped me solve this!

    For others who may find this thread, which I'm now marking "solved," here are the two critical errors I had made:

    1. The registry keys that need to be edited will likely be different from one machine to the next. Note FreeBooter's comments below steps 2 and 6 above. You need to edit ownership and permissions to the keys showing in YOUR event viewer, not the ones documented in other people's posts!
    2. In fixing the AppID registry key, as FreeBooter says in Step 14, you need to note the service referenced by that key, then in DCOM Config, adjust the properties and permissions of THAT service - not the ones that might be documented in other people's posts

    I do have one additional question for which I'll invite answers. One of the services I had to tweak was Runtime Broker. And the computer had TWO "Runtime Broker" services on it. On one of the services, the security customization permissions were grayed out, and, crossing my fingers, I tried the other service and I was able to make the changes. What's with the two Runtime Broker services?
      My Computer

  5. Posts : 4,526
    Windows 11 Pro 64-bit

    You are very welcome @asus2016!
      My Computer

  6. Posts : 31
    Windows 10 Pro (AU) 64-bit

    Hi all & @FreeBooter,

    Executed the steps just fine until I got to the step 16: Seems for some reason, I can not click on the "Add" as it's not activated (for none of the Groups/Usernames). What I'm missing here? See screenshot.

    Event ID 10016, CLSID and APPID-error.png

    Help greatly appreciated!

      My Computer

  7. Posts : 4,526
    Windows 11 Pro 64-bit

    Hi tjsuominen,

    I think registry permission setting are not correct please follow the instructions again.
      My Computer

  8. Posts : 31
    Windows 10 Pro (AU) 64-bit

    Thx @FreeBooter,

    Had missed one step regarding this case, thx!
      My Computer

  9. Posts : 4,526
    Windows 11 Pro 64-bit

    You are very welcome!
      My Computer

  10. Posts : 18
    Win 10 Pro

    Hey, I've been trying to resolve this same dcom issue myself, and I followed the steps you listed @FreeBooter, but when I try to do the last step, I firstly when clicking "edit" get a message saying
    Event ID 10016, CLSID and APPID-error.png
    And then when I do enter the menu after clicking "ok" on that dialog box, the add button is greyed out.

    I'm 100% certain I followed all the steps correctly. I triple-checked it. But no dice...
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:15.
Find Us

Windows 10 Forums