Windows 10: Freshly installed W10 all settings open slow

Page 1 of 2 12 LastLast

  1. Posts : 5
    Windows 10 Home
       19 Dec 2017 #1

    Freshly installed W10 all settings open slow


    Hello.

    I had this problem each and every time I installed Windows 10, it's freshly installed (finished 10 minutes ago at the time of this post) and the settings, photos and pretty much everything related to the apps take a very, very long time to open.

    Click image for larger version. 

Name:	problem.png 
Views:	4 
Size:	781.4 KB 
ID:	168850

    It stays like this and I don't know what causes it, there is no software that may conflict with it, nor any hardware issues that could cause it. I only use SSDs and my PC isn't half bad either.

    Any ideas as to what causes this are appreciated!
      My ComputerSystem Spec

  2. Masterchiefxx17's Avatar
    Posts : 419
    Windows 10 Professional 64bit
       20 Dec 2017 #2

    Refreshes like to skip corners here and there. For example, there is a tool that will completely remove Microsoft Edge from a computer. Only a full reinstall of Windows will bring it back, not a reset or a refresh.

    Does the problem remain if you do a complete format and reinstall of Windows?
      My ComputerSystem Spec


  3. Posts : 5
    Windows 10 Home
    Thread Starter
       22 Dec 2017 #3

    The problem remains indeed.

    Microsoft edge is also slow to respond, and takes a while to load.
      My ComputerSystem Spec

  4. Masterchiefxx17's Avatar
    Posts : 419
    Windows 10 Professional 64bit
       22 Dec 2017 #4

    You performed a full format of the drive and reinstalled Windows?

    Where did you get your copy of Windows from? What is the specifications of your PC?
      My ComputerSystem Spec

  5. MrHudson's Avatar
    Posts : 422
    Windows 10 Home 64-bit Edition
       23 Dec 2017 #5

    I get the same thing, when it does that I just close it out then reopen, it opens then.
    Win 10 is not the best OS. I can look in task manager, my CPU is running faster than it should, CPU is duel core 1.6GHz, 2.16GHz max. just having task manager open, shows CPU speed at 1.86GHz. I can open another APP and it will over clock, just max it out.
      My ComputersSystem Spec


  6. Posts : 5
    Windows 10 Home
    Thread Starter
       24 Dec 2017 #6

    I did perform a full format.

    The windows is the original OS downloaded and installed on my stick by microsoft's application. (Windows 10 Pro)

    My PC specs are: 16GB RAM, i5-4670K, 970 GTX, 2x Kingston SSDs, 550W Platinum PSU

    If I close and reopen the app, the issue remains.

    The issue is exclusive to the Microsoft applications, and exclusive to windows 10.

    I am logged in with my microsoft account in the windows, it is not a local account.
      My ComputerSystem Spec

  7. MrHudson's Avatar
    Posts : 422
    Windows 10 Home 64-bit Edition
       24 Dec 2017 #7

    Can you open store to look in Downloads and Updates to see if all the Microsoft APP's have been updated?
      My ComputersSystem Spec

  8. MrHudson's Avatar
    Posts : 422
    Windows 10 Home 64-bit Edition
       24 Dec 2017 #8

    Click image for larger version. 

Name:	store.jpg 
Views:	1 
Size:	80.4 KB 
ID:	169405
    These are the Microsoft APP's.
      My ComputersSystem Spec

  9.    24 Dec 2017 #9

    I have noticed that, after a clean installation, the first time I open Privacy -> "background applications" in settings it hangs and closes. Next time is ok.
      My ComputerSystem Spec

  10.    24 Dec 2017 #10

    I had a problem with a DELL Latitude e6410 only because they didn't support Windows 10 on the machine and so when I did some research it looked to me that there had to be a certain order to the drivers....like the chipset could pose a problem if the order was out of place...INI files maybe....since then DELL has made a application called "SupportAssist" which seems to find problems and tries to optimize the machine too....your issue reminded me of the problem from months ago.
    Also...event viewer could possible point you in the right direction in there is a issue with multiple errors for one thing.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Solved problems with updates is very slow to be installed in Windows Updates and Activation
Hi I am running Windows 10 Home 14,393,969 who have build 1607 in the recent past been problems with updates is very slow to be installed, and in several cases, freezes the PC. It is managed to receive all updates from Microsoft, but it has...
The main reason I reinstalled the system is to not have Nvlddmkm.sys show up. One day after reinstalling, there it is again. Windows 7 SP1 x64. How do I create and upload an error log?
Hello, I've been trying to tackle this one without luck. After the laptop wakes up from sleep, I get a BSOD that says CRITICAL_PROCESS_DIED. The laptop is an HP g6-1c40ca that I just finished formatting with Windows 10 Home. All drivers are...
Hello, I have just installed a fresh copy of Windows 7 Pro (x64) onto an external hard drive (connected via USB 2.0). (I used a freeware program called WinToUSB to achieve this.) It now exists alongside my normal Windows 7 installation (which is...
Quite often (60% of the time) clicking on Windows Explorer results in no action whether from the tool bar or from the Windows screen for a very long period of time. There is nothing showing to determine if there is a background program causing...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:08.
Find Us