Win 10 Pro install on NVME PCIE drive: My nightmare

Page 4 of 6 FirstFirst ... 23456 LastLast
  1. hdmi's Avatar
    Posts : 557
    10 Home (21H1)
       #31

    3080FE said:
    I' remember installing Windows 3.1 with a dozen of 3.5 floppy disks... things improved but the one click install is not yet existing.
    Ventoy adds the benefit of needing only a single flash drive instead of having to keep on reformatting a whole box of 'em.
      My Computers

  2. 3080FE's Avatar
    Posts : 17
    Windows 10 Pro
    Thread Starter
       #32

    So folks,

    Created a new USB Win10 install stick following the recommendation:
    Option One, here... Create Bootable USB Flash Drive to Install Windows 10

    BOOT>CSM>Launch CSM: Enabled
    BOOT>CSM>Launch CSM>Boot Device Control: UEFI and Legacy OPROM
    BOOT>CSM>Launch CSM>Boot from Network Devices: Ignore
    BOOT>CSM>Launch CSM>Boot from Storage Devices: UEFI only
    BOOT>CSM>Launch CSM>Boot from PCI-E/PCI ED: UEFI only
    BOOT>Secure Boot>OS Type: Windows UEFI mode
    BOOT>Secure Boot>Key Management: Install Default SBK
    BOOT>Secure Boot>Key Management: Clear SBKs

    Boot priority:
    Opt-1: UEFI USB drive
    Opt-2: M2 drive
    Opt-3: USB drive

    Same result, Win installer is not able to see my M2 drive.
    Via command prompt and diskpart command, I only see my USB drive as Disk 1 (14Gb).
      My Computer

  3. NavyLCDR's Avatar
    Posts : 15,974
    Windows 10 Pro
       #33

    Just so you know - none of the above is going to have any affect at all of Windows detecting the M.2 drive during setup. You can mess with UEFI v. CSM booting all you want to. Once you are booted into Windows setup and at the screen shown in post #15 you are chasing rabbits down the wrong rabbit hole.

    I would suggest replacing the SSD.
      My Computer

  4. 3080FE's Avatar
    Posts : 17
    Windows 10 Pro
    Thread Starter
       #34

    NavyLCDR said:
    Just so you know - none of the above is going to have any affect at all of Windows detecting the M.2 drive during setup. You can mess with UEFI v. CSM booting all you want to. Once you are booted into Windows setup and at the screen shown in post #15 you are chasing rabbits down the wrong rabbit hole.

    I would suggest replacing the SSD.
    Sir I think you're right.
    You think my M2 NVME PCIE drive is faulty ? Or I should by a SATA SSD, install Window on it and deal with the nvme drive afterward.
      My Computer

  5.   My Computers

  6. 3080FE's Avatar
    Posts : 17
    Windows 10 Pro
    Thread Starter
       #36

    Thanks for the advice but this is not my problem. My M2 drive is always seen by the bios/motherboard as storage device.
    Depending on bios boot settings (CSM enable), I can even try to boot on it but get the message "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key"

    - - - Updated - - -

    I've ordered a SATA SSD and will install Win10 on it. Then I will try to fix this NVME issue.
    I will let you know the end of the story.

    Thanks to all for your help.
      My Computer

  7. RoadBlaster's Avatar
    Posts : 432
    W10X64 21H1
       #37

    When I have problems finding UFEI boot from the USB created by Win Media Creation Tool I always go into bios reset the bios to optimized settings then reboot to bios, then power off, then power up & press F12 to bring up the "boot from only" menu & UEFI or legacy is then displayed there for the USB W10 Installer drive.

    Sometimes with M.2 or SSD if you have used it before in another Win 10 install in UEFI mode & then deleted the partition before this install Windows can leave a small partition with the UEFI information on it which blocks another installation from being performed..

    & thats how I cure this problem every time for me but may not work for others.
      My Computer

  8. hdmi's Avatar
    Posts : 557
    10 Home (21H1)
       #38

    3080FE said:
    Thanks for the advice but this is not my problem. My M2 drive is always seen by the bios/motherboard as storage device.
    Depending on bios boot settings (CSM enable), I can even try to boot on it but get the message "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key"

    - - - Updated - - -

    I've ordered a SATA SSD and will install Win10 on it. Then I will try to fix this NVME issue.
    I will let you know the end of the story.

    Thanks to all for your help.
    For it to be bootable it needs to be recognized as GPT disk, and needs to have the 100MB EFI partition on it.
      My Computers

  9. NavyLCDR's Avatar
    Posts : 15,974
    Windows 10 Pro
       #39

    Still going down the same rabbit hole. The problem is not whether or not the SSD is bootable. The problem is that it does not show up in the list of drives to install to in Windows setup.
      My Computer

  10. NavyLCDR's Avatar
    Posts : 15,974
    Windows 10 Pro
       #40

    3080FE said:
    Sir I think you're right.
    You think my M2 NVME PCIE drive is faulty ? Or I should by a SATA SSD, install Window on it and deal with the nvme drive afterward.
    I had two brand new ADATA SSDs that were bad. They would be only intermittently detected by both BIOS and Windows. Sometimes yes, sometimes not. I finally went with Samsung. While it is much less likely that the Samsung EVO SSD itself is bad, it is still a possibility. Have you tried physically removing it and re-installing it to make sure it is seated correctly?
      My Computer


 
Page 4 of 6 FirstFirst ... 23456 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:48.
Find Us




Windows 10 Forums