How to see which lanes is used to what HW? Solved

Page 2 of 3 FirstFirst 123 LastLast
  1.    #11

    Yes I have that setting in BIOS, but it is a "read only", as my graphic card is not an ASUS but MSI. It is at this place I can see, that it is only running x8.
      My ComputerSystem Spec

  2. AddRAM's Avatar
    Posts : 2,395
    Windows 7 Pro x64 Windows 10 Pro x64
       #12

    Better get yourself an Asus Strix card to go with that board.

    https://www.asus.com/us/Graphics-Car...TI-11G-GAMING/

    I would have done a lot more research on that board before making your purchase.
      My ComputersSystem Spec

  3.    #13

    Run SIV (SIV - System Information Viewer) and click on PCI Bus->0-01-0 Intel Core i7 PCIe Controller (x16)->Dump PCI->Dump PCI. This will dump a bunch of hexadecimal values into your clipboard. Then paste into notepad, save as a .txt file, and attach to the thread.

    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	153.2 KB 
ID:	228468
      My ComputerSystem Spec

  4.    #14

    OK, here it is. If I have attached the file in the right way

    It is now 4:15 am here, so I'm going to bed. Hope to see your answer (and solution?!) when I get up again
    How to see which lanes is used to what HW? Attached Files
      My ComputerSystem Spec

  5.    #15

    From the PCIe controller side I don't see anything misconfigured. So the problem has to be something downstream - either the motherboard or the graphics card.

    Have you ever seen it work at x16? A quick Google search of the Asus forums shows others with similar issues but no solid solutions. I assume the only PCIe card you have in the x16 slots is the GPU and is plugged into the slot closest to the CPU. And you've tried updating to the latest BIOS and clearing CMOS?

    I also doubt it's related to the NVMe drives since your HWinfo screenshot shows them connected to the PCH PCIe ports. But just to isolate the problem you can create a bootable Ubuntu USB drive (Create a bootable USB stick on Windows | Ubuntu tutorials), remove your NVMe drives, boot to Ubuntu, open a terminal, and run "sudo lspci -vv." Then you can look for the GPU entry and check the LnkSta entry to see what the link width is.
      My ComputerSystem Spec

  6.    #16

    Yes, I have seen it working at x16, before I connected the second NVMe drive. I will try and take the graphic card out and mount it again to see if this can solve it. I had the graphic card dismounted when I put the second NVMe drive in as it is located close to the PCIe port closest to CPU.
      My ComputerSystem Spec

  7.    #17

    I have now dismounted both NVMe and my soundcard (connected to the lowest x1 PCIe port), and this is how it shows in BIOS:
    Click image for larger version. 

Name:	BIOS.jpg 
Views:	3 
Size:	122.3 KB 
ID:	228501

    My next step is to unmount graphic card, mount the NVMe drives as you wrote they did not cause this. I'll be back
      My ComputerSystem Spec

  8.    #18

    YES! I got it. It seems to be my cabinet that is a little off. When just putting the graphiccard into the PCIe port and connect the cable, it runs at x16. But if I tightens the screws at the backplate of the cabinet, then it is down to x8 after poweron.

    Thank you for all the help and infos
      My ComputerSystem Spec

  9. AddRAM's Avatar
    Posts : 2,395
    Windows 7 Pro x64 Windows 10 Pro x64
       #19

    Very strange.
      My ComputersSystem Spec

  10.    #20

    But true. I have now solved it as I have enlarged the holes in the graphic cards backplate, so now it stays correct in the port even if I tighten the screw
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
Z370 Aorus Gaming Wifi PCIE lanes in Drivers and Hardware
Hi guys! A quick question. I have a Z370 Gaming Wifi motherboard and I have 2 SSDs, 3 HDDs and an Optane drive installed. I'm planning to purchase a NVME drive to place on the 2nd M.2 slot (bottom slot) but I would like to clarify if it will read...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:30.
Find Us