I have made the decision to delid my i7 8700k due to high temps. Solved

Page 2 of 18 FirstFirst 123412 ... LastLast
  1.    29 Mar 2018 #11

    Cheers Thrash. I have checked the pump in Corsair link and it appears to be running ok. I am going to have to keep a close eye on it. Will see how the temps look after the delid. If it doesn't yield the same 20c drop most people get then I will be putting it down to the cooler and will look to replace.
      My ComputersSystem Spec

  2. ThrashZone's Avatar
    Posts : 4,204
    3-Win-7Prox64 2-Win10Prox64
       29 Mar 2018 #12

    Hi,
    Can't remember if cl shows a rpm of the pump just performance...
      My ComputersSystem Spec

  3. worf105's Avatar
    Posts : 2,458
    Windows 10 Pro 64-Bit (1809)
       29 Mar 2018 #13

    worf105 said: View Post
    Hi Paul, My Corsair H110i GTX stopped preforming when I got my 8700K. Think air got in the system from evaporation and temps were rubbish. Thread in the forum somewhere about it. I bought the NZXY x62 and never looked back. as a bonus I sent the old AIO back and got a brand new H115i
    NEXT Kraken x62 or Corsair H115i ?
      My ComputersSystem Spec

  4.    29 Mar 2018 #14

    Sorry Worf, missed your reply. Thanks for the info. I can't remember what the warranty is with Corsair is it 5 years on coolers? That's assuming mine has gone faulty. No big deal if not, I guess I should be looking at a new cooler soon anyway.

    @Thrash it shows pump speed bud.
      My ComputersSystem Spec

  5. ThrashZone's Avatar
    Posts : 4,204
    3-Win-7Prox64 2-Win10Prox64
       29 Mar 2018 #15

    Hi,

    5 year warranty :)
      My ComputersSystem Spec

  6.    29 Mar 2018 #16

    ThrashZone said: View Post
    Hi,

    5 year warranty :)

    That's good to know. Thanks Thrash.
      My ComputersSystem Spec

  7. ThrashZone's Avatar
    Posts : 4,204
    3-Win-7Prox64 2-Win10Prox64
       29 Mar 2018 #17

    Hi,
    I don't believe @AddRAM bothered with rma'ing his
    I wasn't but said what the heck I'll just sell it :)
      My ComputersSystem Spec

  8. worf105's Avatar
    Posts : 2,458
    Windows 10 Pro 64-Bit (1809)
       29 Mar 2018 #18

    paulpicks21 said: View Post
    Sorry Worf, missed your reply. Thanks for the info. I can't remember what the warranty is with Corsair is it 5 years on coolers? That's assuming mine has gone faulty. No big deal if not, I guess I should be looking at a new cooler soon anyway.

    @Thrash it shows pump speed bud.
    Yes its 5 years and corsair was great to deal with. I also was not sure but contacted them and arranged the RMA. A short time after I got a new
    Click image for larger version. 

Name:	H115i.jpg 
Views:	3 
Size:	829.6 KB 
ID:	182761

    Now it just sits under my desk doing nothing.
      My ComputersSystem Spec

  9.    29 Mar 2018 #19

    That's great. The main issue with RMA'ing it would be the PC would be out of use for the duration of the RMA due to having no other cooler I could use. I imagine the process would take a couple of weeks.
      My ComputersSystem Spec

  10. AddRAM's Avatar
    Posts : 2,241
    Windows 7 Pro x64 Windows 10 Pro x64
       29 Mar 2018 #20

    The pump is what went on my H110. I replaced it with a H100i v2 and the Z170 is doing great.

    I put a H115i on the 7900X and so far, it`s rockin.
    Last edited by AddRAM; 29 Mar 2018 at 18:18.
      My ComputersSystem Spec


 
Page 2 of 18 FirstFirst 123412 ... LastLast

Related Threads
Ready to push the button on 8700k... in PC Custom Builds and Overclocking
I have spent hours reading over 370Z/390Z, CoffeeLake/CFL Refresh, Cannon Lake, Ice Lake rumors and articles. I have come to some conclusion that there will be nothing released very soon that is of any significant advantage over the 8700K. There...
8700K WHEA ERRORS on 16299.15 build. in BSOD Crashes and Debugging
Hi . Any ideas why my 8700K ( auto OC from UEFI 4700MHZ ) throwing errors WHEA-LOGGER in event viewer on Windows 10 Creators Update FALL only in build 16299.15 ? I updated system to 16299.214 and no errors so far. I know that microcode was...
Very high CPU Temps in Performance & Maintenance
Hi I turned my PC on this morning as I do every morning but instead of behaving like it normally does the fans started spinning 100%. So I checked the temps in the BIOS and the CPU is running at 89c. I have cleaned off and reapplied the...
i7 6700K high temps in Performance & Maintenance
All settings are default with no overclock using the a high end fan cooler Thermal past has been applied 5 times This is while streaming and playing call of duty and battlefield one
Hi all, I have posted here before about BSOD issues and I thought they had stopped after your help. Alas, they have returned with a vengeance. The BSODs usually happen when the CPU is under load, they happen often when playing DotA 2 and every...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:39.
Find Us