Windows 10: Windows 10 - Ethernet Does Not Have a Valid IP Configuration Solved

  1.    08 Dec 2017 #1

    Windows 10 - Ethernet Does Not Have a Valid IP Configuration


    I just build a computer and installed Windows 10. However, when I plug in an Ethernet cable, it says I am connected, but have no internet access. The troubleshooting error says that the Ethernet does not have a valid IP Configuration. This happens when I plug in my Ethernet cable to a Netgear Powerline Adapter (router > powerline adapter 1 > powerline adapter 2 > computer).

    However, if I instead plug the Ethernet cable directly into the router (router > computer), it works without any problems. I have been searching high and low and feel like I have tried everything to get this resolved (command prompts, disabling/enabling, unselecting IPv6, etc.), but have been unsuccessful so far. Any help is appreciated. Thanks!
      My ComputerSystem Spec

  2.    08 Dec 2017 #2

    I had tried resetting my router, which didn't help. But then I reset my router AND modem and the issue seems to be resolved!
      My ComputerSystem Spec


  3. Posts : 10,309
    Windows 10 Pro and Windows 10 Pro Insider
       08 Dec 2017 #3

    nctowle said: View Post
    I had tried resetting my router, which didn't help. But then I reset my router AND modem and the issue seems to be resolved!
    Thanks for letting us know.
      My ComputersSystem Spec


 

Related Threads
So... I just updated from win 7 to win 10, as I got it for free. All went smoothly, but there was no ethernet connection. I'm running a custom built pc, connected to my router via ethernet cable. At first windows detected the cable, but said:...
I have been having on-going Internet connection problems with Windows 10 for months. Initially running the Realtek driver repair program would fix the problem. Not any more. I have tried everything suggested from various posts to no avail. I...
I've been working on this for over two hours now. I have wifi on laptop. In Windows 10 I can't access internet on PC with Ethernet. On the same computer I have a Linux Mint partition and ethernet connection is fine there 160Mbps. I've unplugged...
Hi guys, I am running Windows 10 demo version. I have problems connecting to the net. I am shown the error along the lines of "Ethernet does not have a valid IP configuration". From command prompt I run "ipconfig/all" and here is the...
8 hours ago my computer was connected via Ethernet and functioning fine during online gaming. This morning approx. 4 hours ago I awoke to notice the computer updated and restarted during my sleep. Now the network icon has an exclamation mark and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:00.
Find Us