Windows 10: Windows can't connect to home Wi-Fi but other devices can Solved

  1.    01 Dec 2017 #1

    Windows can't connect to home Wi-Fi but other devices can


    I have my home Wi-Fi and then my ISP provides a backup Wi-Fi that lets me uses other modems (other people's) from the same ISP to have a backup connection when needed. Yesterday I switched from my home's to the backup to test some things but then I wasn't able to reconnect to my home Wi-Fi at all (I believe my home Wi-Fi was having some issues yesterday right around the time I was testing things since none of my others devices could connect to it). I thought it was no big deal, just some connection issues that'll eventually be fixed.
    Comes today and these connection issues seem fixed on every device except my computer, my home Wi-Fi wasn't showing up at all but my backup Wi-Fi still works fine.
    Tried resetting the modem multiple times but no luck, every other device still works except my computer.
    Tried disabling/uninstalling my network adapters on device manager and this seemed to let me view my home Wi-Fi temporarily but when I tried to connect to it it'd try to connect for a few seconds but after that the list of available connections would go empty and the Wi-Fi symbol on the taskbar would turn into the one you get when you disable the network adapter, then a couple seconds later the symbol would go back to normal and it'd say the connection failed.
    Having the device manager open while trying to connect would also make it blink when the symbol changed (as if the adapter potentially crashed or something I guess).
    I then tried to do a full reset of my settings and network adapters (Settings > Network > Status > Reset Network) but still, home Wi-Fi isn't showing up, tried to repeat the above and got the same result with it appearing to disable the network adapter while it was trying to connect.
    Oh, also tried to add the connection manually but again, no luck.

    My network adapter is Qualcomm Atheros QCA9377.

    Appreciate any help, thanks.
      My ComputerSystem Spec

  2.    01 Dec 2017 #2

    I seem to have been able to connect by downloading and installing Wireless LAN_Intel_18.33.0.1_W10x64_A which I found on my laptop make's website (also attempted to install Wireless LAN_Atheros_12.0.0.191_W10x64_A but no luck).
    I am currently unsure if the problem has been fully fixed however as when I tried to connect after installing that the same issue with the adapter seeming to get disabled happened but it did so before asking for the password to the Wi-Fi, and when it got enabled the field with the password showed up and I was able to connect that way.

    And after restarting the laptop it seems it's still connected just fine. I feel like I'm not entirely satisfied with this solution as it seems a bit odd, especially given how the problem just appeared randomly but it seems to be fixed for now so I'll mark this as solved.
    If anyone has any comments or ideas, again, I'd appreciate them.
      My ComputerSystem Spec


 

Related Threads
Cannot Pair/Connect Bluetooth Devices in Drivers and Hardware
^Title. Headphones work fine while connecting to other devices, (phone, a different computer)However, this computer can't connect to any bluetooth devices. Upon running Toubleshoot>Bluetooth Devices, It tells me that the bluetooth radio wasn't...
Hi guys , as the title says I am not able to connect remotely to windows 10 home edition even disabling the target pc firewall. I have no issues in connecting to other pcs.i am connecting on a local area network using windows in built remote...
Hi, Using Windows 10 I've set up a VPN server at home. The idea is not to hide my IP, but to use my own network IP when at work etc. Hence I do not use VPN providers or similar. I think it uses PPTP (?) connection. After upgrading my iPad and...
Hi, I have asked this before, but didn't get any answer, so I will ask again. How can I disable WPD devices Write Access on Windows Home Editions because there is no GPEdit.msc on Windows Home Editions. Thank you.
My main desktop PC is Win10 I have another Win10 system, a Laptop Then I have two Linux systems And an Android Tablet with a File Manager App. The Win 10 systems appear in their respective Network Maps, but I cannot open them: In my Main...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:10.
Find Us