Windows 10: W10 pro update 1709 shares cannot be accesed FROM NAS Server (Samba)

  1.    22 Nov 2017 #1

    W10 pro update 1709 shares cannot be accesed FROM NAS Server (Samba)


    Hi folks

    it's definitely a windows update problem with version 1709.

    FROM Nas server -- cannot access windows shares vua samba anymore -- says timeout on xxxxx - and this comes up immediately !!!

    other windows machines have no problem.

    Accessing the server FROM windows is OK but I need to access windows FROM the server as well (auto backups from server).

    Any suggestions folks.

    I actually didn't want this last update but some how windows set to auto update.

    version is W10 pro 1709 build 16299.64

    SAMBA on server running just fine -- TV's, phones etc can all access OK. SAMBA V4 (latest) being used on server.

    Note Windows TO server works, Windows FROM server fails. I have 2 NAS servers and same problem -old Windows works but not the latest.

    Tested also disabling BOTH sets of firewalls and Windows has all the allow remote access stuff enabled.

    Is there some type of local security policy default enabled that wasn't there before. ??

    Cheers
    jimbo
      My ComputerSystem Spec

  2.    22 Nov 2017 #2

    I think you need to accept the new certificate that is all. Like if you update a VM then RDC will fail as certitficate has changed after update of Windows version.

    For SAMBA I never had a problem - I know you always do with every upgrade - but since about Windows 8 I use this and never change it
    Code:
    #
    # /etc/fstab: static file system information
    #
    # <file system> <dir>   <type>  <options>       <dump>  <pass>
    UUID=b023985e-c449-4301-ae92-582e6d3c39b3       /               btrfs           defaults,compress              0 0
    //192.168.1.100/Downloads        /mnt/MacBook cifs credentials=/root/secret.txt,iocharset=utf8,uid=1000,gid=1000,file_mode=0777,dir_mode=0777,nounix,nofail,x-systemd.device-timeout=1 0 0
    with the "/root/secret.txt" being in plain text:
    Code:
    username=Hali
    domain=TP5
    password=xxx{whatever}xxx
      My ComputerSystem Spec

  3.    22 Nov 2017 #3

    I got the same problem with my Buffalo NAS in W10 1607 and SMB 1.0 disabled. Enabling did the job here.
    Can it be that in W10 pro 1709 build 16299.64 SMB 1.0 CIFS File sharing Support is disabled.
    https://www.theregister.co.uk/2017/0...xploited_smb1/
    Can it be that your Samba needs SMB 1.0.
    Try an Firmware update of your NAS or try to enable SMB 1.0 again in W10 1709.
      My ComputerSystem Spec

  4.    22 Nov 2017 #4

    There was also a security worry about using SMB 2 in 1709 and it was disabled by default. Perhaps that was it.

    Guest access smb2 disabled by default in windows 10

    I would say though that connecting using CIFS it has NEVER been a problem for me connecting from Linux to Windows. Jimbo seems to get a problem every upgrade so perhaps his security requirements are more extreme than mine.

    I'm pretty lax - I even store my password in plain text (although root only access).
      My ComputerSystem Spec

  5.    22 Nov 2017 #5

    I have had strange issues accessing Samba shares on C drive from android that worked fin before 16299. I can access share on non OS drives without any issues. Interestingly, I can access public folders on c drive ok but no others. See this post

    Cannot access C drive from android devices since upgraded to 16299 - Windows 10 Forums

    Pretty sure there is a bug somewhere. Can you access non OS drives?
      My ComputerSystem Spec

  6.    22 Nov 2017 #6

    cereberus said: View Post
    Can you access non OS drives?
    Now you mention it I've not tried. I only share Downloads from Windows which I have on C. I'll try sharing another partition or drive and see.
      My ComputerSystem Spec

  7.   My ComputerSystem Spec

  8.    12 Dec 2017 #8

    Try this
    Run gpedit.msc
    Computer Configuration>Administrative Templates>Network>Lanman Workstation
    Enable insecure guest logon = enabled
    The 1709 update has introduced a policy on Pro and higher version to disable the guest account by default
      My ComputerSystem Spec


 

Related Threads
I have a peculiar Samba share issue. I was running Windows 7 on my laptop. I have a file server running Linux and Samba. When I open the Network icon in Windows 7, I see my server there and I can open it and access the associated folder shares. ...
I have found with Windows 10 that if I make a drive or directory available for use over a lan, using standard windows shares, and then try to copy a file to or from an android device, it is very slow, and at best I get 4 Mbits/second. However, if...
Hello everyone, I'm having this very annoying issue with samba shares. The server is running on a CentOS 7 distro with samba-4.1.12-23.el7_1.x86_64. My Windows 10 build is 10240. The shares are visible but when I try to connect it waits a...
I have a Linux server with file shares on my local network. My problem is with writing data to those shares from my Windows 10 Home PC. The problem manifests with data writes that are exceedingly slow (not greater than 300 kB/sec) and generally...
Solved Can't access Samba shares on 10049 in Network and Sharing
I just reinstalled after I was having issues. Everything seems to be working smoothly, except that I can't access the shares on all but one of my other computers for some reason. Most devices that aren't running either some flavor of Windows or...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:39.
Find Us