Super high speed internet but actual browser speed is terrible


  1. Posts : 71
    Duh Windows 9
       #1

    Super high speed internet but actual browser speed is terrible


    My desktop has a external network card that connects at 520 mb, using comcast internet with a dl of 150 and ul of 30
    I tried chrome and internet explorer and they both are quite laggy, my laptop works just fine

    The desktop is actually closer to the router than my laptop is

    Where should i start troubleshooting
      My Computer

  2. dalchina's Avatar
    Posts : 31,310
    Win 10 Pro (1903)
       #2

    Hi, do both use the same DNS?
    Is there a difference in ping results to the same server?

    When you're using your browser is general resource use on your desktop low?

    Is your laptop using Wifi, and your desktop ethernet? If so, how does the laptop perform using an ethernet connection?

    If you try a network speed test, are the results similar?
      My Computers


  3. Posts : 71
    Duh Windows 9
    Thread Starter
       #3

    Same DNS, same ping, no other resources aside from browser, both are on wifi 5hz, speed test is about the same for both
      My Computer

  4. dalchina's Avatar
    Posts : 31,310
    Win 10 Pro (1903)
       #4

    History: was the desktop behaving ok until recently.. i.e. did something change?
    If so, has there been an upgrade or update (including driver)?

    What is the Windows build?
    Windows key + R, winver
      My Computers

  5. dencal's Avatar
    Posts : 3,059
    W10 Pro + W10 Preview
       #5

    Open CMD (ADMIN) and copy paste the following....then restart computer.

    netsh winsock reset
      My Computers


  6. Posts : 71
    Duh Windows 9
    Thread Starter
       #6

    dalchina said:
    History: was the desktop behaving ok until recently.. i.e. did something change?
    If so, has there been an upgrade or update (including driver)?

    What is the Windows build?
    Windows key + R, winver

    I havent installed or changed anything in the machine, it does have automatic updates, i just checked and the wireless driver was updated 2 mths ago, not sure how i missed that before

    Right at this moment internet is working fine, but if problem happens again i will roll back driver
    Build is 15063 674 version 1703
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:47.
Find Us




Windows 10 Forums